summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-10-18 15:41:38 +0000
committerJeroen Roovers <jer@gentoo.org>2013-10-18 15:41:38 +0000
commit9a330fff9dc16048f0828dcef90213d031b778fc (patch)
tree6203c1cef9758e083403c272c89b89109fe8b02f /sys-boot
parenttest suite dep added, test phase code corrected, re-invoked (diff)
downloadgentoo-2-9a330fff9dc16048f0828dcef90213d031b778fc.tar.gz
gentoo-2-9a330fff9dc16048f0828dcef90213d031b778fc.tar.bz2
gentoo-2-9a330fff9dc16048f0828dcef90213d031b778fc.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/palo/ChangeLog8
-rw-r--r--sys-boot/palo/palo-1.91.ebuild4
-rw-r--r--sys-boot/palo/palo-1.92.ebuild47
3 files changed, 56 insertions, 3 deletions
diff --git a/sys-boot/palo/ChangeLog b/sys-boot/palo/ChangeLog
index c9cae5854e66..91c17a7068f0 100644
--- a/sys-boot/palo/ChangeLog
+++ b/sys-boot/palo/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-boot/palo
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/palo/ChangeLog,v 1.39 2013/07/21 14:13:39 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/palo/ChangeLog,v 1.40 2013/10/18 15:41:38 jer Exp $
+
+*palo-1.92 (18 Oct 2013)
+
+ 18 Oct 2013; Jeroen Roovers <jer@gentoo.org> +palo-1.92.ebuild,
+ palo-1.91.ebuild:
+ Version bump.
21 Jul 2013; Jeroen Roovers <jer@gentoo.org> palo-9999.ebuild:
Remove patches that have been applied upstream.
diff --git a/sys-boot/palo/palo-1.91.ebuild b/sys-boot/palo/palo-1.91.ebuild
index 823af8ed9396..150c50c21ebf 100644
--- a/sys-boot/palo/palo-1.91.ebuild
+++ b/sys-boot/palo/palo-1.91.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/palo/palo-1.91.ebuild,v 1.1 2013/07/18 15:37:25 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/palo/palo-1.91.ebuild,v 1.2 2013/10/18 15:41:38 jer Exp $
EAPI=5
@@ -12,7 +12,7 @@ SRC_URI="http://dev.gentoo.org/~jer/${P/-/_}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="-* ~hppa"
+KEYWORDS="-* hppa"
IUSE=""
src_prepare() {
diff --git a/sys-boot/palo/palo-1.92.ebuild b/sys-boot/palo/palo-1.92.ebuild
new file mode 100644
index 000000000000..5c2217ee5a7f
--- /dev/null
+++ b/sys-boot/palo/palo-1.92.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/palo/palo-1.92.ebuild,v 1.1 2013/10/18 15:41:38 jer Exp $
+
+EAPI=5
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="PALO : PArisc Linux Loader"
+HOMEPAGE="http://parisc-linux.org/"
+SRC_URI="http://dev.gentoo.org/~jer/${P/-/_}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~hppa"
+IUSE=""
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-9999-toolchain.patch
+ sed -i palo/Makefile -e '/^LDFLAGS=/d' || die
+}
+
+src_compile() {
+ local target
+ for target in '-C palo' '-C ipl' 'MACHINE=parisc iplboot'; do
+ emake AR=$(tc-getAR) CC=$(tc-getCC) LD=$(tc-getLD) ${target}
+ done
+}
+
+src_install() {
+ into /
+ dosbin palo/palo
+
+ doman palo.8
+ dohtml README.html
+ dodoc palo.conf
+
+ insinto /etc
+ doins "${FILESDIR}"/palo.conf
+
+ insinto /usr/share/palo
+ doins iplboot
+
+ insinto /etc/kernel/postinst.d/
+ INSOPTIONS="-m 0744" doins "${FILESDIR}"/99palo
+}