summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuy Martin <gmsoft@gentoo.org>2004-05-17 17:15:46 +0000
committerGuy Martin <gmsoft@gentoo.org>2004-05-17 17:15:46 +0000
commitc1a46ace2493c8b5236c684a9026ad1cae9d78af (patch)
tree10f09af9013f39bd2e39c9c2b19248399290abf8 /sys-boot
parentInitial import. Ebuild submitted by Martin Diers <martin@diers.us>. Bug #4668... (diff)
downloadgentoo-2-c1a46ace2493c8b5236c684a9026ad1cae9d78af.tar.gz
gentoo-2-c1a46ace2493c8b5236c684a9026ad1cae9d78af.tar.bz2
gentoo-2-c1a46ace2493c8b5236c684a9026ad1cae9d78af.zip
Removed the use of HOME and TERM variable in kernel command line to save some chars.
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/palo/ChangeLog7
-rw-r--r--sys-boot/palo/files/palo-remove-HOME-TERM.patch95
-rw-r--r--sys-boot/palo/files/palo.conf2
-rw-r--r--sys-boot/palo/palo-1.5_pre20040515.ebuild7
4 files changed, 108 insertions, 3 deletions
diff --git a/sys-boot/palo/ChangeLog b/sys-boot/palo/ChangeLog
index 475c8223151b..59714f753e6b 100644
--- a/sys-boot/palo/ChangeLog
+++ b/sys-boot/palo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/palo
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/palo/ChangeLog,v 1.5 2004/05/15 22:46:37 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/palo/ChangeLog,v 1.6 2004/05/17 17:15:46 gmsoft Exp $
+
+ 17 May 2004; Guy Martin <gmsoft@gentoo.org> palo-1.5_pre20040515.ebuild,
+ files/palo-remove-HOME-TERM.patch, files/palo.conf:
+ Removed the use of HOME and TERM variable in kernel command line to save some
+ chars.
*palo-1.5_pre20040515 (15 May 2004)
diff --git a/sys-boot/palo/files/palo-remove-HOME-TERM.patch b/sys-boot/palo/files/palo-remove-HOME-TERM.patch
new file mode 100644
index 000000000000..0e5221addb2a
--- /dev/null
+++ b/sys-boot/palo/files/palo-remove-HOME-TERM.patch
@@ -0,0 +1,95 @@
+diff -uNr palo.orig/Makefile palo/Makefile
+--- palo.orig/Makefile 2004-05-17 13:39:00.431714000 +0200
++++ palo/Makefile 2004-05-17 13:39:45.221714000 +0200
+@@ -56,7 +56,7 @@
+ ROOT=root=/dev/nfs nfsroot=${NFSROOT} ip=bootp
+ endif
+
+-CMDLINE = 0/vmlinux HOME=/ TERM=linux $(ROOT) $(EISAIRQ) $(CONSOLE)
++CMDLINE = 0/vmlinux $(ROOT) $(EISAIRQ) $(CONSOLE)
+
+ all: makepalo README palo.conf
+
+diff -uNr palo.orig/README palo/README
+--- palo.orig/README 2004-05-17 13:39:00.431714000 +0200
++++ palo/README 2004-05-17 13:40:09.341714000 +0200
+@@ -42,13 +42,13 @@
+ files to it, unmount.
+ * Use palo to make the disk bootable:
+ $ palo \
+- -c "5/vmlinux HOME=/ TERM=linux console=tty" \
++ -c "5/vmlinux console=tty" \
+ -k path/to/vmlinux \
+ -I /dev/your-disk
+
+ On a self-hosted system, you can accomplish the same thing by placing
+ the following into /etc/palo.conf:
+- --commandline=5/vmlinux HOME=/ TERM=linux console=tty
++ --commandline=5/vmlinux console=tty
+ --recoverykernel=/boot/vmlinux
+ --init-partitioned=/dev/your-disk
+
+diff -uNr palo.orig/README.html palo/README.html
+--- palo.orig/README.html 2004-05-17 13:39:00.431714000 +0200
++++ palo/README.html 2004-05-17 13:40:27.801714000 +0200
+@@ -52,13 +52,13 @@
+ <p><li>Use <i>palo</i> to make the disk bootable:
+ <pre>
+ $ palo \
+- -c "5/vmlinux HOME=/ TERM=linux console=tty" \
++ -c "5/vmlinux console=tty" \
+ -k path/to/vmlinux \
+ -I /dev/your-disk</pre>
+ <center><table border=1 bgcolor=yellow width=80%><tr><td>
+ On a self-hosted system, you can accomplish the same thing by placing
+ the following into <tt>/etc/palo.conf</tt>:
+-<pre>--commandline=5/vmlinux HOME=/ TERM=linux console=tty
++<pre>--commandline=5/vmlinux console=tty
+ --recoverykernel=/boot/vmlinux
+ --init-partitioned=/dev/your-disk</pre>
+ and running <i>palo</i>.
+diff -uNr palo.orig/ipl/ipl.c palo/ipl/ipl.c
+--- palo.orig/ipl/ipl.c 2004-05-17 13:39:00.491714000 +0200
++++ palo/ipl/ipl.c 2004-05-17 13:39:19.681714000 +0200
+@@ -481,9 +481,6 @@
+ chk_strcat(commandline, "ttyB0", CMDLINELEN, &ok);
+ else
+ chk_strcat(commandline, "ttyS0", CMDLINELEN, &ok);
+-
+- if (strstr(commandline, " TERM=") == 0)
+- chk_strcat(commandline, " TERM=vt102", CMDLINELEN, &ok);
+ }
+ else
+ {
+@@ -519,8 +516,6 @@
+ }
+ if (strstr(commandline, " sti_font=") == 0)
+ chk_strcat(commandline, " sti_font=VGA8x16", CMDLINELEN, &ok);
+- if (strstr(commandline, " TERM=") == 0)
+- chk_strcat(commandline, " TERM=linux", CMDLINELEN, &ok);
+ }
+ }
+
+diff -uNr palo.orig/palo.conf palo/palo.conf
+--- palo.orig/palo.conf 2004-05-17 13:39:00.431714000 +0200
++++ palo/palo.conf 2004-05-17 13:41:01.541714000 +0200
+@@ -8,7 +8,7 @@
+ # recovery kernel, and the default dynamically-booted kernel.
+ # --recoverykernel=/boot/vmlinux
+ # --init-partitioned=/dev/sda
+-# --commandline=3/boot/vmlinux HOME=/ TERM=linux root=/dev/sda3
++# --commandline=3/boot/vmlinux root=/dev/sda3
+
+ #
+ #Usage: palo [options]
+@@ -18,8 +18,8 @@
+ # Maximum 127 characters.
+ # -k, --recoverykernel=path to recovery kernel (perhaps /boot/vmlinux)
+ # -b, --bootloader=path to boot loader
+- Defaults to /usr/share/palo/iplboot -- you usually don't
+- need to use -b or --bootloader
++# Defaults to /usr/share/palo/iplboot -- you usually don't
++# need to use -b or --bootloader
+ # -r, --ramdisk=path to initial ramdisk image
+ # -I, --init-partitioned=partitioned device or file
+ # Initialize a pre-partitioned device, usually a hard disk.
diff --git a/sys-boot/palo/files/palo.conf b/sys-boot/palo/files/palo.conf
index 25ffaa24052d..7fb1fee1c820 100644
--- a/sys-boot/palo/files/palo.conf
+++ b/sys-boot/palo/files/palo.conf
@@ -1,6 +1,6 @@
# Please read /usr/share/doc/palo/palo.conf for more info
---commandline=2/vmlinux root=/dev/sda3 HOME=/
+--commandline=2/vmlinux root=/dev/sda3
--init-partitioned=/dev/sda
#Uncomment this if you want a rescue kernel
diff --git a/sys-boot/palo/palo-1.5_pre20040515.ebuild b/sys-boot/palo/palo-1.5_pre20040515.ebuild
index 4c7eb1022223..ff7d524f4c34 100644
--- a/sys-boot/palo/palo-1.5_pre20040515.ebuild
+++ b/sys-boot/palo/palo-1.5_pre20040515.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/palo/palo-1.5_pre20040515.ebuild,v 1.1 2004/05/15 22:46:37 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/palo/palo-1.5_pre20040515.ebuild,v 1.2 2004/05/17 17:15:46 gmsoft Exp $
MY_V=${PV/_pre/-CVS}
DESCRIPTION="PALO : PArisc Linux Loader"
@@ -17,6 +17,11 @@ PROVIDE="virtual/bootloader"
S=${WORKDIR}/palo
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PN}-remove-HOME-TERM.patch
+}
+
src_compile() {
emake -C palo CFLAGS="${CFLAGS} -I../include -I../lib" || die
emake -C ipl CFLAGS="${CFLAGS} -I. -I../lib -I../include -fwritable-strings -mdisable-fpregs -Wall" || die