summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-09-03 18:10:49 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-09-03 18:10:49 +0000
commitdcaf5fd6c4619ca9bdb664425aa55d99ffac630e (patch)
tree83d9f564f9e04abbc6599b40c2cf5b2a14f0b0a2 /sys-boot
parentVersion bump wrt bug 232940 (diff)
downloadgentoo-2-dcaf5fd6c4619ca9bdb664425aa55d99ffac630e.tar.gz
gentoo-2-dcaf5fd6c4619ca9bdb664425aa55d99ffac630e.tar.bz2
gentoo-2-dcaf5fd6c4619ca9bdb664425aa55d99ffac630e.zip
Version bump per bug #236554, also fix perl deps per bug 236597.
(Portage version: 2.2_rc8/cvs/Linux 2.6.27-rc1-10246-gca5de40 x86_64)
Diffstat (limited to 'sys-boot')
-rw-r--r--sys-boot/syslinux/ChangeLog7
-rw-r--r--sys-boot/syslinux/syslinux-3.71.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/sys-boot/syslinux/ChangeLog b/sys-boot/syslinux/ChangeLog
index fd0bd720544a..897f76bfabff 100644
--- a/sys-boot/syslinux/ChangeLog
+++ b/sys-boot/syslinux/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-boot/syslinux
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/ChangeLog,v 1.36 2008/08/19 12:13:05 cla Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/ChangeLog,v 1.37 2008/09/03 18:10:49 robbat2 Exp $
+
+*syslinux-3.71 (03 Sep 2008)
+
+ 03 Sep 2008; Robin H. Johnson <robbat2@gentoo.org> +syslinux-3.71.ebuild:
+ Version bump per bug #236554, also fix perl deps per bug 236597.
19 Aug 2008; Dawid Węgliński <cla@gentoo.org> syslinux-3.52.ebuild:
Add missing dev-perl/Digest-SHA1 to RDEPEND
diff --git a/sys-boot/syslinux/syslinux-3.71.ebuild b/sys-boot/syslinux/syslinux-3.71.ebuild
new file mode 100644
index 000000000000..87fdc4573b2e
--- /dev/null
+++ b/sys-boot/syslinux/syslinux-3.71.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-boot/syslinux/syslinux-3.71.ebuild,v 1.1 2008/09/03 18:10:49 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="SysLinux, IsoLinux and PXELinux bootloader"
+HOMEPAGE="http://syslinux.zytor.com/"
+SRC_URI="mirror://kernel/linux/utils/boot/syslinux/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-fs/mtools
+ dev-perl/Crypt-PasswdMD5
+ dev-perl/Digest-SHA1"
+DEPEND="${RDEPEND}
+ dev-lang/nasm"
+
+# This ebuild is a departure from the old way of rebuilding everything in syslinux
+# This departure is necessary since hpa doesn't support the rebuilding of anything other
+# than the installers.
+
+# removed all the unpack/patching stuff since we aren't rebuilding the core stuff anymore
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-3.70-nopie.patch
+ # Don't prestrip, makes portage angry
+ epatch "${FILESDIR}/${PN}-3.70-nostrip.patch"
+ rm -f gethostip #137081
+}
+
+src_compile() {
+ emake installer || die
+}
+
+src_install() {
+ emake INSTALLROOT="${D}" install || die
+ dodoc README NEWS TODO doc/*
+}