summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Zoffoli <xmerlin@gentoo.org>2008-03-17 16:31:39 +0000
committerChristian Zoffoli <xmerlin@gentoo.org>2008-03-17 16:31:39 +0000
commitfd3040e405a697ebfd7f267d0a2488a215e42b05 (patch)
treeab59b94de7906857f14a863d0f2093239a84c181 /sys-cluster/ccs
parentamd64 stable and pkgconfig dep added (bug #205439). (diff)
downloadgentoo-2-fd3040e405a697ebfd7f267d0a2488a215e42b05.tar.gz
gentoo-2-fd3040e405a697ebfd7f267d0a2488a215e42b05.tar.bz2
gentoo-2-fd3040e405a697ebfd7f267d0a2488a215e42b05.zip
Version bump. 1.0x.00 is scheduled to be removed soon.
(Portage version: 2.1.4.4)
Diffstat (limited to 'sys-cluster/ccs')
-rw-r--r--sys-cluster/ccs/ChangeLog9
-rw-r--r--sys-cluster/ccs/ccs-1.02.00-r1.ebuild14
-rw-r--r--sys-cluster/ccs/ccs-1.03.00.ebuild10
-rw-r--r--sys-cluster/ccs/ccs-1.04.00.ebuild10
-rw-r--r--sys-cluster/ccs/ccs-2.02.00.ebuild55
5 files changed, 79 insertions, 19 deletions
diff --git a/sys-cluster/ccs/ChangeLog b/sys-cluster/ccs/ChangeLog
index 1286d5334bcd..60b64be4da15 100644
--- a/sys-cluster/ccs/ChangeLog
+++ b/sys-cluster/ccs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/ccs
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ccs/ChangeLog,v 1.36 2007/10/15 14:54:45 corsair Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ccs/ChangeLog,v 1.37 2008/03/17 16:31:39 xmerlin Exp $
+
+*ccs-2.02.00 (17 Mar 2008)
+
+ 17 Mar 2008; Christian Zoffoli <xmerlin@gentoo.org> +ccs-2.02.00.ebuild:
+ Version bump. 1.0x.00 is scheduled to be removed soon.
15 Oct 2007; Markus Rothe <corsair@gentoo.org> ccs-1.03.00.ebuild:
Stable on ppc64
diff --git a/sys-cluster/ccs/ccs-1.02.00-r1.ebuild b/sys-cluster/ccs/ccs-1.02.00-r1.ebuild
index adbee0701567..98497208b733 100644
--- a/sys-cluster/ccs/ccs-1.02.00-r1.ebuild
+++ b/sys-cluster/ccs/ccs-1.02.00-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ccs/ccs-1.02.00-r1.ebuild,v 1.6 2007/03/09 10:57:12 xmerlin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ccs/ccs-1.02.00-r1.ebuild,v 1.7 2008/03/17 16:31:39 xmerlin Exp $
inherit eutils
@@ -28,8 +28,8 @@ S="${WORKDIR}/${MY_P}/${PN}"
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${WORKDIR}/${PN}-${PV}-${CVS_RELEASE}-cvs.patch || die
+ cd "${S}"
+ epatch "${WORKDIR}"/${PN}-${PV}-${CVS_RELEASE}-cvs.patch || die
}
src_compile() {
@@ -38,8 +38,8 @@ src_compile() {
}
src_install() {
- emake DESTDIR=${D} install || die "install problem"
+ emake DESTDIR="${D}" install || die "install problem"
- newinitd ${FILESDIR}/${PN}d.rc ${PN}d || die
- newconfd ${FILESDIR}/${PN}d.conf ${PN}d || die
+ newinitd "${FILESDIR}"/${PN}d.rc ${PN}d || die
+ newconfd "${FILESDIR}"/${PN}d.conf ${PN}d || die
}
diff --git a/sys-cluster/ccs/ccs-1.03.00.ebuild b/sys-cluster/ccs/ccs-1.03.00.ebuild
index 3eae2494e56b..68043dcde005 100644
--- a/sys-cluster/ccs/ccs-1.03.00.ebuild
+++ b/sys-cluster/ccs/ccs-1.03.00.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ccs/ccs-1.03.00.ebuild,v 1.5 2007/10/15 14:54:45 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ccs/ccs-1.03.00.ebuild,v 1.6 2008/03/17 16:31:39 xmerlin Exp $
CLUSTER_RELEASE="1.03.00"
MY_P="cluster-${CLUSTER_RELEASE}"
@@ -26,8 +26,8 @@ src_compile() {
}
src_install() {
- emake DESTDIR=${D} install || die "install problem"
+ emake DESTDIR="${D}" install || die "install problem"
- newinitd ${FILESDIR}/${PN}d.rc ${PN}d || die
- newconfd ${FILESDIR}/${PN}d.conf ${PN}d || die
+ newinitd "${FILESDIR}"/${PN}d.rc ${PN}d || die
+ newconfd "${FILESDIR}"/${PN}d.conf ${PN}d || die
}
diff --git a/sys-cluster/ccs/ccs-1.04.00.ebuild b/sys-cluster/ccs/ccs-1.04.00.ebuild
index a60804cb1502..29e4d885179c 100644
--- a/sys-cluster/ccs/ccs-1.04.00.ebuild
+++ b/sys-cluster/ccs/ccs-1.04.00.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ccs/ccs-1.04.00.ebuild,v 1.1 2007/03/09 10:57:12 xmerlin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ccs/ccs-1.04.00.ebuild,v 1.2 2008/03/17 16:31:39 xmerlin Exp $
CLUSTER_RELEASE="1.04.00"
MY_P="cluster-${CLUSTER_RELEASE}"
@@ -26,8 +26,8 @@ src_compile() {
}
src_install() {
- emake DESTDIR=${D} install || die "install problem"
+ emake DESTDIR="${D}" install || die "install problem"
- newinitd ${FILESDIR}/${PN}d.rc ${PN}d || die
- newconfd ${FILESDIR}/${PN}d.conf ${PN}d || die
+ newinitd "${FILESDIR}"/${PN}d.rc ${PN}d || die
+ newconfd "${FILESDIR}"/${PN}d.conf ${PN}d || die
}
diff --git a/sys-cluster/ccs/ccs-2.02.00.ebuild b/sys-cluster/ccs/ccs-2.02.00.ebuild
new file mode 100644
index 000000000000..4a023fa33c21
--- /dev/null
+++ b/sys-cluster/ccs/ccs-2.02.00.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ccs/ccs-2.02.00.ebuild,v 1.1 2008/03/17 16:31:39 xmerlin Exp $
+
+inherit eutils versionator
+
+CLUSTER_RELEASE="${PV}"
+MY_P="cluster-${CLUSTER_RELEASE}"
+
+MAJ_PV="$(get_major_version)"
+MIN_PV="$(get_version_component_range 2).$(get_version_component_range 3)"
+
+DESCRIPTION="cluster configuration system to manage the cluster config file"
+HOMEPAGE="http://sources.redhat.com/cluster/"
+SRC_URI="ftp://sources.redhat.com/pub/cluster/releases/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="=sys-cluster/cman-lib-${CLUSTER_RELEASE}*"
+DEPEND="${RDEPEND}
+ dev-libs/libxml2
+ sys-libs/zlib"
+
+S="${WORKDIR}/${MY_P}/${PN}"
+
+src_compile() {
+ (cd "${WORKDIR}"/${MY_P};
+ ./configure \
+ --cc=$(tc-getCC) \
+ --cflags="-Wall" \
+ --disable_kernel_check \
+ --release_major="$MAJ_PV" \
+ --release_minor="$MIN_PV" \
+ --cmanlibdir=/usr/lib \
+ --cmanincdir=/usr/include \
+ ) || die "configure problem"
+
+ # fix the manual pages have executable bit
+ sed -i -e '
+ /\tinstall -d/s/install/& -m 0755/; t
+ /\tinstall/s/install/& -m 0644/' \
+ man/Makefile
+
+ #rm -f "${S}"/lib/log.c || die
+
+ emake clean || die "clean problem"
+ emake || die "compile problem"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install problem"
+}