summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2013-05-09 21:05:40 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2013-05-09 21:05:40 +0000
commit50854a6aa1790b0d1f40d6f56e5c97d0d5735cf3 (patch)
tree0e8b97b9a6a390b578aafc5296df2310e7ed0490 /sys-cluster/ceph
parentVersion bump, drop old (diff)
downloadgentoo-2-50854a6aa1790b0d1f40d6f56e5c97d0d5735cf3.tar.gz
gentoo-2-50854a6aa1790b0d1f40d6f56e5c97d0d5735cf3.tar.bz2
gentoo-2-50854a6aa1790b0d1f40d6f56e5c97d0d5735cf3.zip
Version bump & clean up
(Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key F82F92E6)
Diffstat (limited to 'sys-cluster/ceph')
-rw-r--r--sys-cluster/ceph/ChangeLog8
-rw-r--r--sys-cluster/ceph/ceph-0.61.1.ebuild (renamed from sys-cluster/ceph/ceph-0.60-r1.ebuild)8
-rw-r--r--sys-cluster/ceph/files/ceph-0.60-mds_sessionmap.patch29
3 files changed, 9 insertions, 36 deletions
diff --git a/sys-cluster/ceph/ChangeLog b/sys-cluster/ceph/ChangeLog
index 9de15d7bf9f9..d9cc37464930 100644
--- a/sys-cluster/ceph/ChangeLog
+++ b/sys-cluster/ceph/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/ceph
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ChangeLog,v 1.37 2013/04/12 10:21:14 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ChangeLog,v 1.38 2013/05/09 21:05:40 alexxy Exp $
+
+*ceph-0.61.1 (09 May 2013)
+
+ 09 May 2013; Alexey Shvetsov <alexxy@gentoo.org> +ceph-0.61.1.ebuild,
+ -ceph-0.60-r1.ebuild, -files/ceph-0.60-mds_sessionmap.patch:
+ Version bump & clean up
*ceph-0.60-r1 (12 Apr 2013)
diff --git a/sys-cluster/ceph/ceph-0.60-r1.ebuild b/sys-cluster/ceph/ceph-0.61.1.ebuild
index 1307fa70b2d9..ff88c61eebb3 100644
--- a/sys-cluster/ceph/ceph-0.60-r1.ebuild
+++ b/sys-cluster/ceph/ceph-0.61.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ceph-0.60-r1.ebuild,v 1.1 2013/04/12 10:21:14 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ceph/ceph-0.61.1.ebuild,v 1.1 2013/05/09 21:05:40 alexxy Exp $
EAPI=5
@@ -31,8 +31,8 @@ CDEPEND="
dev-libs/fcgi
dev-libs/libaio
dev-libs/libedit
- dev-libs/crypto++
dev-libs/leveldb
+ dev-libs/crypto++
sys-apps/keyutils
fuse? ( sys-fs/fuse )
libatomic? ( dev-libs/libatomic_ops )
@@ -55,10 +55,6 @@ RDEPEND="${CDEPEND}
STRIP_MASK="/usr/lib*/rados-classes/*"
-PATCHES=(
- "${FILESDIR}/${P}-mds_sessionmap.patch"
-)
-
src_prepare() {
if [ ! -z ${PATCHES[@]} ]; then
epatch ${PATCHES[@]}
diff --git a/sys-cluster/ceph/files/ceph-0.60-mds_sessionmap.patch b/sys-cluster/ceph/files/ceph-0.60-mds_sessionmap.patch
deleted file mode 100644
index 65cd8caae930..000000000000
--- a/sys-cluster/ceph/files/ceph-0.60-mds_sessionmap.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-commit 01f99c9d6cc0c3494bcb81e914b28bcc4ca2f7a1
-Author: Yan, Zheng <zheng.z.yan@intel.com>
-Date: Fri Apr 5 13:58:36 2013 +0800
-
- mds: fix session_info_t decoding
-
- commit 0bcf2ac081 changes session_info_t's format, but there is
- a typo in the code that decodes old format. We also need to
- decode struct_v == 1 in the same way as struct_v == 2.
-
- Signed-off-by: Yan, Zheng <zheng.z.yan@intel.com>
- Signed-off-by: Greg Farnum <greg@inktank.com>
-
-diff --git a/src/mds/mdstypes.cc b/src/mds/mdstypes.cc
-index ad4a71a..b1ce640 100644
---- a/src/mds/mdstypes.cc
-+++ b/src/mds/mdstypes.cc
-@@ -541,9 +541,9 @@ void session_info_t::decode(bufferlist::iterator& p)
- {
- DECODE_START_LEGACY_COMPAT_LEN(3, 2, 2, p);
- ::decode(inst, p);
-- if (struct_v == 2) {
-+ if (struct_v <= 2) {
- set<tid_t> s;
-- ::decode(completed_requests, p);
-+ ::decode(s, p);
- while (!s.empty()) {
- completed_requests[*s.begin()] = inodeno_t();
- s.erase(s.begin());