summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Zoffoli <xmerlin@gentoo.org>2006-08-30 12:49:02 +0000
committerChristian Zoffoli <xmerlin@gentoo.org>2006-08-30 12:49:02 +0000
commit9f126a1d9b5edefdf93b7500de589986c0659575 (patch)
tree19f3adcccc19c2cce5ca1b5d0e7e66babb7cc51c /sys-cluster/cman/cman-1.03.00.ebuild
parentppc stable, bug #141920 (diff)
downloadgentoo-2-9f126a1d9b5edefdf93b7500de589986c0659575.tar.gz
gentoo-2-9f126a1d9b5edefdf93b7500de589986c0659575.tar.bz2
gentoo-2-9f126a1d9b5edefdf93b7500de589986c0659575.zip
Version bump.
(Portage version: 2.1-r1)
Diffstat (limited to 'sys-cluster/cman/cman-1.03.00.ebuild')
-rw-r--r--sys-cluster/cman/cman-1.03.00.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-cluster/cman/cman-1.03.00.ebuild b/sys-cluster/cman/cman-1.03.00.ebuild
new file mode 100644
index 000000000000..bc4cb68a5268
--- /dev/null
+++ b/sys-cluster/cman/cman-1.03.00.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/cman/cman-1.03.00.ebuild,v 1.1 2006/08/30 12:49:02 xmerlin Exp $
+
+inherit eutils
+
+MY_P="cluster-${PV}"
+
+DESCRIPTION="general-purpose symmetric cluster manager"
+HOMEPAGE="http://sources.redhat.com/cluster/"
+SRC_URI="ftp://sources.redhat.com/pub/cluster/releases/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND=">=sys-cluster/ccs-1.03.00
+ >=sys-cluster/cman-headers-1.03.00"
+
+RDEPEND="virtual/libc"
+
+S="${WORKDIR}/${MY_P}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/cman-1.03.00-compile-hack.patch || die
+}
+
+
+src_compile() {
+ ./configure || die
+ emake -j1 || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+
+ newinitd ${FILESDIR}/${PN}.rc ${PN} || die
+ newconfd ${FILESDIR}/${PN}.conf ${PN} || die
+}