summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2012-09-04 03:34:04 +0000
committerJustin Bronder <jsbronder@gentoo.org>2012-09-04 03:34:04 +0000
commitd96ac952e9943efbb68de4d0f3968df625be3879 (patch)
tree0e4e3eed67cd562dc30e85352a8ed5467f720227 /sys-cluster/ganglia-web/ganglia-web-3.5.2.ebuild
parentStable ppc64, bug #433263 (diff)
downloadgentoo-2-d96ac952e9943efbb68de4d0f3968df625be3879.tar.gz
gentoo-2-d96ac952e9943efbb68de4d0f3968df625be3879.tar.bz2
gentoo-2-d96ac952e9943efbb68de4d0f3968df625be3879.zip
Add sys-cluster/ganglia-web to match upstream development. Resolves #428776
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster/ganglia-web/ganglia-web-3.5.2.ebuild')
-rw-r--r--sys-cluster/ganglia-web/ganglia-web-3.5.2.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sys-cluster/ganglia-web/ganglia-web-3.5.2.ebuild b/sys-cluster/ganglia-web/ganglia-web-3.5.2.ebuild
new file mode 100644
index 000000000000..53a90f4ec7ea
--- /dev/null
+++ b/sys-cluster/ganglia-web/ganglia-web-3.5.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/ganglia-web/ganglia-web-3.5.2.ebuild,v 1.1 2012/09/04 03:34:04 jsbronder Exp $
+
+EAPI=4
+WEBAPP_MANUAL_SLOT="yes"
+inherit webapp eutils
+
+DESCRIPTION="Web frontend for sys-cluster/ganglia"
+HOMEPAGE="http://ganglia.sourceforge.net"
+SRC_URI="mirror://sourceforge/ganglia/${PN}/${PV}/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="vhosts"
+
+DEPEND="net-misc/rsync"
+RDEPEND="
+ ${DEPEND}
+ ${WEBAPP_DEPEND}
+ >=sys-cluster/ganglia-3.3.7[-minimal]
+ dev-lang/php[gd,xml,ctype,cgi]
+ media-fonts/dejavu"
+
+src_configure() {
+ return 0
+}
+
+src_compile() {
+ return 0
+}
+
+src_install() {
+ webapp_src_preinst
+ cd "${S}"
+ emake \
+ GDESTDIR="${MY_HTDOCSDIR}" \
+ DESTDIR="${D}" \
+ APACHE_USER=nobody \
+ install || die
+ webapp_configfile "${MY_HTDOCSDIR}"/conf_default.php
+ webapp_src_install
+
+ keepdir /var/lib/ganglia/rrds
+ fowners nobody:nobody /var/lib/ganglia/rrds
+ fowners -R nobody:nobody /var/lib/ganglia/dwoo
+ fperms -R 777 /var/lib/ganglia/dwoo
+
+ dodoc AUTHORS README TODO || die
+}