summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-11-18 16:39:00 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-11-18 16:39:00 +0000
commit648f97d43c8319b5e24cde97f2c6bb1be72afdd6 (patch)
treead5c023600a4d15dc2276c20e78af370b7d9d3c2 /sys-cluster/heartbeat/files
parentAdding web documentation, bug #293608 (diff)
downloadgentoo-2-648f97d43c8319b5e24cde97f2c6bb1be72afdd6.tar.gz
gentoo-2-648f97d43c8319b5e24cde97f2c6bb1be72afdd6.tar.bz2
gentoo-2-648f97d43c8319b5e24cde97f2c6bb1be72afdd6.zip
Non-maintainer commit. Fix building with _FORTIFY_SOURCE=2 and recent gnutls wrt #285305. The bug has also -Wl,--as-needed patch which should be applied to Makefile.am instead of Makefile.in, so leaving it out, instead using append-ldflags $(no-as-needed) so that we have something that actually compiles.
(Portage version: 2.2_rc49/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster/heartbeat/files')
-rw-r--r--sys-cluster/heartbeat/files/heartbeat-2.0.8-glibc.patch14
1 files changed, 14 insertions, 0 deletions
diff --git a/sys-cluster/heartbeat/files/heartbeat-2.0.8-glibc.patch b/sys-cluster/heartbeat/files/heartbeat-2.0.8-glibc.patch
new file mode 100644
index 000000000000..9e226de533c9
--- /dev/null
+++ b/sys-cluster/heartbeat/files/heartbeat-2.0.8-glibc.patch
@@ -0,0 +1,14 @@
+diff -ur heartbeat-2.0.8.orig/lib/clplumbing/cl_msg.c heartbeat-2.0.8/lib/clplumbing/cl_msg.c
+--- heartbeat-2.0.8.orig/lib/clplumbing/cl_msg.c 2007-01-12 04:57:07.000000000 +0200
++++ heartbeat-2.0.8/lib/clplumbing/cl_msg.c 2009-11-18 18:21:18.000000000 +0200
+@@ -145,8 +145,8 @@
+ cl_log(LOG_ERR, "%s: filename is NULL", __FUNCTION__);
+ return -1;
+ }
+-
+- return open(filename, O_WRONLY|O_CREAT|O_APPEND);
++ // see http://hg.linux-ha.org/lha-2.1/rev/148fb2e06d1c
++ return open(filename, O_WRONLY|O_CREAT|O_APPEND, 0644);
+
+ }
+