summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2008-03-06 20:04:24 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2008-03-06 20:04:24 +0000
commit7c8a02e83269eff1b7caaa27438ffa4a2d2d20b3 (patch)
tree615d2a77ce20e7c3b8bf796d46738491132b5c18 /sys-cluster/heartbeat/heartbeat-2.0.8.ebuild
parentI'm sure somebody will laugh at me for this, but running through ekeyword to ... (diff)
downloadgentoo-2-7c8a02e83269eff1b7caaa27438ffa4a2d2d20b3.tar.gz
gentoo-2-7c8a02e83269eff1b7caaa27438ffa4a2d2d20b3.tar.bz2
gentoo-2-7c8a02e83269eff1b7caaa27438ffa4a2d2d20b3.zip
QA cleanup: Fixing quoting.
(Portage version: 2.1.4.4)
Diffstat (limited to 'sys-cluster/heartbeat/heartbeat-2.0.8.ebuild')
-rw-r--r--sys-cluster/heartbeat/heartbeat-2.0.8.ebuild28
1 files changed, 14 insertions, 14 deletions
diff --git a/sys-cluster/heartbeat/heartbeat-2.0.8.ebuild b/sys-cluster/heartbeat/heartbeat-2.0.8.ebuild
index 727bac992fdb..52dc5915c52e 100644
--- a/sys-cluster/heartbeat/heartbeat-2.0.8.ebuild
+++ b/sys-cluster/heartbeat/heartbeat-2.0.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/heartbeat/heartbeat-2.0.8.ebuild,v 1.10 2008/03/01 18:32:32 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/heartbeat/heartbeat-2.0.8.ebuild,v 1.11 2008/03/06 20:04:24 wolf31o2 Exp $
inherit flag-o-matic eutils
@@ -45,10 +45,10 @@ DEPEND="
src_unpack() {
unpack ${A}
- cd ${S}
- #epatch ${FILESDIR}/${P}-update-resources-failcount.patch || die
- epatch ${FILESDIR}/${P}-crm-leaks.patch || die
- epatch ${FILESDIR}/${P}-delay.patch || die
+ cd "${S}"
+ #epatch "${FILESDIR}"/${P}-update-resources-failcount.patch || die
+ epatch "${FILESDIR}"/${P}-crm-leaks.patch || die
+ epatch "${FILESDIR}"/${P}-delay.patch || die
}
src_compile() {
@@ -82,7 +82,7 @@ pkg_preinst() {
}
src_install() {
- make DESTDIR=${D} install || die
+ make DESTDIR="${D}" install || die
# heartbeat modules need these dirs
#keepdir /var/lib/heartbeat/ckpt /var/lib/heartbeat/ccm /var/lib/heartbeat
@@ -102,18 +102,18 @@ src_install() {
# if ! USE="ldirectord" then don't install it
if ! use ldirectord ; then
- rm ${D}/etc/init.d/ldirectord
- rm ${D}/etc/logrotate.d/ldirectord
- rm ${D}/etc/ha.d/resource.d/ldirectord
- rm ${D}/usr/share/man/man8/supervise-ldirectord-config.8
- rm ${D}/usr/share/man/man8/ldirectord.8
- rm ${D}/usr/sbin/ldirectord
- rm ${D}/usr/sbin/supervise-ldirectord-config
+ rm "${D}"/etc/init.d/ldirectord
+ rm "${D}"/etc/logrotate.d/ldirectord
+ rm "${D}"/etc/ha.d/resource.d/ldirectord
+ rm "${D}"/usr/share/man/man8/supervise-ldirectord-config.8
+ rm "${D}"/usr/share/man/man8/ldirectord.8
+ rm "${D}"/usr/sbin/ldirectord
+ rm "${D}"/usr/sbin/supervise-ldirectord-config
fi
dodir /var/lib/heartbeat/cores/cluster
keepdir /var/lib/heartbeat/cores/cluster
- newinitd ${FILESDIR}/heartbeat-init heartbeat
+ newinitd "${FILESDIR}"/heartbeat-init heartbeat
dodoc ldirectord/ldirectord.cf doc/*.cf doc/haresources doc/authkeys || die
if use doc ; then