summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2004-07-13 16:11:49 +0000
committerMichael Imhof <tantive@gentoo.org>2004-07-13 16:11:49 +0000
commitca417f4912ca3cd9ca68160d3ec6fef867468b45 (patch)
treeae41ea257e24e08a9cbf3c6806e06f1d1dfa18f3 /sys-cluster/lam-mpi/lam-mpi-7.0.6.ebuild
parentthe previous amd64 nvidia drivers arent exactly what i would call stable, but... (diff)
downloadgentoo-2-ca417f4912ca3cd9ca68160d3ec6fef867468b45.tar.gz
gentoo-2-ca417f4912ca3cd9ca68160d3ec6fef867468b45.tar.bz2
gentoo-2-ca417f4912ca3cd9ca68160d3ec6fef867468b45.zip
Version bumped. Closes #55047.
Diffstat (limited to 'sys-cluster/lam-mpi/lam-mpi-7.0.6.ebuild')
-rw-r--r--sys-cluster/lam-mpi/lam-mpi-7.0.6.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/sys-cluster/lam-mpi/lam-mpi-7.0.6.ebuild b/sys-cluster/lam-mpi/lam-mpi-7.0.6.ebuild
new file mode 100644
index 000000000000..13a7b246b604
--- /dev/null
+++ b/sys-cluster/lam-mpi/lam-mpi-7.0.6.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/lam-mpi/lam-mpi-7.0.6.ebuild,v 1.1 2004/07/13 16:11:49 tantive Exp $
+
+IUSE="crypt"
+
+MY_P=${P/-mpi}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="the LAM MPI parallel computing environment"
+SRC_URI="http://www.lam-mpi.org/download/files/${MY_P}.tar.bz2"
+HOMEPAGE="http://www.lam-mpi.org"
+
+DEPEND="virtual/libc"
+# we need ssh if we want to use it instead of rsh
+RDEPEND="${DEPEND}
+ crypt? ( net-misc/openssh )
+ !crypt? ( net-misc/netkit-rsh )
+ !sys-cluster/mpich"
+
+SLOT="6"
+KEYWORDS="~x86"
+LICENSE="as-is"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/romio/util/
+ sed -i "s|docdir=\"\$datadir/lam/doc\"|docdir=\"${D}/usr/share/doc/${PF}\"|" romioinstall.in
+}
+
+src_compile() {
+
+ local myconf
+
+ if use crypt; then
+ myconf="--with-rsh=ssh"
+ else
+ myconf="--with-rsh=rsh"
+ fi
+
+ econf \
+ --sysconfdir=/etc/lam-mpi \
+ --enable-shared \
+ --enable-long-long \
+ --enable-threads=posix \
+ --enable-languages=c,c++,f77 \
+ --disable-checking \
+ --enable-cstdio=stdio \
+ --with-system-zlib \
+ ${myconf} || die
+
+ # sometimes emake doesn't finish since it gets ahead of itself :)
+
+ make || die
+}
+
+src_install () {
+
+ make DESTDIR="${D}" install || die
+
+ #need to correct the produced absolute symlink
+ cd ${D}/usr/include
+ rm mpi++.h
+ ln -sf mpi2c++/mpi++.h mpi++.h
+
+ # There are a bunch more tex docs we could make and install too,
+ # but they might be replicated in the pdf.
+ dodoc README HISTORY LICENSE VERSION
+ cd ${S}/doc
+ dodoc {user,install}.pdf
+}