summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-03-17 09:20:28 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-03-17 09:20:28 +0000
commit0d0da65ff0d5596e8b289594715c84fa5654a892 (patch)
tree07c588618cc020284459cd72c657aa4ddeb038ca /sys-cluster/mpich
parentfix for bug #44712 by Michael Sterret <mr_bones_@gentoo.org> (Manifest recommit) (diff)
downloadgentoo-2-0d0da65ff0d5596e8b289594715c84fa5654a892.tar.gz
gentoo-2-0d0da65ff0d5596e8b289594715c84fa5654a892.tar.bz2
gentoo-2-0d0da65ff0d5596e8b289594715c84fa5654a892.zip
don't mess with P (bug #44712); install man pages in /usr/share/man; tidy
Diffstat (limited to 'sys-cluster/mpich')
-rw-r--r--sys-cluster/mpich/ChangeLog6
-rw-r--r--sys-cluster/mpich/mpich-1.2.5.2.ebuild53
2 files changed, 32 insertions, 27 deletions
diff --git a/sys-cluster/mpich/ChangeLog b/sys-cluster/mpich/ChangeLog
index 12e3b42bd1c9..288751f0224a 100644
--- a/sys-cluster/mpich/ChangeLog
+++ b/sys-cluster/mpich/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-cluster/mpich
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich/ChangeLog,v 1.9 2004/03/17 08:17:19 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich/ChangeLog,v 1.10 2004/03/17 09:20:28 mr_bones_ Exp $
+
+ 17 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> mpich-1.2.5.2.ebuild:
+ don't mess with P (bug #44712); install man pages in /usr/share/man;
+ crypt? () : () -> crypt? () !crypt ()
17 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> mpich-1.2.5-r1.ebuild:
tidy older version
diff --git a/sys-cluster/mpich/mpich-1.2.5.2.ebuild b/sys-cluster/mpich/mpich-1.2.5.2.ebuild
index 6ed2c1e9de95..19ebbf27f2af 100644
--- a/sys-cluster/mpich/mpich-1.2.5.2.ebuild
+++ b/sys-cluster/mpich/mpich-1.2.5.2.ebuild
@@ -1,25 +1,30 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich/mpich-1.2.5.2.ebuild,v 1.2 2004/03/17 08:16:42 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich/mpich-1.2.5.2.ebuild,v 1.3 2004/03/17 09:20:28 mr_bones_ Exp $
DESCRIPTION="MPICH - A portable MPI implementation"
HOMEPAGE="http://www-unix.mcs.anl.gov/mpi/mpich"
SRC_URI="ftp://ftp.mcs.anl.gov/pub/mpi/${P}.tar.gz"
-IUSE="doc crypt"
-DEPEND=""
-RDEPEND="${DEPEND}
- crypt? ( net-misc/openssh ) : ( net-misc/netkit-rsh )
- !dev-libs/lam-mpi
- virtual/glibc"
-SLOT="0"
+
LICENSE="as-is"
+SLOT="0"
KEYWORDS="x86"
+IUSE="doc crypt"
+
+DEPEND="virtual/glibc"
+RDEPEND="${DEPEND}
+ crypt? ( net-misc/openssh )
+ !crypt? ( net-misc/netkit-rsh )
+ !dev-libs/lam-mpi"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ grep -FrlZ '$(P) ' . | xargs -0 sed -i -e 's/\$(P)//'
+}
src_compile() {
- #looks like P is one of used vars, need to wrap around build...
- local PSave RSHCOMMAND
- PSave=${P}
- unset P
+ local RSHCOMMAND
if use crypt; then
RSHCOMMAND="ssh -x"
@@ -33,17 +38,11 @@ src_compile() {
--mandir=/usr/share/man \
--prefix=/usr || die
make || die
- P=${PSave}
}
src_install() {
dodir /usr/sbin
- #mangle P here as well..
- local PSave
- PSave=${P}
- unset P
-
# mpich install process is really weird, need to do some hand work perhaps
# to skip installation of man pages, uncomment following line
@@ -51,15 +50,11 @@ src_install() {
./bin/mpiinstall -echo -prefix=${D}/usr || die
- P=${PSave}
-
if use doc; then
dodir /usr/share/doc/${PF}
mv ${D}/usr/doc/* ${D}/usr/share/doc/${PF}
- rmdir ${D}/usr/doc/
- else
- rm -rf ${D}/usr/doc/
fi
+ rm -rf ${D}/usr/doc/
dodir /etc/mpich
mv ${D}/usr/etc/* ${D}/etc/mpich/
@@ -97,7 +92,13 @@ src_install() {
dosed /usr/share/mpich/upshot/bin/upshot
# those are dangling symlinks
- rm ${D}/usr/share/mpich/examples1/mpirun
- rm ${D}/usr/share/mpich/examples2/mpirun
-}
+ rm -f \
+ ${D}/usr/share/mpich/examples1/mpirun \
+ ${D}/usr/share/mpich/examples2/mpirun
+
+ mv ${D}/usr/man ${D}/usr/share/man
+ prepallman
+ #FIXME: Here, we should either clean the empty directories
+ # or use keepdir to make sure they stick around.
+}