summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2014-10-16 04:50:05 +0000
committerJustin Bronder <jsbronder@gentoo.org>2014-10-16 04:50:05 +0000
commit87a8d5e91cfd5ece7219f4c872848a3a3da07ebc (patch)
treef29a8e4a70e7454a52a94a7e9f33c414eca133a6 /sys-cluster/mpich
parentbump, working with mpich2-1.5 and openmpi-1.8.3. (diff)
downloadgentoo-2-87a8d5e91cfd5ece7219f4c872848a3a3da07ebc.tar.gz
gentoo-2-87a8d5e91cfd5ece7219f4c872848a3a3da07ebc.tar.bz2
gentoo-2-87a8d5e91cfd5ece7219f4c872848a3a3da07ebc.zip
bump, #480760
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4D7043C9)
Diffstat (limited to 'sys-cluster/mpich')
-rw-r--r--sys-cluster/mpich/ChangeLog9
-rw-r--r--sys-cluster/mpich/mpich-3.1.3.ebuild114
2 files changed, 121 insertions, 2 deletions
diff --git a/sys-cluster/mpich/ChangeLog b/sys-cluster/mpich/ChangeLog
index 1f49c31e7ecc..817a9ff6d569 100644
--- a/sys-cluster/mpich/ChangeLog
+++ b/sys-cluster/mpich/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/mpich
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich/ChangeLog,v 1.41 2013/07/09 22:37:55 jsbronder Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich/ChangeLog,v 1.42 2014/10/16 04:50:05 jsbronder Exp $
+
+*mpich-3.1.3 (16 Oct 2014)
+
+ 16 Oct 2014; Justin Bronder <jsbronder@gentoo.org> +mpich-3.1.3.ebuild:
+ bump, #480760
*mpich-3.0.4 (09 Jul 2013)
diff --git a/sys-cluster/mpich/mpich-3.1.3.ebuild b/sys-cluster/mpich/mpich-3.1.3.ebuild
new file mode 100644
index 000000000000..acd54ba5b569
--- /dev/null
+++ b/sys-cluster/mpich/mpich-3.1.3.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/mpich/mpich-3.1.3.ebuild,v 1.1 2014/10/16 04:50:05 jsbronder Exp $
+
+EAPI=5
+
+FORTRAN_NEEDED=fortran
+
+inherit fortran-2
+
+MY_PV=${PV/_/}
+DESCRIPTION="A high performance and portable MPI implementation"
+HOMEPAGE="http://www.mpich.org/"
+SRC_URI="http://www.mpich.org/static/downloads/${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="mpich"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="+cxx doc fortran mpi-threads romio threads"
+
+COMMON_DEPEND="
+ dev-libs/libaio
+ >=sys-apps/hwloc-1.9
+ romio? ( net-fs/nfs-utils )"
+
+DEPEND="${COMMON_DEPEND}
+ dev-lang/perl
+ sys-devel/libtool"
+
+RDEPEND="${COMMON_DEPEND}
+ !sys-cluster/mpich2
+ !sys-cluster/openmpi"
+
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+pkg_setup() {
+ FORTRAN_STANDARD="77 90"
+ fortran-2_pkg_setup
+
+ if use mpi-threads && ! use threads; then
+ ewarn "mpi-threads requires threads, assuming that's what you want"
+ fi
+}
+
+src_prepare() {
+ # Using MPICHLIB_LDFLAGS doesn't seem to fully work.
+ sed -i 's| *@WRAPPER_LDFLAGS@ *||' \
+ src/packaging/pkgconfig/mpich.pc.in \
+ src/env/*.in \
+ || die
+}
+
+src_configure() {
+ local c="--enable-shared"
+
+ # The configure statements can be somewhat confusing, as they
+ # don't all show up in the top level configure, however, they
+ # are picked up in the children directories.
+
+ if use mpi-threads; then
+ # MPI-THREAD requries threading.
+ c="${c} --with-thread-package=pthreads"
+ c="${c} --enable-threads=runtime"
+ else
+ if use threads ; then
+ c="${c} --with-thread-package=pthreads"
+ else
+ c="${c} --with-thread-package=none"
+ fi
+ c="${c} --enable-threads=single"
+ fi
+
+ c="${c} --sysconfdir=${EPREFIX}/etc/${PN}"
+ c="${c} --docdir=${EPREFIX}/usr/share/doc/${PF}"
+
+ export MPICHLIB_CFLAGS=${CFLAGS}
+ export MPICHLIB_CPPFLAGS=${CPPFLAGS}
+ export MPICHLIB_CXXFLAGS=${CXXFLAGS}
+ export MPICHLIB_FFLAGS=${FFLAGS}
+ export MPICHLIB_FCFLAGS=${FCFLAGS}
+ export MPICHLIB_LDFLAGS=${LDFLAGS}
+ unset CFLAGS CPPFLAGS CXXFLAGS FFLAGS FCFLAGS LDFLAGS
+
+ econf ${c} \
+ --with-pm=hydra \
+ --disable-mpe \
+ --disable-fast \
+ --enable-smpcoll \
+ --enable-versioning \
+ --with-hwloc-prefix=/usr \
+ $(use_enable romio) \
+ $(use_enable cxx) \
+ $(use_enable fortran f77) \
+ $(use_enable fortran fc)
+}
+
+src_test() {
+ emake -j1 check
+}
+
+src_install() {
+ default
+
+ dodir /usr/share/doc/${PF}
+ dodoc README{,.envvar} CHANGES RELEASE_NOTES
+ newdoc src/pm/hydra/README README.hydra
+ if use romio; then
+ newdoc src/mpi/romio/README README.romio
+ fi
+
+ if ! use doc; then
+ rm -rf "${D}"usr/share/doc/${PF}/www*
+ fi
+}