summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-05-05 06:17:52 +0000
committerIan Delaney <idella4@gentoo.org>2014-05-05 06:17:52 +0000
commit0ec07e01692b2b57eeef39fdd52ecc26785b9e03 (patch)
tree36829f206de71eb8d5654545174803fa442a6d5d /sys-cluster/nova
parentversion bump (diff)
downloadgentoo-2-0ec07e01692b2b57eeef39fdd52ecc26785b9e03.tar.gz
gentoo-2-0ec07e01692b2b57eeef39fdd52ecc26785b9e03.tar.bz2
gentoo-2-0ec07e01692b2b57eeef39fdd52ecc26785b9e03.zip
revbump; add sample conf file, fixes Bug #509092
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'sys-cluster/nova')
-rw-r--r--sys-cluster/nova/ChangeLog8
-rw-r--r--sys-cluster/nova/nova-2014.1-r1.ebuild125
-rw-r--r--sys-cluster/nova/nova-2014.1.9999.ebuild7
3 files changed, 138 insertions, 2 deletions
diff --git a/sys-cluster/nova/ChangeLog b/sys-cluster/nova/ChangeLog
index f1314da074d7..48ef25d27b14 100644
--- a/sys-cluster/nova/ChangeLog
+++ b/sys-cluster/nova/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/nova
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/ChangeLog,v 1.61 2014/04/28 04:00:51 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/ChangeLog,v 1.62 2014/05/05 06:17:52 idella4 Exp $
+
+*nova-2014.1-r1 (05 May 2014)
+
+ 05 May 2014; Ian Delaney <idella4@gentoo.org> +nova-2014.1-r1.ebuild,
+ nova-2014.1.9999.ebuild:
+ revbump; add sample conf file, fixes Bug #509092
28 Apr 2014; Matthew Thode <prometheanfire@gentoo.org> files/nova.initd:
don't depend unneeded init stuff
diff --git a/sys-cluster/nova/nova-2014.1-r1.ebuild b/sys-cluster/nova/nova-2014.1-r1.ebuild
new file mode 100644
index 000000000000..700d3ad47714
--- /dev/null
+++ b/sys-cluster/nova/nova-2014.1-r1.ebuild
@@ -0,0 +1,125 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/nova-2014.1-r1.ebuild,v 1.1 2014/05/05 06:17:52 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils multilib user
+
+DESCRIPTION="A cloud computing fabric controller (main part of an IaaS system) written in Python."
+HOMEPAGE="https://launchpad.net/nova"
+SRC_URI="http://launchpad.net/${PN}/icehouse/${PV}/+download/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+compute +kvm +network +novncproxy sqlite mysql postgres xen"
+REQUIRED_USE="|| ( mysql postgres sqlite )
+ compute? ( || ( kvm xen ) )"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.6[${PYTHON_USEDEP}]
+ <dev-python/pbr-1.0[${PYTHON_USEDEP}]
+ app-admin/sudo"
+
+RDEPEND="sqlite? ( >=dev-python/sqlalchemy-0.7.8[sqlite,${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-0.9.99[sqlite,${PYTHON_USEDEP}] )
+ mysql? ( >=dev-python/sqlalchemy-0.7.8[mysql,${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-0.9.99[mysql,${PYTHON_USEDEP}] )
+ postgres? ( >=dev-python/sqlalchemy-0.7.8[postgres,${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-0.9.99[postgres,${PYTHON_USEDEP}] )
+ >=dev-python/amqplib-0.6.1[${PYTHON_USEDEP}]
+ >=dev-python/anyjson-0.3.3[${PYTHON_USEDEP}]
+ virtual/python-argparse[${PYTHON_USEDEP}]
+ >=dev-python/boto-2.12.0[${PYTHON_USEDEP}]
+ !~dev-python/boto-2.13.0[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.13.0[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ >=dev-python/kombu-2.4.8[${PYTHON_USEDEP}]
+ >=dev-python/lxml-2.3[${PYTHON_USEDEP}]
+ >=dev-python/routes-1.12.3-r1[${PYTHON_USEDEP}]
+ >=dev-python/webob-1.2.3[${PYTHON_USEDEP}]
+ >=dev-python/greenlet-0.3.2[${PYTHON_USEDEP}]
+ >=dev-python/pastedeploy-1.5.0-r1[${PYTHON_USEDEP}]
+ dev-python/paste[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-migrate-0.8.2[${PYTHON_USEDEP}]
+ !~dev-python/sqlalchemy-migrate-0.8.4[${PYTHON_USEDEP}]
+ >=dev-python/netaddr-0.7.6[${PYTHON_USEDEP}]
+ >=dev-python/suds-0.4[${PYTHON_USEDEP}]
+ >=dev-python/paramiko-1.9.0[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ >=dev-python/Babel-1.3[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.9[${PYTHON_USEDEP}]
+ >=dev-python/python-cinderclient-1.0.6[${PYTHON_USEDEP}]
+ >=dev-python/python-neutronclient-2.3.4[${PYTHON_USEDEP}]
+ <=dev-python/python-neutronclient-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/python-glanceclient-0.9.0[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.5.2[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-0.14[${PYTHON_USEDEP}]
+ >=dev-python/websockify-0.5.1[${PYTHON_USEDEP}]
+ <dev-python/websockify-0.6[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-1.2.0[${PYTHON_USEDEP}]
+ dev-python/oslo-rootwrap[${PYTHON_USEDEP}]
+ >=dev-python/pycadf-0.4.1[${PYTHON_USEDEP}]
+ >=dev-python/oslo-messaging-1.3.0[${PYTHON_USEDEP}]
+ dev-python/libvirt-python[${PYTHON_USEDEP}]
+ novncproxy? ( www-apps/novnc )
+ sys-apps/iproute2
+ net-misc/openvswitch
+ net-misc/rabbitmq-server
+ sys-fs/sysfsutils
+ sys-fs/multipath-tools
+ kvm? ( app-emulation/qemu )
+ xen? ( app-emulation/xen
+ app-emulation/xen-tools )"
+
+PATCHES=(
+)
+
+pkg_setup() {
+ enewgroup nova
+ enewuser nova -1 -1 /var/lib/nova nova
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ ./tools/config/generate_sample.sh -b ./ -p nova -o etc/nova
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ for svc in api cert compute conductor consoleauth network scheduler spicehtml5proxy xvpvncproxy; do
+ newinitd "${FILESDIR}/nova.initd" "nova-${svc}"
+ done
+ use compute && newinitd "${FILESDIR}/nova.initd" "nova-compute"
+ use novncproxy && newinitd "${FILESDIR}/nova.initd" "nova-novncproxy"
+
+ diropts -m 0750 -o nova -g nova
+ dodir /var/log/nova /var/lib/nova/instances
+
+ insinto /etc/nova
+ insopts -m 0640 -o nova -g nova
+ newins "etc/nova/nova.conf.sample" "nova.conf"
+ doins "etc/nova/api-paste.ini"
+ doins "etc/nova/logging_sample.conf"
+ doins "etc/nova/policy.json"
+ doins "etc/nova/rootwrap.conf"
+ #rootwrap filters
+ insinto /etc/nova/rootwrap.d
+ doins "etc/nova/rootwrap.d/api-metadata.filters"
+ doins "etc/nova/rootwrap.d/compute.filters"
+ doins "etc/nova/rootwrap.d/network.filters"
+ #copy migration conf file (not coppied on install via setup.py script)
+ insinto /usr/$(get_libdir)/python2.7/site-packages/nova/db/sqlalchemy/migrate_repo/
+ doins "nova/db/sqlalchemy/migrate_repo/migrate.cfg"
+ #copy the CA cert dir (not coppied on install via setup.py script)
+ cp -R "${S}/nova/CA" "${D}/usr/$(get_libdir)/python2.7/site-packages/nova/" || die "installing CA files failed"
+
+ #add sudoers definitions for user nova
+ insinto /etc/sudoers.d/
+ insopts -m 0600 -o root -g root
+ doins "${FILESDIR}/nova-sudoers"
+}
diff --git a/sys-cluster/nova/nova-2014.1.9999.ebuild b/sys-cluster/nova/nova-2014.1.9999.ebuild
index 99f31d92c8cc..945974b2e35d 100644
--- a/sys-cluster/nova/nova-2014.1.9999.ebuild
+++ b/sys-cluster/nova/nova-2014.1.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/nova-2014.1.9999.ebuild,v 1.1 2014/04/28 03:03:58 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/nova-2014.1.9999.ebuild,v 1.2 2014/05/05 06:17:52 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -84,6 +84,11 @@ pkg_setup() {
enewuser nova -1 -1 /var/lib/nova nova
}
+python_compile() {
+ distutils-r1_python_compile
+ ./tools/config/generate_sample.sh -b ./ -p nova -o etc/nova
+}
+
python_install() {
distutils-r1_python_install