summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVadim Kuznetsov <vadimk@gentoo.org>2014-05-11 12:38:13 +0000
committerVadim Kuznetsov <vadimk@gentoo.org>2014-05-11 12:38:13 +0000
commitb6dcb87c308135abe8790c0a0c5a038d14247c11 (patch)
treeea9a06417175ee69be2307e016e5a3577682e11e /sys-cluster/nova
parentFix required use (diff)
downloadgentoo-2-b6dcb87c308135abe8790c0a0c5a038d14247c11.tar.gz
gentoo-2-b6dcb87c308135abe8790c0a0c5a038d14247c11.tar.bz2
gentoo-2-b6dcb87c308135abe8790c0a0c5a038d14247c11.zip
slot conflicts, bug 508002
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key E1DF22D5)
Diffstat (limited to 'sys-cluster/nova')
-rw-r--r--sys-cluster/nova/ChangeLog8
-rw-r--r--sys-cluster/nova/files/nova.initd6
-rw-r--r--sys-cluster/nova/files/nova.sudoersd3
-rw-r--r--sys-cluster/nova/nova-2014.1-r2.ebuild (renamed from sys-cluster/nova/nova-2014.1.ebuild)26
4 files changed, 28 insertions, 15 deletions
diff --git a/sys-cluster/nova/ChangeLog b/sys-cluster/nova/ChangeLog
index 48ef25d27b14..1eab02864c41 100644
--- a/sys-cluster/nova/ChangeLog
+++ b/sys-cluster/nova/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/nova
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/ChangeLog,v 1.62 2014/05/05 06:17:52 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/ChangeLog,v 1.63 2014/05/11 12:38:13 vadimk Exp $
+
+*nova-2014.1-r2 (11 May 2014)
+
+ 11 May 2014; Vadim Kuznetsov vadimk@gentoo.org +files/nova.sudoersd,
+ +nova-2014.1-r2.ebuild, -nova-2014.1.ebuild, files/nova.initd:
+ slot conflicts, bug 508002
*nova-2014.1-r1 (05 May 2014)
diff --git a/sys-cluster/nova/files/nova.initd b/sys-cluster/nova/files/nova.initd
index fcd2ec292be1..14fae14dd88d 100644
--- a/sys-cluster/nova/files/nova.initd
+++ b/sys-cluster/nova/files/nova.initd
@@ -2,7 +2,7 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-description="Starts ${SVCNAME} service for OpenStack"
+description="Starts ${SVCNAME} service for OpenStack"
command=/usr/bin/${SVCNAME}
command_background=yes
@@ -15,6 +15,6 @@ depend() {
}
start_pre() {
- checkpath --directory --owner ${NOVA_USER:-nova}:${NOVA_GROUP:-nova} --mode 0664 ${NOVA_RUN:-/var/run/nova}
- checkpath --directory --owner ${NOVA_USER:-nova}:${NOVA_GROUP:-nova} --mode 0664 ${NOVA_RUN:-/var/lock/nova}
+ checkpath --directory --owner ${NOVA_USER:-nova}:${NOVA_GROUP:-nova} --mode 0775 ${NOVA_RUN:-/var/run/nova}
+ checkpath --directory --owner ${NOVA_USER:-nova}:${NOVA_GROUP:-nova} --mode 0775 ${NOVA_RUN:-/var/lock/nova}
}
diff --git a/sys-cluster/nova/files/nova.sudoersd b/sys-cluster/nova/files/nova.sudoersd
new file mode 100644
index 000000000000..f15b3285b7d4
--- /dev/null
+++ b/sys-cluster/nova/files/nova.sudoersd
@@ -0,0 +1,3 @@
+Defaults:nova !requiretty
+
+nova ALL = (root) NOPASSWD: /usr/bin/nova-rootwrap
diff --git a/sys-cluster/nova/nova-2014.1.ebuild b/sys-cluster/nova/nova-2014.1-r2.ebuild
index e4af705be717..ec757fee17d2 100644
--- a/sys-cluster/nova/nova-2014.1.ebuild
+++ b/sys-cluster/nova/nova-2014.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/nova-2014.1.ebuild,v 1.1 2014/04/28 03:03:58 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/nova-2014.1-r2.ebuild,v 1.1 2014/05/11 12:38:13 vadimk Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -23,12 +23,11 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
<dev-python/pbr-1.0[${PYTHON_USEDEP}]
app-admin/sudo"
-RDEPEND="sqlite? ( >=dev-python/sqlalchemy-0.7.8[sqlite,${PYTHON_USEDEP}]
- <dev-python/sqlalchemy-0.9.99[sqlite,${PYTHON_USEDEP}] )
- mysql? ( >=dev-python/sqlalchemy-0.7.8[mysql,${PYTHON_USEDEP}]
- <dev-python/sqlalchemy-0.9.99[mysql,${PYTHON_USEDEP}] )
- postgres? ( >=dev-python/sqlalchemy-0.7.8[postgres,${PYTHON_USEDEP}]
- <dev-python/sqlalchemy-0.9.99[postgres,${PYTHON_USEDEP}] )
+RDEPEND=">=dev-python/sqlalchemy-0.7.8[${PYTHON_USEDEP}]
+ <dev-python/sqlalchemy-0.9.99[${PYTHON_USEDEP}]
+ mysql? ( dev-python/mysql-python[${PYTHON_USEDEP}] )
+ postgres? ( >=dev-python/psycopg-2[${PYTHON_USEDEP}] )
+ sqlite? ( dev-db/sqlite )
>=dev-python/amqplib-0.6.1[${PYTHON_USEDEP}]
>=dev-python/anyjson-0.3.3[${PYTHON_USEDEP}]
virtual/python-argparse[${PYTHON_USEDEP}]
@@ -83,10 +82,15 @@ pkg_setup() {
enewuser nova -1 -1 /var/lib/nova nova
}
+python_compile() {
+ distutils-r1_python_compile
+ ./tools/config/generate_sample.sh -b ./ -p nova -o etc/nova
+}
+
python_install() {
distutils-r1_python_install
- for svc in api cert compute conductor consoleauth network scheduler spicehtml5proxy xvpvncproxy; do
+ for svc in api cert conductor consoleauth network scheduler spicehtml5proxy xvpvncproxy; do
newinitd "${FILESDIR}/nova.initd" "nova-${svc}"
done
use compute && newinitd "${FILESDIR}/nova.initd" "nova-compute"
@@ -97,7 +101,7 @@ python_install() {
insinto /etc/nova
insopts -m 0640 -o nova -g nova
- newins "etc/nova/nova.conf.sample" "nova.conf"
+ #newins "etc/nova/nova.conf.sample" "nova.conf"
doins "etc/nova/api-paste.ini"
doins "etc/nova/logging_sample.conf"
doins "etc/nova/policy.json"
@@ -115,6 +119,6 @@ python_install() {
#add sudoers definitions for user nova
insinto /etc/sudoers.d/
- insopts -m 0600 -o root -g root
- doins "${FILESDIR}/nova-sudoers"
+ insopts -m 0440 -o root -g root
+ newins "${FILESDIR}/nova.sudoersd" nova
}