summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2009-04-17 15:51:00 +0000
committerJustin Bronder <jsbronder@gentoo.org>2009-04-17 15:51:00 +0000
commit17bbf36a7141726b7b153bdf98c6965ac666c912 (patch)
tree29b5e5166a3a14b97c092bf7b0d696d565270b02 /sys-cluster/openmpi
parentCleanup old versions. (diff)
downloadgentoo-2-17bbf36a7141726b7b153bdf98c6965ac666c912.tar.gz
gentoo-2-17bbf36a7141726b7b153bdf98c6965ac666c912.tar.bz2
gentoo-2-17bbf36a7141726b7b153bdf98c6965ac666c912.zip
Use EAPI=1 for default +cxx with openmpi-1.2.9
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster/openmpi')
-rw-r--r--sys-cluster/openmpi/ChangeLog5
-rw-r--r--sys-cluster/openmpi/openmpi-1.2.9.ebuild7
2 files changed, 8 insertions, 4 deletions
diff --git a/sys-cluster/openmpi/ChangeLog b/sys-cluster/openmpi/ChangeLog
index b38d79096e91..3c0db6babe50 100644
--- a/sys-cluster/openmpi/ChangeLog
+++ b/sys-cluster/openmpi/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-cluster/openmpi
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/ChangeLog,v 1.41 2009/04/17 15:48:09 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/ChangeLog,v 1.42 2009/04/17 15:51:00 jsbronder Exp $
+
+ 17 Apr 2009; Justin Bronder <jsbronder@gentoo.org> openmpi-1.2.9.ebuild:
+ Use EAPI=1 for default +cxx with openmpi-1.2.9
17 Apr 2009; Justin Bronder <jsbronder@gentoo.org> -openmpi-1.2.5.ebuild,
-openmpi-1.2.6.ebuild, -openmpi-1.2.7.ebuild, -openmpi-1.2.7-r1.ebuild,
diff --git a/sys-cluster/openmpi/openmpi-1.2.9.ebuild b/sys-cluster/openmpi/openmpi-1.2.9.ebuild
index 225050fe6b7f..bbc2c272734c 100644
--- a/sys-cluster/openmpi/openmpi-1.2.9.ebuild
+++ b/sys-cluster/openmpi/openmpi-1.2.9.ebuild
@@ -1,7 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.2.9.ebuild,v 1.1 2009/02/20 19:42:54 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.2.9.ebuild,v 1.2 2009/04/17 15:51:00 jsbronder Exp $
+EAPI=1
inherit eutils multilib flag-o-matic toolchain-funcs fortran
MY_P=${P/-mpi}
@@ -14,7 +15,7 @@ LICENSE="BSD"
SLOT="0"
RESTRICT="mpi-threads? ( test )"
KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="fortran heterogeneous ipv6 mpi-threads nocxx pbs romio threads"
+IUSE="+cxx fortran heterogeneous ipv6 mpi-threads pbs romio threads"
RDEPEND="pbs? ( sys-cluster/torque )
!sys-cluster/mpich
!sys-cluster/lam-mpi
@@ -86,7 +87,7 @@ src_compile() {
fi
econf ${myconf} \
- $(use_enable !nocxx mpi-cxx) \
+ $(use_enable cxx mpi-cxx) \
$(use_enable romio io-romio) \
$(use_enable heterogeneous) \
$(use_with pbs tm) \