summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-01-01 23:01:41 +0000
committerMichał Górny <mgorny@gentoo.org>2015-01-01 23:01:41 +0000
commitbeeb532c4b457572c2f4d4331ff063fd36f3a65d (patch)
tree1233ffa76c9be05c228cd1b2a73d07cf05e2caaf /sys-cluster/pacemaker
parentstable amd64 x86 (diff)
downloadgentoo-2-beeb532c4b457572c2f4d4331ff063fd36f3a65d.tar.gz
gentoo-2-beeb532c4b457572c2f4d4331ff063fd36f3a65d.tar.bz2
gentoo-2-beeb532c4b457572c2f4d4331ff063fd36f3a65d.zip
Fix use of python-single-r1. python_convert_shebangs -> python_fix_shebang. Replace base.eclass inherit. Remove broken versions.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'sys-cluster/pacemaker')
-rw-r--r--sys-cluster/pacemaker/ChangeLog11
-rw-r--r--sys-cluster/pacemaker/pacemaker-1.1.10.ebuild94
-rw-r--r--sys-cluster/pacemaker/pacemaker-1.1.12-r1.ebuild (renamed from sys-cluster/pacemaker/pacemaker-1.1.12.ebuild)21
3 files changed, 22 insertions, 104 deletions
diff --git a/sys-cluster/pacemaker/ChangeLog b/sys-cluster/pacemaker/ChangeLog
index 013c853c14e0..f76167eeb21f 100644
--- a/sys-cluster/pacemaker/ChangeLog
+++ b/sys-cluster/pacemaker/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-cluster/pacemaker
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pacemaker/ChangeLog,v 1.36 2014/12/12 13:41:15 ultrabug Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pacemaker/ChangeLog,v 1.37 2015/01/01 23:01:41 mgorny Exp $
+
+*pacemaker-1.1.12-r1 (01 Jan 2015)
+
+ 01 Jan 2015; Michał Górny <mgorny@gentoo.org> +pacemaker-1.1.12-r1.ebuild,
+ -pacemaker-1.1.10.ebuild, -pacemaker-1.1.12.ebuild:
+ Fix use of python-single-r1. python_convert_shebangs -> python_fix_shebang.
+ Replace base.eclass inherit. Remove broken versions.
*pacemaker-1.1.12 (12 Dec 2014)
diff --git a/sys-cluster/pacemaker/pacemaker-1.1.10.ebuild b/sys-cluster/pacemaker/pacemaker-1.1.10.ebuild
deleted file mode 100644
index 06a5fca6d93e..000000000000
--- a/sys-cluster/pacemaker/pacemaker-1.1.10.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pacemaker/pacemaker-1.1.10.ebuild,v 1.2 2014/12/12 13:41:15 ultrabug Exp $
-
-EAPI="5"
-PYTHON_COMPAT=( python{2_6,2_7} )
-WANT_AUTOMAKE="1.12"
-
-inherit autotools base python-single-r1
-
-MY_PN="Pacemaker"
-MY_P=${MY_PN}-${PV/_/-}
-
-DESCRIPTION="Pacemaker CRM"
-HOMEPAGE="http://www.linux-ha.org/wiki/Pacemaker"
-SRC_URI="https://github.com/ClusterLabs/${PN}/archive/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~hppa ~x86"
-REQUIRED_USE="cman? ( !heartbeat )"
-IUSE="acl cman heartbeat smtp snmp static-libs"
-
-DEPEND="
- app-text/docbook-xsl-stylesheets
- dev-libs/libxslt
- sys-cluster/cluster-glue
- >=sys-cluster/libqb-0.14.0
- sys-cluster/resource-agents
- cman? ( sys-cluster/cman )
- heartbeat? ( >=sys-cluster/heartbeat-3.0.0 )
- !heartbeat? ( sys-cluster/corosync )
- smtp? ( net-libs/libesmtp )
- snmp? ( net-analyzer/net-snmp )
-"
-RDEPEND="${DEPEND}"
-
-PATCHES=("${FILESDIR}"/pacemaker-1.1.10-tinfo.patch)
-
-S="${WORKDIR}/${PN}-${MY_P}"
-
-pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
-}
-
-src_prepare() {
- base_src_prepare
- sed -i -e "/ggdb3/d" configure.ac || die
- sed -i -e "s/ -ggdb//g" configure.ac || die
- sed -i -e "s/uid2username(uid)/uid2username(uid_client)/g" lib/common/ipc.c || die
- sed -i -e "s:<glib/ghash.h>:<glib.h>:" lib/ais/plugin.c || die
- eautoreconf
- python_convert_shebangs -r 2 .
-}
-
-src_configure() {
- local myopts=""
- if use heartbeat ; then
- myopts="--without-corosync"
- else
- myopts="--with-ais"
- fi
- # appends lib to localstatedir automatically
- econf \
- --libdir=/usr/$(get_libdir) \
- --localstatedir=/var \
- --disable-dependency-tracking \
- --disable-fatal-warnings \
- $(use_with acl) \
- $(use_with cman cs-quorum) \
- $(use_with cman cman) \
- $(use_with heartbeat) \
- $(use_with smtp esmtp) \
- $(use_with snmp) \
- $(use_enable static-libs static) \
- ${myopts}
-}
-
-src_install() {
- base_src_install
- rm -rf "${D}"/var/run "${D}"/etc/init.d
- newinitd "${FILESDIR}/${PN}.initd" ${PN} || die
- if has_version "<sys-cluster/corosync-2.0"; then
- insinto /etc/corosync/service.d
- newins "${FILESDIR}/${PN}.service" ${PN} || die
- fi
-}
-
-pkg_postinst() {
- elog " "
- elog "Looking for the crm CLI ? emerge sys-cluster/crmsh !"
- elog " "
-}
diff --git a/sys-cluster/pacemaker/pacemaker-1.1.12.ebuild b/sys-cluster/pacemaker/pacemaker-1.1.12-r1.ebuild
index 42d5718243e0..c7030410e23b 100644
--- a/sys-cluster/pacemaker/pacemaker-1.1.12.ebuild
+++ b/sys-cluster/pacemaker/pacemaker-1.1.12-r1.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pacemaker/pacemaker-1.1.12.ebuild,v 1.1 2014/12/12 13:41:15 ultrabug Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pacemaker/pacemaker-1.1.12-r1.ebuild,v 1.1 2015/01/01 23:01:41 mgorny Exp $
EAPI="5"
-PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_COMPAT=( python2_7 )
WANT_AUTOMAKE="1.12"
-inherit autotools base python-single-r1
+inherit autotools eutils python-single-r1
MY_PN="Pacemaker"
MY_P=${MY_PN}-${PV/_/-}
@@ -21,7 +21,7 @@ KEYWORDS="~amd64 ~hppa ~x86"
REQUIRED_USE="cman? ( !heartbeat )"
IUSE="acl cman heartbeat smtp snmp static-libs"
-DEPEND="
+DEPEND="${PYTHON_DEPS}
app-text/docbook-xsl-stylesheets
dev-libs/libxslt
sys-cluster/cluster-glue
@@ -35,18 +35,23 @@ DEPEND="
"
RDEPEND="${DEPEND}"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
PATCHES=("${FILESDIR}"/pacemaker-1.1.10-tinfo.patch)
S="${WORKDIR}/${PN}-${MY_P}"
src_prepare() {
- base_src_prepare
+ epatch "${PATCHES[@]}"
+ epatch_user
+
sed -i -e "/ggdb3/d" configure.ac || die
sed -i -e "s/ -ggdb//g" configure.ac || die
sed -i -e "s/uid2username(uid)/uid2username(uid_client)/g" lib/common/ipc.c || die
sed -i -e "s:<glib/ghash.h>:<glib.h>:" lib/ais/plugin.c || die
eautoreconf
- python_convert_shebangs -r 2 .
+
+ python_fix_shebang .
}
src_configure() {
@@ -73,7 +78,7 @@ src_configure() {
}
src_install() {
- base_src_install
+ default
rm -rf "${D}"/var/run "${D}"/etc/init.d
newinitd "${FILESDIR}/${PN}.initd" ${PN} || die
if has_version "<sys-cluster/corosync-2.0"; then