summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Bock <nicolasbock@gentoo.org>2013-12-13 20:13:12 +0000
committerNicolas Bock <nicolasbock@gentoo.org>2013-12-13 20:13:12 +0000
commitd88dcb4b030495159cbaef36bac1e2d8b29b6de9 (patch)
tree7748919671f52d71ff61715d8bd004f901982610 /sys-cluster/projections/projections-6.2.1.ebuild
parentsys-cluster/charmdebug: Copied latest ebuild from sci overlay. (diff)
downloadgentoo-2-d88dcb4b030495159cbaef36bac1e2d8b29b6de9.tar.gz
gentoo-2-d88dcb4b030495159cbaef36bac1e2d8b29b6de9.tar.bz2
gentoo-2-d88dcb4b030495159cbaef36bac1e2d8b29b6de9.zip
sys-cluster/projections: Copied latest ebuild from sci overlay.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key AC91CA52)
Diffstat (limited to 'sys-cluster/projections/projections-6.2.1.ebuild')
-rw-r--r--sys-cluster/projections/projections-6.2.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/sys-cluster/projections/projections-6.2.1.ebuild b/sys-cluster/projections/projections-6.2.1.ebuild
new file mode 100644
index 000000000000..af70d58d3936
--- /dev/null
+++ b/sys-cluster/projections/projections-6.2.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/projections/projections-6.2.1.ebuild,v 1.1 2013/12/13 20:13:12 nicolasbock Exp $
+
+EAPI=5
+
+inherit java-pkg-2
+
+DESCRIPTION="Projections Performance Analysis Framework for Charm++ Applications"
+HOMEPAGE="http://charm.cs.uiuc.edu/"
+SRC_URI="http://charm.cs.illinois.edu/distrib/binaries/projections/projections_${PV}.tar.gz"
+
+S="${WORKDIR}/${PN}_${PV}"
+
+LICENSE="charm"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ >=virtual/jre-1.6
+ sys-cluster/charm[charmtracing]"
+
+src_install() {
+ java-pkg_newjar ${PN}.jar
+ java-pkg_dolauncher ${PN} \
+ --main projections.analysis.ProjMain \
+ --jar ${PN}.jar
+}