summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2008-04-17 02:51:23 +0000
committerJustin Bronder <jsbronder@gentoo.org>2008-04-17 02:51:23 +0000
commit17441572a2f8de23bada75bac79308dce878a3df (patch)
treec89f94dbfd6fbf6954e6f7551a4677c2b909d78e /sys-cluster/pvfs2
parentx86 stable, security bug #204344 (diff)
downloadgentoo-2-17441572a2f8de23bada75bac79308dce878a3df.tar.gz
gentoo-2-17441572a2f8de23bada75bac79308dce878a3df.tar.bz2
gentoo-2-17441572a2f8de23bada75bac79308dce878a3df.zip
Bump pvfs2 to 2.7.1. Added threads use flag for the client threaded libraries.
(Portage version: 2.1.4.4)
Diffstat (limited to 'sys-cluster/pvfs2')
-rw-r--r--sys-cluster/pvfs2/ChangeLog9
-rw-r--r--sys-cluster/pvfs2/files/pvfs2-split-kernapps.patch19
-rw-r--r--sys-cluster/pvfs2/pvfs2-2.7.1.ebuild144
3 files changed, 171 insertions, 1 deletions
diff --git a/sys-cluster/pvfs2/ChangeLog b/sys-cluster/pvfs2/ChangeLog
index 7a3ad61ce8cb..d69afa989311 100644
--- a/sys-cluster/pvfs2/ChangeLog
+++ b/sys-cluster/pvfs2/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-cluster/pvfs2
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pvfs2/ChangeLog,v 1.11 2008/03/10 01:17:07 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pvfs2/ChangeLog,v 1.12 2008/04/17 02:51:23 jsbronder Exp $
+
+*pvfs2-2.7.1 (17 Apr 2008)
+
+ 17 Apr 2008; Justin Bronder <jsbronder@gentoo.org>
+ +files/pvfs2-split-kernapps.patch, +pvfs2-2.7.1.ebuild:
+ Bump pvfs2 to 2.7.1. Added threads use flag for the client threaded
+ libraries.
*pvfs2-2.7.0-r2 (10 Mar 2008)
diff --git a/sys-cluster/pvfs2/files/pvfs2-split-kernapps.patch b/sys-cluster/pvfs2/files/pvfs2-split-kernapps.patch
new file mode 100644
index 000000000000..eb1eb97ec24b
--- /dev/null
+++ b/sys-cluster/pvfs2/files/pvfs2-split-kernapps.patch
@@ -0,0 +1,19 @@
+diff -urN pvfs-2.7.1/Makefile.in pvfs-2.7.1_patched/Makefile.in
+--- pvfs-2.7.1/Makefile.in 2008-04-14 11:37:32.000000000 -0400
++++ pvfs-2.7.1_patched/Makefile.in 2008-04-16 22:00:55.354355245 -0400
+@@ -984,10 +984,13 @@
+ install -d $(KMOD_DIR)
+ install -m 755 src/kernel/linux-2.6/pvfs2.ko $(KMOD_DIR)
+
+-.PHONY: kmod_install
+-kmod_install: kmod kernapps just_kmod_install
++.PHONY: kernapps_install
++kernapps_install: kernapps
+ install -d $(sbindir)
+ install -m 755 $(KERNAPPS) $(KERNAPPSTHR) $(sbindir)
++
++.PHONY: kmod_install
++kmod_install: kmod kernapps_install just_kmod_install
+ endif
+
+ ifneq (,$(LINUX24_KERNEL_SRC))
diff --git a/sys-cluster/pvfs2/pvfs2-2.7.1.ebuild b/sys-cluster/pvfs2/pvfs2-2.7.1.ebuild
new file mode 100644
index 000000000000..cebef8cb2ca9
--- /dev/null
+++ b/sys-cluster/pvfs2/pvfs2-2.7.1.ebuild
@@ -0,0 +1,144 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pvfs2/pvfs2-2.7.1.ebuild,v 1.1 2008/04/17 02:51:23 jsbronder Exp $
+
+inherit linux-mod autotools toolchain-funcs
+
+MY_PN="${PN%[0-9]*}"
+MY_P="${MY_PN}-${PV}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Parallel Virtual File System version 2"
+HOMEPAGE="http://www.pvfs.org/"
+SRC_URI="ftp://ftp.parl.clemson.edu/pub/pvfs2/${MY_P}.tar.gz"
+IUSE="gtk server static doc ssl examples apidocs threads"
+RDEPEND="gtk? ( >=x11-libs/gtk+-2 )
+ ssl? ( dev-libs/openssl )
+ doc? ( dev-tex/latex2html )
+ apidocs? ( app-doc/doxygen )
+ sys-libs/db"
+DEPEND="${RDEPEND}
+ virtual/linux-sources"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86 ~ppc64"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ if kernel_is 2 4; then
+ BUILD_TARGETS="just_kmod24"
+ ECONF_PARAMS="--with-kernel24=${KV_DIR}"
+ MODULE_NAMES="pvfs2(fs::src/kernel/linux-2.4)"
+ else
+ BUILD_TARGETS="just_kmod"
+ ECONF_PARAMS="--with-kernel=${KV_DIR} --enable-verbose-build"
+ MODULE_NAMES="pvfs2(fs::src/kernel/linux-2.6)"
+ fi
+
+ ECONF_PARAMS="${ECONF_PARAMS}
+ --enable-mmap-racache
+ --sysconfdir=/etc/pvfs2
+ --enable-shared
+ --enable-static
+ $(use_enable static static-server)
+ $(use_enable gtk karma)
+ $(use_enable server)
+ $(use_enable threads threaded-kmod-helper)
+ $(use_with ssl openssl /usr/$(get_libdir))"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Upstream doesn't seem to want to apply this which makes
+ # sense as it probably only matters to us. Simple patch
+ # to split the installation of the module (which we use
+ # the eclass for) and the installation of the kernapps.
+ epatch "${FILESDIR}"/${PN}-split-kernapps.patch
+}
+
+src_compile() {
+ linux-mod_src_compile || die
+ emake kernapps || die
+ emake all || die
+ if use doc; then
+ emake docs || die
+ if use apidocs; then
+ cd "${S}"/doc
+ doxygen doxygen/pvfs2-doxygen.conf || die
+ fi
+ fi
+}
+
+src_install() {
+ linux-mod_src_install || die
+ emake DESTDIR="${D}" kernapps_install || die
+ emake DESTDIR="${D}" install || die
+
+ if use server; then
+ newinitd "${FILESDIR}"/pvfs2-server-init.d-2.7.0 pvfs2-server
+ newconfd "${FILESDIR}"/pvfs2-server-conf.d-2.7.0 pvfs2-server
+ fi
+
+ newinitd "${FILESDIR}"/pvfs2-client-init.d-2.7.0 pvfs2-client
+ newconfd "${FILESDIR}"/pvfs2-client-conf.d-2.7.0 pvfs2-client
+
+ dodoc AUTHORS CREDITS ChangeLog INSTALL README
+
+ # this is LARGE (~5mb)
+ if use doc; then
+ dodoc doc/multi-fs-doc.txt doc/add-server-req \
+ doc/add-client-syscall doc/coding/valgrind \
+ doc/coding/backtrace_analysis.txt
+ insinto /usr/share/doc/${PF}
+ doins doc/*.pdf doc/coding/developer-guidelines.pdf \
+ doc/design/*.pdf doc/random/SystemInterfaceTesting.pdf
+ if use apidocs; then
+ dohtml -A map -A md5 doc/doxygen/html/*
+ fi
+ fi
+ if use examples; then
+ docinto examples/heartbeat
+ dodoc examples/heartbeat/*
+ docinto examples
+ dodoc examples/fs.conf
+ fi
+}
+
+pkg_preinst() {
+ linux-mod_pkg_preinst
+}
+
+pkg_postinst() {
+ linux-mod_pkg_postinst
+ local f="$(source "${ROOT}"etc/conf.d/pvfs2-server; echo ${PVFS2_FS_CONF})"
+ elog "1.) Pvfs2 uses a unified configuration file as of 2.7.0. If you"
+ elog " have configuration files from an earlier version, use the provided:"
+ elog " ${ROOT}usr/bin/pvfs2-config-convert"
+ elog "to automatically update to the newer configuration scheme."
+ elog "2.) Use emerge --config pvfs2 to create new configuration files."
+ elog "3.) If the storage space has not been previously created, either set"
+ elog " PVFS2_AUTO_MKFS=1 in ${ROOT}etc/conf.d/pvfs2-server or run:"
+ elog " ${ROOT}usr/sbin/pvfs2-server --mkfs ${f}"
+}
+
+pkg_config() {
+ local s
+ local f="$(source "${ROOT}"etc/conf.d/pvfs2-server; echo ${PVFS2_FS_CONF})"
+ if [[ -f "${f}" ]]; then
+ ewarn "Previous install detected."
+ ewarn "We're about to wipe out ${f} and replace it with"
+ ewarn "the file generated by running pvfs2-genconfig. If this is what"
+ ewarn "you want to do, hit any key to continue. Otherwise hit ctrl+C"
+ ewarn "to abort."
+ read s
+ fi
+ einfo "Creating new unified configuration file"
+ ewarn "WARNING: pvfs2 is picky about hostnames. Make sure you use the"
+ ewarn "correct shortname for all nodes and have name resolution for these"
+ ewarn "shortnames correctly configured on all nodes."
+ [ ! -d "${ROOT}$(dirname "${f}")" ] && mkdir -p "${ROOT}$(dirname "${f}")"
+ "${ROOT}"usr/bin/pvfs2-genconfig "${f}"
+}