summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2005-02-22 06:45:40 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2005-02-22 06:45:40 +0000
commit012a78e367c2b53bb50995503d570bc2945a8cd3 (patch)
tree3e25120c8238dab99d8b7c4f208418fc149f669b /sys-cluster/pvm/pvm-3.4.5.ebuild
parentadded debug flag at user request (diff)
downloadgentoo-2-012a78e367c2b53bb50995503d570bc2945a8cd3.tar.gz
gentoo-2-012a78e367c2b53bb50995503d570bc2945a8cd3.tar.bz2
gentoo-2-012a78e367c2b53bb50995503d570bc2945a8cd3.zip
Bump. Attempt to fix miscellaneous issues, including weird, non-standard PVM_ARCH definitions (mentioned in #61017, among others). Nab some patches from Red Hat.
(Portage version: 2.0.51-r15)
Diffstat (limited to 'sys-cluster/pvm/pvm-3.4.5.ebuild')
-rw-r--r--sys-cluster/pvm/pvm-3.4.5.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/sys-cluster/pvm/pvm-3.4.5.ebuild b/sys-cluster/pvm/pvm-3.4.5.ebuild
new file mode 100644
index 000000000000..9d5c57127d85
--- /dev/null
+++ b/sys-cluster/pvm/pvm-3.4.5.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/pvm/pvm-3.4.5.ebuild,v 1.1 2005/02/22 06:45:40 spyderous Exp $
+
+inherit eutils
+
+MY_P="${P/-}"
+DESCRIPTION="PVM: Parallel Virtual Machine"
+HOMEPAGE="http://www.epm.ornl.gov/pvm/pvm_home.html"
+SRC_URI="ftp://ftp.netlib.org/pvm3/${MY_P}.tgz "
+IUSE=""
+DEPEND=""
+RDEPEND="virtual/libc"
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~x86 ~ppc ~amd64 ~ppc64 ~ia64 ~sparc"
+S="${WORKDIR}/${MY_P%%.*}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # Patches from Red Hat
+ epatch ${FILESDIR}/${P}-envvars.patch || die
+ epatch ${FILESDIR}/${P}-strerror.patch || die
+ epatch ${FILESDIR}/${P}-extra-arches.patch || die
+ epatch ${FILESDIR}/${P}-x86_64-segfault.patch || die
+
+# setup def files for other archs
+ cp conf/LINUX64.def conf/LINUXPPC64.def
+ cp conf/LINUX64.m4 conf/LINUXPPC64.m4
+
+# s390 should go in this list if there is ever interest
+# Patch the 64bit def files to look in lib64 dirs as well for libraries.
+ for I in 64 PPC64; do
+ sed -i -e "s|ARCHDLIB =|ARCHDLIB = -L/usr/lib64 -L/usr/X11R6/lib64 |" conf/LINUX${I}.def
+ sed -i -e "s|ARCHLIB =|ARCHLIB = -L/usr/lib64 -L/usr/X11R6/lib64 |" conf/LINUX${I}.def
+ done
+}
+
+src_compile() {
+ export PVM_ROOT="${S}"
+ emake || die
+}
+
+src_install() {
+ dodir /usr/share/man
+ rm man/man1 -fr
+ mv man/man3 ${D}/usr/share/man/
+ prepallman
+
+ dodoc Readme
+
+ #installs the rest of pvm
+ dodir /usr/share/pvm3
+ cp -r * ${D}/usr/share/pvm3
+
+ #environment variables:
+ echo PVM_ROOT=/usr/share/pvm3 > ${T}/98pvm
+ echo PVM_ARCH=$(${D}/usr/share/pvm3/lib/pvmgetarch) >> ${T}/98pvm
+ doenvd ${T}/98pvm
+}
+
+pkg_postinst() {
+ ewarn "Environment variables have changed. Do not forget to run etc-update,"
+ ewarn "reboot or perform . /etc/profile before using pvm!"
+}