summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2014-10-17 02:54:02 +0000
committerJustin Bronder <jsbronder@gentoo.org>2014-10-17 02:54:02 +0000
commit3e26a039b49139c2bc54c194ca3647839231e5c8 (patch)
tree90cff79a5319f2c910f702248c801e11a04c8dbd /sys-cluster/torque/torque-4.1.5.1-r1.ebuild
parentenable --enable-linker-build-id by default with gcc-4.5+ (diff)
downloadgentoo-2-3e26a039b49139c2bc54c194ca3647839231e5c8.tar.gz
gentoo-2-3e26a039b49139c2bc54c194ca3647839231e5c8.tar.bz2
gentoo-2-3e26a039b49139c2bc54c194ca3647839231e5c8.zip
Add blocker on dev-libs/uthash. Note that we should be just depending on it, but do to how upstream ships the tarfile, we cannot patch the build system. http://www.supercluster.org/pipermail/torquedev/2014-October/004773.html. #490000
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 4D7043C9)
Diffstat (limited to 'sys-cluster/torque/torque-4.1.5.1-r1.ebuild')
-rw-r--r--sys-cluster/torque/torque-4.1.5.1-r1.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/sys-cluster/torque/torque-4.1.5.1-r1.ebuild b/sys-cluster/torque/torque-4.1.5.1-r1.ebuild
index d98d772a3d1b..d931c037cf91 100644
--- a/sys-cluster/torque/torque-4.1.5.1-r1.ebuild
+++ b/sys-cluster/torque/torque-4.1.5.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/torque-4.1.5.1-r1.ebuild,v 1.9 2014/01/19 13:46:43 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/torque/torque-4.1.5.1-r1.ebuild,v 1.10 2014/10/17 02:54:02 jsbronder Exp $
EAPI=4
inherit flag-o-matic eutils linux-info
@@ -30,7 +30,13 @@ DEPEND="${DEPEND_COMMON}
RDEPEND="${DEPEND_COMMON}
crypt? ( net-misc/openssh )
- !crypt? ( net-misc/netkit-rsh )"
+ !crypt? ( net-misc/netkit-rsh )
+ !dev-libs/uthash"
+
+# Torque should depend on dev-libs/uthash but that's pretty much impossible
+# to patch in as they ship with a broken configure such that files referenced
+# by the configure.ac and Makefile.am are missing.
+# http://www.supercluster.org/pipermail/torquedev/2014-October/004773.html
pkg_setup() {
PBS_SERVER_HOME="${PBS_SERVER_HOME:-/var/spool/torque}"