summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2014-05-07 08:15:58 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2014-05-07 08:15:58 +0000
commit2dfa627a04de863f0c237764d16137a9a8814a6b (patch)
tree980d805e0a9cdac9316faac598d7ff498203a895 /sys-cluster/vzctl
parentAdd missing dependency on dev-perl/MP3-Info (bug #509408) (diff)
downloadgentoo-2-2dfa627a04de863f0c237764d16137a9a8814a6b.tar.gz
gentoo-2-2dfa627a04de863f0c237764d16137a9a8814a6b.tar.bz2
gentoo-2-2dfa627a04de863f0c237764d16137a9a8814a6b.zip
Bump to 4.7.2, thanks to slepnoga.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key F8DBDADE)
Diffstat (limited to 'sys-cluster/vzctl')
-rw-r--r--sys-cluster/vzctl/ChangeLog7
-rw-r--r--sys-cluster/vzctl/vzctl-4.7.2.ebuild93
2 files changed, 99 insertions, 1 deletions
diff --git a/sys-cluster/vzctl/ChangeLog b/sys-cluster/vzctl/ChangeLog
index c7ccd3b6c243..feed353d8e94 100644
--- a/sys-cluster/vzctl/ChangeLog
+++ b/sys-cluster/vzctl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/vzctl
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.123 2014/04/11 02:22:31 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.124 2014/05/07 08:15:58 maksbotan Exp $
+
+*vzctl-4.7.2 (07 May 2014)
+
+ 07 May 2014; Maxim Koltsov <maksbotan@gentoo.org> +vzctl-4.7.2.ebuild:
+ Bump to 4.7.2, thanks to slepnoga.
11 Apr 2014; Patrick Lauer <patrick@gentoo.org> metadata.xml:
Remove unneeded useflag descriptions from metadata.xml
diff --git a/sys-cluster/vzctl/vzctl-4.7.2.ebuild b/sys-cluster/vzctl/vzctl-4.7.2.ebuild
new file mode 100644
index 000000000000..58c75a4591d2
--- /dev/null
+++ b/sys-cluster/vzctl/vzctl-4.7.2.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-4.7.2.ebuild,v 1.1 2014/05/07 08:15:58 maksbotan Exp $
+
+EAPI="5"
+
+inherit base bash-completion-r1 eutils toolchain-funcs udev
+
+DESCRIPTION="OpenVZ ConTainers control utility"
+HOMEPAGE="http://openvz.org/"
+SRC_URI="http://download.openvz.org/utils/${PN}/${PV}/src/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~ppc64 -amd64-fbsd -x86-fbsd -sparc-fbsd"
+IUSE="+ploop +vz-kernel +vzmigrate"
+
+RDEPEND="net-firewall/iptables
+ sys-apps/ed
+ >=sys-apps/iproute2-3.3.0
+ vz-kernel? ( >=sys-fs/vzquota-3.1 )
+ ploop? (
+ >=sys-cluster/ploop-1.9
+ sys-block/parted
+ sys-fs/quota
+ )
+ >=dev-libs/libcgroup-0.38
+ vzmigrate? (
+ net-misc/openssh
+ net-misc/rsync[xattr,acl]
+ app-arch/tar[xattr,acl]
+ )
+ "
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ "
+
+src_prepare() {
+ # Set default OSTEMPLATE on gentoo
+ sed -i -e 's:=redhat-:=gentoo-:' etc/dists/default || die 'sed on etc/dists/default failed'
+ # Set proper udev directory
+ sed -i -e "s:/lib/udev:$(udev_get_udevdir):" src/lib/dev.c || die 'sed on src/lib/dev.c failed'
+}
+
+src_configure() {
+ econf \
+ --localstatedir=/var \
+ --enable-udev \
+ --enable-bashcomp \
+ --enable-logrotate \
+ --with-vz \
+ $(use_with ploop) \
+ --with-cgroup
+}
+
+src_install() {
+ emake DESTDIR="${D}" udevdir="$(udev_get_udevdir)"/rules.d install install-gentoo
+
+ # install the bash-completion script into the right location
+ rm -rf "${ED}"/etc/bash_completion.d
+ newbashcomp etc/bash_completion.d/vzctl.sh ${PN}
+
+ # We need to keep some dirs
+ keepdir /vz/{dump,lock,root,private,template/cache}
+ keepdir /etc/vz/names /var/lib/vzctl/veip
+}
+
+pkg_postinst() {
+ ewarn "To avoid loosing network to CTs on iface down/up, please, add the"
+ ewarn "following code to /etc/conf.d/net:"
+ ewarn " postup() {"
+ ewarn " /usr/sbin/vzifup-post \${IFACE}"
+ ewarn " }"
+
+ ewarn "Starting with 3.0.25 there is new vzeventd service to reboot CTs."
+ ewarn "Please remove /usr/share/vzctl/scripts/vpsnetclean and"
+ ewarn "/usr/share/vzctl/scripts/vpsreboot from crontab and use"
+ ewarn "/etc/init.d/vzeventd."
+
+ if !has_version sys-process/criu; then
+ einfo "If you want checkpoint suspend/restore feature in vanilla kernel"
+ einfo "please install sys-process/criu."
+ einfo "This is experimental and not stable (in Gentoo) at the moment."
+ fi
+
+ if !has_version app-arch/xz-utils; then
+ einfo "If you work with xz compressed templates, please install app-arch/xz-utils"
+ fi
+ if !has_version app-crypt/gnupg; then
+ einfo "If you want to check signature of donwloaded template, install app-crypt/gnupg"
+ fi
+}