summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2013-06-26 23:58:38 +0000
committerChristoph Junghans <ottxor@gentoo.org>2013-06-26 23:58:38 +0000
commit07d9f5bb07c87d8cd2103913fc1bb6d02f66dcec (patch)
tree234f7a50b1db2b8305f662842791900035faaf16 /sys-cluster
parentinitial import from sci overlay (diff)
downloadgentoo-2-07d9f5bb07c87d8cd2103913fc1bb6d02f66dcec.tar.gz
gentoo-2-07d9f5bb07c87d8cd2103913fc1bb6d02f66dcec.tar.bz2
gentoo-2-07d9f5bb07c87d8cd2103913fc1bb6d02f66dcec.zip
version bump (bug #432834)
(Portage version: 2.2.0_alpha185/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/charm/ChangeLog11
-rw-r--r--sys-cluster/charm/charm-6.5.0.ebuild178
-rw-r--r--sys-cluster/charm/metadata.xml6
3 files changed, 192 insertions, 3 deletions
diff --git a/sys-cluster/charm/ChangeLog b/sys-cluster/charm/ChangeLog
index b50ae919843b..ec5ebb5d3deb 100644
--- a/sys-cluster/charm/ChangeLog
+++ b/sys-cluster/charm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/charm
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/charm/ChangeLog,v 1.33 2012/07/01 14:12:34 jlec Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/charm/ChangeLog,v 1.34 2013/06/26 23:58:38 ottxor Exp $
+
+*charm-6.5.0 (26 Jun 2013)
+
+ 26 Jun 2013; Christoph Junghans <ottxor@gentoo.org> +charm-6.5.0.ebuild,
+ metadata.xml:
+ version bump (bug #432834)
01 Jul 2012; Justin Lecher <jlec@gentoo.org> charm-6.2.0.ebuild,
+files/charm-6.2.0-gcc-4.7.patch:
@@ -132,4 +138,3 @@
+charm-5.9.ebuild:
Initial import. Ebuild contributed by Markus Dittrich <markusle@gmail.com>
(bug #108031).
-
diff --git a/sys-cluster/charm/charm-6.5.0.ebuild b/sys-cluster/charm/charm-6.5.0.ebuild
new file mode 100644
index 000000000000..25982f85a5d4
--- /dev/null
+++ b/sys-cluster/charm/charm-6.5.0.ebuild
@@ -0,0 +1,178 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/charm/charm-6.5.0.ebuild,v 1.1 2013/06/26 23:58:38 ottxor Exp $
+
+EAPI=5
+
+inherit eutils flag-o-matic fortran-2 multilib toolchain-funcs
+
+DESCRIPTION="Message-passing parallel language and runtime system"
+HOMEPAGE="http://charm.cs.uiuc.edu/"
+SRC_URI="http://charm.cs.uiuc.edu/distrib/${P}.tar.gz"
+
+LICENSE="charm"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="charmdebug charmtracing charmproduction cmkopt doc examples mpi smp static-libs tcp"
+
+RDEPEND="mpi? ( virtual/mpi )"
+DEPEND="
+ ${RDEPEND}
+ doc? (
+ >=app-text/poppler-0.12.3-r3[utils]
+ dev-tex/latex2html
+ virtual/tex-base
+ )"
+
+REQUIRED_USE="
+ cmkopt? ( !charmdebug !charmtracing )
+ charmproduction? ( !charmdebug !charmtracing )"
+
+FORTRAN_STANDARD="90"
+
+src_prepare() {
+ # Build shared libraries by default.
+ CHARM_OPTS="--build-shared"
+ if use charmproduction; then
+ CHARM_OPTS+=" --with-production"
+ else
+ if use charmdebug; then
+ CHARM_OPTS+=" --with-charmdebug"
+ fi
+
+ if use charmtracing; then
+ CHARM_OPTS+=" --with-tracing --with-tracing-commthread"
+ fi
+ fi
+
+ # TCP instead of default UDP for socket comunication
+ # protocol
+ CHARM_OPTS+="$(usex tcp ' tcp' '')"
+
+ # enable direct SMP support using shared memory
+ CHARM_OPTS+="$(usex smp ' smp' '')"
+
+ # CMK optimization
+ use cmkopt && append-cppflags -DCMK_OPTIMIZE=1
+
+ sed \
+ -e "/CMK_CF90/s:f90:$(usex mpi "mpif90" "$(tc-getFC)"):g" \
+ -e "/CMK_CXX/s:g++:$(usex mpi "mpic++" "$(tc-getCXX)"):g" \
+ -e "/CMK_CC/s:gcc:$(usex mpi "mpicc" "$(tc-getCC)"):g" \
+ -e '/CMK_F90_MODINC/s:-p:-I:g' \
+ -e "/CMK_LD/s:\"$: ${LDFLAGS} \":g" \
+ -i src/arch/$(usex mpi "mpi" "net")-linux*/*sh || die
+
+ sed \
+ -e "s:-o conv-cpm:${LDFLAGS} &:g" \
+ -e "s:-o charmxi:${LDFLAGS} &:g" \
+ -e "s:-o charmrun-silent:${LDFLAGS} &:g" \
+ -e "s:-o charmrun-notify:${LDFLAGS} &:g" \
+ -e "s:-o charmrun:${LDFLAGS} &:g" \
+ -e "s:-o charmd_faceless:${LDFLAGS} &:g" \
+ -e "s:-o charmd:${LDFLAGS} &:g" \
+ -i \
+ src/scripts/Makefile \
+ src/arch/net/charmrun/Makefile || die
+
+ einfo "charm opts: ${CHARM_OPTS}"
+}
+
+src_compile() {
+ # Build charmm++ first.
+ ./build charm++ $(usex mpi "mpi" "net")-linux$(usex amd64 "-amd64" '') \
+ ${CHARM_OPTS} ${MAKEOPTS} ${CFLAGS} || die "Failed to build charm++"
+
+ # make pdf/html docs
+ if use doc; then
+ cd "${S}"/doc
+ make doc || die "failed to create pdf/html docs"
+ fi
+}
+
+src_test() {
+ make -C tests/charm++ test TESTOPTS="++local" || die
+}
+
+src_install() {
+ # Make charmc play well with gentoo before we move it into /usr/bin.
+ epatch "${FILESDIR}/charm-6.5.0-charmc-gentoo.patch"
+
+ sed -e "s|gentoo-include|${P}|" \
+ -e "s|gentoo-libdir|$(get_libdir)|g" \
+ -e "s|VERSION|${P}/VERSION|" \
+ -i ./src/scripts/charmc || die "failed patching charmc script"
+
+ # In the following, some of the files are symlinks to ../tmp which we need
+ # to dereference first (see bug 432834).
+
+ local i
+
+ # Install binaries.
+ for i in bin/*; do
+ if [[ -L ${i} ]]; then
+ i=$(readlink -e "${i}") || die
+ fi
+ dobin "${i}"
+ done
+
+ # Install headers.
+ insinto /usr/include/${P}
+ for i in include/*; do
+ if [[ -L ${i} ]]; then
+ i=$(readlink -e "${i}") || die
+ fi
+ doins "${i}"
+ done
+
+ # Install static libs. Charm has a lot of .o "libs" that it requires at
+ # runtime.
+ if use static-libs; then
+ for i in lib/*.{a,o}; do
+ if [[ -L ${i} ]]; then
+ i=$(readlink -e "${i}") || die
+ fi
+ dolib "${i}"
+ done
+ fi
+
+ # Install shared libs.
+ for i in lib_so/*; do
+ if [[ -L ${i} ]]; then
+ i=$(readlink -e "${i}") || die
+ fi
+ dolib.so "${i}"
+ done
+
+ # Basic docs.
+ dodoc CHANGES README
+
+ # Install examples.
+ if use examples; then
+ find examples/ -name 'Makefile' | xargs sed \
+ -r "s:(../)+bin/charmc:/usr/bin/charmc:" -i || \
+ die "Failed to fix examples"
+ find examples/ -name 'Makefile' | xargs sed \
+ -r "s:./charmrun:./charmrun ++local:" -i || \
+ die "Failed to fix examples"
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/charm++/*
+ fi
+
+ # Install pdf/html docs
+ if use doc; then
+ cd "${S}"/doc
+ # Install pdfs.
+ insinto /usr/share/doc/${PF}/pdf
+ doins doc/pdf/*
+ # Install html.
+ docinto html
+ dohtml -r doc/html/*
+ fi
+}
+
+pkg_postinst() {
+ einfo "Please test your charm installation by copying the"
+ einfo "content of /usr/share/doc/${PF}/examples to a"
+ einfo "temporary location and run 'make test'."
+}
diff --git a/sys-cluster/charm/metadata.xml b/sys-cluster/charm/metadata.xml
index f555a9f50c29..ea5896e21a07 100644
--- a/sys-cluster/charm/metadata.xml
+++ b/sys-cluster/charm/metadata.xml
@@ -2,7 +2,13 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>sci</herd>
+ <maintainer>
+ <email>nicolasbock@gmail.com</email>
+ </maintainer>
<use>
+ <flag name="charmdebug">Enable the charm debugger</flag>
+ <flag name="charmproduction">Optimize performance of Charm++ runtime</flag>
+ <flag name="charmtracing">Enable tracing support in Charm++</flag>
<flag name="cmkopt">Enable CMK optimisation</flag>
<flag name="tcp">Use TCP (instead of UPD) for socket communication</flag>
</use>