summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2009-04-17 15:48:09 +0000
committerJustin Bronder <jsbronder@gentoo.org>2009-04-17 15:48:09 +0000
commit0a87047029d2ebbe180cc66fef16908f5017add1 (patch)
treeb1535afc9ab6f6c2f196339bf60e7ea0627fc75d /sys-cluster
parentMarking mod_mono-2.2 ~ppc for bug 255410 (diff)
downloadgentoo-2-0a87047029d2ebbe180cc66fef16908f5017add1.tar.gz
gentoo-2-0a87047029d2ebbe180cc66fef16908f5017add1.tar.bz2
gentoo-2-0a87047029d2ebbe180cc66fef16908f5017add1.zip
Cleanup old versions.
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/openmpi/ChangeLog7
-rw-r--r--sys-cluster/openmpi/openmpi-1.2.5.ebuild91
-rw-r--r--sys-cluster/openmpi/openmpi-1.2.6.ebuild98
-rw-r--r--sys-cluster/openmpi/openmpi-1.2.7-r1.ebuild108
-rw-r--r--sys-cluster/openmpi/openmpi-1.2.7.ebuild97
-rw-r--r--sys-cluster/openmpi/openmpi-1.2.8.ebuild108
-rw-r--r--sys-cluster/openmpi/openmpi-1.3.ebuild117
7 files changed, 6 insertions, 620 deletions
diff --git a/sys-cluster/openmpi/ChangeLog b/sys-cluster/openmpi/ChangeLog
index 43e0dcbcecd6..b38d79096e91 100644
--- a/sys-cluster/openmpi/ChangeLog
+++ b/sys-cluster/openmpi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/openmpi
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/ChangeLog,v 1.40 2009/03/25 15:52:58 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/ChangeLog,v 1.41 2009/04/17 15:48:09 jsbronder Exp $
+
+ 17 Apr 2009; Justin Bronder <jsbronder@gentoo.org> -openmpi-1.2.5.ebuild,
+ -openmpi-1.2.6.ebuild, -openmpi-1.2.7.ebuild, -openmpi-1.2.7-r1.ebuild,
+ -openmpi-1.2.8.ebuild, -openmpi-1.3.ebuild:
+ Cleanup old versions.
25 Mar 2009; Justin Bronder <jsbronder@gentoo.org> openmpi-1.3.1.ebuild:
Fix #257086 again. The previous fix was copied incorrectly from the ebuild
diff --git a/sys-cluster/openmpi/openmpi-1.2.5.ebuild b/sys-cluster/openmpi/openmpi-1.2.5.ebuild
deleted file mode 100644
index 5d916c5b166f..000000000000
--- a/sys-cluster/openmpi/openmpi-1.2.5.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.2.5.ebuild,v 1.5 2008/04/18 20:35:22 jsbronder Exp $
-
-inherit eutils multilib flag-o-matic toolchain-funcs fortran
-
-MY_P=${P/-mpi}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="A high-performance message passing library (MPI)"
-HOMEPAGE="http://www.open-mpi.org"
-SRC_URI="http://www.open-mpi.org/software/ompi/v1.2/downloads/${MY_P}.tar.bz2"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~ppc64 ~sparc ~x86 ~ppc"
-IUSE="pbs fortran nocxx threads romio heterogeneous smp ipv6"
-RDEPEND="pbs? ( sys-cluster/torque )
- !sys-cluster/mpich
- !sys-cluster/lam-mpi
- !sys-cluster/mpich2"
-DEPEND="${RDEPEND}"
-
-pkg_setup() {
- if use threads; then
- ewarn
- ewarn "WARNING: use of threads is still disabled by default in"
- ewarn "upstream builds."
- ewarn "You may stop now and set USE=-threads"
- ewarn
- epause 5
- fi
-
- elog
- elog "OpenMPI has an overwhelming count of configuration options."
- elog "Don't forget the EXTRA_ECONF environment variable can let you"
- elog "specify configure options if you find them necessary."
- elog
-
- if use fortran; then
- FORTRAN="g77 gfortran ifc"
- fortran_pkg_setup
- fi
-}
-
-src_compile() {
- local myconf="
- --sysconfdir=/etc/${PN}
- --without-xgrid
- --enable-pretty-print-stacktrace
- --enable-orterun-prefix-by-default
- --without-slurm"
-
- if use threads; then
- myconf="${myconf}
- --enable-mpi-threads
- --with-progress-threads
- --with-threads=posix"
- fi
-
- if use fortran; then
- if [[ "${FORTRANC}" = "g77" ]]; then
- myconf="${myconf} --disable-mpi-f90"
- elif [[ "${FORTRANC}" = "gfortran" ]]; then
- # Because that's just a pain in the butt.
- myconf="${myconf} --with-wrapper-fflags=-I/usr/include"
- elif [[ "${FORTRANC}" = if* ]]; then
- # Enabled here as gfortran compile times are huge with this enabled.
- myconf="${myconf} --with-mpi-f90-size=medium"
- fi
- else
- myconf="${myconf}
- --disable-mpi-f90
- --disable-mpi-f77"
- fi
-
- econf ${myconf} \
- $(use_enable !nocxx mpi-cxx) \
- $(use_enable romio romio-io) \
- $(use_enable smp smp-locks) \
- $(use_enable heterogeneous) \
- $(use_with pbs tm) \
- $(use_enable ipv6) \
- || die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc README AUTHORS NEWS VERSION
-}
diff --git a/sys-cluster/openmpi/openmpi-1.2.6.ebuild b/sys-cluster/openmpi/openmpi-1.2.6.ebuild
deleted file mode 100644
index 15c8133139a7..000000000000
--- a/sys-cluster/openmpi/openmpi-1.2.6.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.2.6.ebuild,v 1.7 2008/06/25 14:53:03 jsbronder Exp $
-
-inherit eutils multilib flag-o-matic toolchain-funcs fortran
-
-MY_P=${P/-mpi}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="A high-performance message passing library (MPI)"
-HOMEPAGE="http://www.open-mpi.org"
-SRC_URI="http://www.open-mpi.org/software/ompi/v1.2/downloads/${MY_P}.tar.bz2"
-LICENSE="BSD"
-SLOT="0"
-RESTRICT="threads? ( test )"
-KEYWORDS="~alpha ~amd64 ppc ppc64 sparc x86"
-IUSE="pbs fortran nocxx threads romio heterogeneous smp ipv6"
-RDEPEND="pbs? ( sys-cluster/torque )
- !sys-cluster/mpich
- !sys-cluster/lam-mpi
- !sys-cluster/mpich2"
-DEPEND="${RDEPEND}"
-
-pkg_setup() {
- if use threads; then
- ewarn
- ewarn "WARNING: use of threads is still disabled by default in"
- ewarn "upstream builds."
- ewarn "You may stop now and set USE=-threads"
- ewarn
- epause 5
- fi
-
- elog
- elog "OpenMPI has an overwhelming count of configuration options."
- elog "Don't forget the EXTRA_ECONF environment variable can let you"
- elog "specify configure options if you find them necessary."
- elog
-
- if use fortran; then
- FORTRAN="g77 gfortran ifc"
- fortran_pkg_setup
- fi
-}
-
-src_compile() {
- local myconf="
- --sysconfdir=/etc/${PN}
- --without-xgrid
- --enable-pretty-print-stacktrace
- --enable-orterun-prefix-by-default
- --without-slurm"
-
- if use threads; then
- myconf="${myconf}
- --enable-mpi-threads
- --with-progress-threads
- --with-threads=posix"
- fi
-
- if use fortran; then
- if [[ "${FORTRANC}" = "g77" ]]; then
- myconf="${myconf} --disable-mpi-f90"
- elif [[ "${FORTRANC}" = "gfortran" ]]; then
- # Because that's just a pain in the butt.
- myconf="${myconf} --with-wrapper-fflags=-I/usr/include"
- elif [[ "${FORTRANC}" = if* ]]; then
- # Enabled here as gfortran compile times are huge with this enabled.
- myconf="${myconf} --with-mpi-f90-size=medium"
- fi
- else
- myconf="${myconf}
- --disable-mpi-f90
- --disable-mpi-f77"
- fi
-
- econf ${myconf} \
- $(use_enable !nocxx mpi-cxx) \
- $(use_enable romio io-romio) \
- $(use_enable smp smp-locks) \
- $(use_enable heterogeneous) \
- $(use_with pbs tm) \
- $(use_enable ipv6) \
- || die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc README AUTHORS NEWS VERSION
-}
-
-src_test() {
- # Doesn't work with the default src_test as the dry run (-n) fails.
- cd "${S}"
- emake -j1 check || die "emake check failed"
-}
diff --git a/sys-cluster/openmpi/openmpi-1.2.7-r1.ebuild b/sys-cluster/openmpi/openmpi-1.2.7-r1.ebuild
deleted file mode 100644
index 27c31558dc47..000000000000
--- a/sys-cluster/openmpi/openmpi-1.2.7-r1.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.2.7-r1.ebuild,v 1.1 2008/09/12 14:34:02 jsbronder Exp $
-
-inherit eutils multilib flag-o-matic toolchain-funcs fortran
-
-MY_P=${P/-mpi}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="A high-performance message passing library (MPI)"
-HOMEPAGE="http://www.open-mpi.org"
-SRC_URI="http://www.open-mpi.org/software/ompi/v1.2/downloads/${MY_P}.tar.bz2"
-LICENSE="BSD"
-SLOT="0"
-RESTRICT="mpi-threads? ( test )"
-KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="fortran heterogeneous ipv6 mpi-threads nocxx pbs romio threads"
-RDEPEND="pbs? ( sys-cluster/torque )
- !sys-cluster/mpich
- !sys-cluster/lam-mpi
- !sys-cluster/mpich2"
-DEPEND="${RDEPEND}"
-
-pkg_setup() {
- if use mpi-threads; then
- ewarn
- ewarn "WARNING: use of MPI_THREAD_MULTIPLE is still disabled by"
- ewarn "default and officially unsupported by upstream."
- ewarn "You may stop now and set USE=-mpi-threads"
- ewarn
- epause 5
- fi
-
- elog
- elog "OpenMPI has an overwhelming count of configuration options."
- elog "Don't forget the EXTRA_ECONF environment variable can let you"
- elog "specify configure options if you find them necessary."
- elog
-
- if use fortran; then
- FORTRAN="g77 gfortran ifc"
- fortran_pkg_setup
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Necessary for scalibility, see
- # http://www.open-mpi.org/community/lists/users/2008/09/6514.php
- if use threads; then
- echo 'oob_tcp_listen_mode = listen_thread' \
- >> opal/etc/openmpi-mca-params.conf
- fi
-}
-
-src_compile() {
- local myconf="
- --sysconfdir=/etc/${PN}
- --without-xgrid
- --enable-pretty-print-stacktrace
- --enable-orterun-prefix-by-default
- --without-slurm"
-
- if use mpi-threads; then
- myconf="${myconf}
- --enable-mpi-threads
- --with-progress-threads"
- fi
-
- if use fortran; then
- if [[ "${FORTRANC}" = "g77" ]]; then
- myconf="${myconf} --disable-mpi-f90"
- elif [[ "${FORTRANC}" = "gfortran" ]]; then
- # Because that's just a pain in the butt.
- myconf="${myconf} --with-wrapper-fflags=-I/usr/include"
- elif [[ "${FORTRANC}" = if* ]]; then
- # Enabled here as gfortran compile times are huge with this enabled.
- myconf="${myconf} --with-mpi-f90-size=medium"
- fi
- else
- myconf="${myconf}
- --disable-mpi-f90
- --disable-mpi-f77"
- fi
-
- econf ${myconf} \
- $(use_enable !nocxx mpi-cxx) \
- $(use_enable romio io-romio) \
- $(use_enable heterogeneous) \
- $(use_with pbs tm) \
- $(use_enable ipv6) \
- || die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc README AUTHORS NEWS VERSION
-}
-
-src_test() {
- # Doesn't work with the default src_test as the dry run (-n) fails.
- cd "${S}"
- emake -j1 check || die "emake check failed"
-}
diff --git a/sys-cluster/openmpi/openmpi-1.2.7.ebuild b/sys-cluster/openmpi/openmpi-1.2.7.ebuild
deleted file mode 100644
index 59f6e7d3d688..000000000000
--- a/sys-cluster/openmpi/openmpi-1.2.7.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.2.7.ebuild,v 1.1 2008/08/31 20:20:42 jsbronder Exp $
-
-inherit eutils multilib flag-o-matic toolchain-funcs fortran
-
-MY_P=${P/-mpi}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="A high-performance message passing library (MPI)"
-HOMEPAGE="http://www.open-mpi.org"
-SRC_URI="http://www.open-mpi.org/software/ompi/v1.2/downloads/${MY_P}.tar.bz2"
-LICENSE="BSD"
-SLOT="0"
-RESTRICT="threads? ( test )"
-KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="pbs fortran nocxx threads romio heterogeneous ipv6"
-RDEPEND="pbs? ( sys-cluster/torque )
- !sys-cluster/mpich
- !sys-cluster/lam-mpi
- !sys-cluster/mpich2"
-DEPEND="${RDEPEND}"
-
-pkg_setup() {
- if use threads; then
- ewarn
- ewarn "WARNING: use of threads is still disabled by default in"
- ewarn "upstream builds."
- ewarn "You may stop now and set USE=-threads"
- ewarn
- epause 5
- fi
-
- elog
- elog "OpenMPI has an overwhelming count of configuration options."
- elog "Don't forget the EXTRA_ECONF environment variable can let you"
- elog "specify configure options if you find them necessary."
- elog
-
- if use fortran; then
- FORTRAN="g77 gfortran ifc"
- fortran_pkg_setup
- fi
-}
-
-src_compile() {
- local myconf="
- --sysconfdir=/etc/${PN}
- --without-xgrid
- --enable-pretty-print-stacktrace
- --enable-orterun-prefix-by-default
- --without-slurm"
-
- if use threads; then
- myconf="${myconf}
- --enable-mpi-threads
- --with-progress-threads
- --with-threads=posix"
- fi
-
- if use fortran; then
- if [[ "${FORTRANC}" = "g77" ]]; then
- myconf="${myconf} --disable-mpi-f90"
- elif [[ "${FORTRANC}" = "gfortran" ]]; then
- # Because that's just a pain in the butt.
- myconf="${myconf} --with-wrapper-fflags=-I/usr/include"
- elif [[ "${FORTRANC}" = if* ]]; then
- # Enabled here as gfortran compile times are huge with this enabled.
- myconf="${myconf} --with-mpi-f90-size=medium"
- fi
- else
- myconf="${myconf}
- --disable-mpi-f90
- --disable-mpi-f77"
- fi
-
- econf ${myconf} \
- $(use_enable !nocxx mpi-cxx) \
- $(use_enable romio io-romio) \
- $(use_enable heterogeneous) \
- $(use_with pbs tm) \
- $(use_enable ipv6) \
- || die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc README AUTHORS NEWS VERSION
-}
-
-src_test() {
- # Doesn't work with the default src_test as the dry run (-n) fails.
- cd "${S}"
- emake -j1 check || die "emake check failed"
-}
diff --git a/sys-cluster/openmpi/openmpi-1.2.8.ebuild b/sys-cluster/openmpi/openmpi-1.2.8.ebuild
deleted file mode 100644
index 3d0bee28cfd9..000000000000
--- a/sys-cluster/openmpi/openmpi-1.2.8.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.2.8.ebuild,v 1.1 2008/10/19 20:00:56 jsbronder Exp $
-
-inherit eutils multilib flag-o-matic toolchain-funcs fortran
-
-MY_P=${P/-mpi}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="A high-performance message passing library (MPI)"
-HOMEPAGE="http://www.open-mpi.org"
-SRC_URI="http://www.open-mpi.org/software/ompi/v1.2/downloads/${MY_P}.tar.bz2"
-LICENSE="BSD"
-SLOT="0"
-RESTRICT="mpi-threads? ( test )"
-KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="fortran heterogeneous ipv6 mpi-threads nocxx pbs romio threads"
-RDEPEND="pbs? ( sys-cluster/torque )
- !sys-cluster/mpich
- !sys-cluster/lam-mpi
- !sys-cluster/mpich2"
-DEPEND="${RDEPEND}"
-
-pkg_setup() {
- if use mpi-threads; then
- ewarn
- ewarn "WARNING: use of MPI_THREAD_MULTIPLE is still disabled by"
- ewarn "default and officially unsupported by upstream."
- ewarn "You may stop now and set USE=-mpi-threads"
- ewarn
- epause 5
- fi
-
- elog
- elog "OpenMPI has an overwhelming count of configuration options."
- elog "Don't forget the EXTRA_ECONF environment variable can let you"
- elog "specify configure options if you find them necessary."
- elog
-
- if use fortran; then
- FORTRAN="g77 gfortran ifc"
- fortran_pkg_setup
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Necessary for scalibility, see
- # http://www.open-mpi.org/community/lists/users/2008/09/6514.php
- if use threads; then
- echo 'oob_tcp_listen_mode = listen_thread' \
- >> opal/etc/openmpi-mca-params.conf
- fi
-}
-
-src_compile() {
- local myconf="
- --sysconfdir=/etc/${PN}
- --without-xgrid
- --enable-pretty-print-stacktrace
- --enable-orterun-prefix-by-default
- --without-slurm"
-
- if use mpi-threads; then
- myconf="${myconf}
- --enable-mpi-threads
- --with-progress-threads"
- fi
-
- if use fortran; then
- if [[ "${FORTRANC}" = "g77" ]]; then
- myconf="${myconf} --disable-mpi-f90"
- elif [[ "${FORTRANC}" = "gfortran" ]]; then
- # Because that's just a pain in the butt.
- myconf="${myconf} --with-wrapper-fflags=-I/usr/include"
- elif [[ "${FORTRANC}" = if* ]]; then
- # Enabled here as gfortran compile times are huge with this enabled.
- myconf="${myconf} --with-mpi-f90-size=medium"
- fi
- else
- myconf="${myconf}
- --disable-mpi-f90
- --disable-mpi-f77"
- fi
-
- econf ${myconf} \
- $(use_enable !nocxx mpi-cxx) \
- $(use_enable romio io-romio) \
- $(use_enable heterogeneous) \
- $(use_with pbs tm) \
- $(use_enable ipv6) \
- || die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc README AUTHORS NEWS VERSION
-}
-
-src_test() {
- # Doesn't work with the default src_test as the dry run (-n) fails.
- cd "${S}"
- emake -j1 check || die "emake check failed"
-}
diff --git a/sys-cluster/openmpi/openmpi-1.3.ebuild b/sys-cluster/openmpi/openmpi-1.3.ebuild
deleted file mode 100644
index c7e69e647670..000000000000
--- a/sys-cluster/openmpi/openmpi-1.3.ebuild
+++ /dev/null
@@ -1,117 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.3.ebuild,v 1.3 2009/02/22 19:51:13 jsbronder Exp $
-
-EAPI=1
-inherit eutils multilib flag-o-matic toolchain-funcs fortran
-
-MY_P=${P/-mpi}
-S=${WORKDIR}/${MY_P}
-
-DESCRIPTION="A high-performance message passing library (MPI)"
-HOMEPAGE="http://www.open-mpi.org"
-SRC_URI="http://www.open-mpi.org/software/ompi/v1.3/downloads/${MY_P}.tar.bz2"
-LICENSE="BSD"
-SLOT="0"
-RESTRICT="mpi-threads? ( test )"
-KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="+cxx fortran heterogeneous ipv6 mpi-threads pbs romio threads"
-RDEPEND="pbs? ( sys-cluster/torque )
- !sys-cluster/mpich
- !sys-cluster/lam-mpi
- !sys-cluster/mpich2
- !sys-cluster/mpiexec"
-DEPEND="${RDEPEND}"
-
-pkg_setup() {
- if use mpi-threads; then
- ewarn
- ewarn "WARNING: use of MPI_THREAD_MULTIPLE is still disabled by"
- ewarn "default and officially unsupported by upstream."
- ewarn "You may stop now and set USE=-mpi-threads"
- ewarn
- epause 5
- fi
-
- elog
- elog "OpenMPI has an overwhelming count of configuration options."
- elog "Don't forget the EXTRA_ECONF environment variable can let you"
- elog "specify configure options if you find them necessary."
- elog
-
- if use fortran; then
- FORTRAN="g77 gfortran ifc"
- fortran_pkg_setup
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Necessary for scalibility, see
- # http://www.open-mpi.org/community/lists/users/2008/09/6514.php
- if use threads; then
- echo 'oob_tcp_listen_mode = listen_thread' \
- >> opal/etc/openmpi-mca-params.conf
- fi
-}
-
-src_compile() {
- local myconf="
- --sysconfdir=/etc/${PN}
- --without-xgrid
- --enable-pretty-print-stacktrace
- --enable-orterun-prefix-by-default
- --without-slurm"
-
- if use mpi-threads; then
- myconf="${myconf}
- --enable-mpi-threads
- --with-progress-threads"
- fi
-
- if use fortran; then
- if [[ "${FORTRANC}" = "g77" ]]; then
- myconf="${myconf} --disable-mpi-f90"
- elif [[ "${FORTRANC}" = "gfortran" ]]; then
- # Because that's just a pain in the butt.
- myconf="${myconf} --with-wrapper-fflags=-I/usr/include"
- elif [[ "${FORTRANC}" = if* ]]; then
- # Enabled here as gfortran compile times are huge with this enabled.
- myconf="${myconf} --with-mpi-f90-size=medium"
- fi
- else
- myconf="${myconf}
- --disable-mpi-f90
- --disable-mpi-f77"
- fi
-
- # 256529 Vampir Trace doesn't build on sparc.
- # http://www.open-mpi.org/faq/?category=vampirtrace
- use sparc && myconf="${myconf} --enable-contrib-no-build=vt"
-
- # Push Vampir Trace includes to a subdir.
- c="${c} --with-contrib-vt-flags=\"--includedir=/usr/include/vt\""
-
- econf ${myconf} \
- $(use_enable cxx mpi-cxx) \
- $(use_enable romio io-romio) \
- $(use_enable heterogeneous) \
- $(use_with pbs tm) \
- $(use_enable ipv6) \
- || die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_install () {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc README AUTHORS NEWS VERSION
-}
-
-src_test() {
- # Doesn't work with the default src_test as the dry run (-n) fails.
- cd "${S}"
- emake -j1 check || die "emake check failed"
-}