summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Imhof <tantive@gentoo.org>2003-07-10 11:18:00 +0000
committerMichael Imhof <tantive@gentoo.org>2003-07-10 11:18:00 +0000
commit0c550cccfb39370c3818af825be8d09371bdf806 (patch)
treea59777799136e5c6bba5bb284b3bc36cd52e0f2f /sys-cluster
parentShould close #24198. (diff)
downloadgentoo-2-0c550cccfb39370c3818af825be8d09371bdf806.tar.gz
gentoo-2-0c550cccfb39370c3818af825be8d09371bdf806.tar.bz2
gentoo-2-0c550cccfb39370c3818af825be8d09371bdf806.zip
Should close #24198.
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/xpvm/ChangeLog9
-rw-r--r--sys-cluster/xpvm/Manifest2
-rw-r--r--sys-cluster/xpvm/files/digest-xpvm-1.2.5-r11
-rw-r--r--sys-cluster/xpvm/xpvm-1.2.5-r1.ebuild64
4 files changed, 74 insertions, 2 deletions
diff --git a/sys-cluster/xpvm/ChangeLog b/sys-cluster/xpvm/ChangeLog
index d775d72ed301..069e65cd797e 100644
--- a/sys-cluster/xpvm/ChangeLog
+++ b/sys-cluster/xpvm/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-cluster/xpvm
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/xpvm/ChangeLog,v 1.2 2003/06/27 13:39:57 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/xpvm/ChangeLog,v 1.3 2003/07/10 11:17:41 tantive Exp $
+
+*xpvm-1.2.5-r1 (10 Jul 2003)
+
+ 10 Jul 2003; Michael Imhof <tantive@gentoo.org>:
+ Submitted by the <the@weird-birds.org>.
+ Should close #24198.
+
*xpvm-1.2.5 (22 Jun 2003)
diff --git a/sys-cluster/xpvm/Manifest b/sys-cluster/xpvm/Manifest
index 97e2a364e668..c184faaa96e2 100644
--- a/sys-cluster/xpvm/Manifest
+++ b/sys-cluster/xpvm/Manifest
@@ -1,5 +1,5 @@
MD5 f98f1e822673bb15499b1a1f0f4046cb xpvm-1.2.5.ebuild 1516
-MD5 52d5fec6ed95a0c58402d0eadc077dd8 ChangeLog 376
+MD5 747127579edb7df7dfed8a75818b8462 ChangeLog 527
MD5 c27701d17dc82621b8d26122015fc9f0 xpvm-1.2.5-r1.ebuild 1437
MD5 4844e6d445655538fdc6b850dc33e539 files/xpvm-1.2.5-gentoo.diff 2910
MD5 915d49a269c55c9d68cf0d7d30f1b272 files/digest-xpvm-1.2.5 63
diff --git a/sys-cluster/xpvm/files/digest-xpvm-1.2.5-r1 b/sys-cluster/xpvm/files/digest-xpvm-1.2.5-r1
new file mode 100644
index 000000000000..b9694694f22c
--- /dev/null
+++ b/sys-cluster/xpvm/files/digest-xpvm-1.2.5-r1
@@ -0,0 +1 @@
+MD5 7b20143cb2ff61e3cb28baf8f9cb2770 XPVM.src.1.2.5.tgz 196004
diff --git a/sys-cluster/xpvm/xpvm-1.2.5-r1.ebuild b/sys-cluster/xpvm/xpvm-1.2.5-r1.ebuild
new file mode 100644
index 000000000000..2e232483a25c
--- /dev/null
+++ b/sys-cluster/xpvm/xpvm-1.2.5-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header:
+
+S=${WORKDIR}/${P}
+DESCRIPTION="XPVM: A graphical console and monitor for PVM"
+SRC_URI="http://www.netlib.org/pvm3/xpvm/XPVM.src.1.2.5.tgz"
+HOMEPAGE="http://www.csm.ornl.gov/pvm/pvm_home.html"
+IUSE=""
+
+DEPEND=">=sys-cluster/pvm-3.4.1-r1
+ =dev-lang/tcl-8.3.4
+ =dev-lang/tk-8.3.4"
+RDEPEND=""
+
+SLOT="0"
+KEYWORDS="~x86"
+LICENSE="LGPL-2"
+
+src_unpack() {
+ unpack ${A}
+ patch -p0 <${FILESDIR}/xpvm-1.2.5-gentoo.diff || die
+}
+
+src_compile() {
+ cd ${WORKDIR}/xpvm
+
+ export PVM_ROOT="/usr/local/pvm3"
+ export PVM_ARCH="LINUX"
+ export XPVM_ROOT=${WORKDIR}"/xpvm"
+
+ emake xpvm || die
+}
+
+src_install() {
+ cd ${WORKDIR}/xpvm
+ dodir ${PVM_ROOT}"/xpvm"
+ dodir ${PVM_ROOT}"/bin/"${PVM_ARCH}
+ dodir "/usr/bin"
+
+ export XPVM_ROOT=${PVM_ROOT}"/xpvm"
+
+ #create symlinks to xpvm binary
+ dosym ${XPVM_ROOT}"/src/"${PVM_ARCH}"/xpvm" ${PVM_ROOT}"/bin/"${PVM_ARCH}"/xpvm"
+ dosym ${XPVM_ROOT}"/src/"${PVM_ARCH}"/xpvm" "/usr/bin/xpvm"
+
+ #install headers and libs and binary
+ export PVM_ROOT=${D}"/usr/local/pvm3"
+ cp ${WORKDIR}/xpvm ${PVM_ROOT} -r
+
+ #environment variables:
+ touch 97xpvm
+ echo XPVM_ROOT=/usr/local/pvm3/xpvm/src >>97xpvm
+ insinto /etc/env.d
+ doins 97xpvm
+
+ dodoc README
+}
+
+pkg_postinst() {
+ ewarn "Environment Variables have changed. Do not forget to reboot or perform"
+ ewarn "source /etc/profile before using xpvm !"
+}
+