summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2006-04-24 14:53:35 +0000
committerChristian Heim <phreak@gentoo.org>2006-04-24 14:53:35 +0000
commit166e739df436cc0e2e29a57d1ea340e12bffbb2d (patch)
tree3e5a13341d73cdd0b22fc170c8a565a25cb84124 /sys-cluster
parentMark 1.0.11 stable on ia64 (diff)
downloadgentoo-2-166e739df436cc0e2e29a57d1ea340e12bffbb2d.tar.gz
gentoo-2-166e739df436cc0e2e29a57d1ea340e12bffbb2d.tar.bz2
gentoo-2-166e739df436cc0e2e29a57d1ea340e12bffbb2d.zip
Version bump, see http://openvz.org/news/updates/vzctl-3.0.0-8 for a detailed ChangeLog
(Portage version: 2.1_pre9-r4)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/vzctl/ChangeLog8
-rw-r--r--sys-cluster/vzctl/files/digest-vzctl-3.0.0.86
-rw-r--r--sys-cluster/vzctl/vzctl-3.0.0.8.ebuild71
3 files changed, 84 insertions, 1 deletions
diff --git a/sys-cluster/vzctl/ChangeLog b/sys-cluster/vzctl/ChangeLog
index 3bd3b44a196b..7c55ffe5fe23 100644
--- a/sys-cluster/vzctl/ChangeLog
+++ b/sys-cluster/vzctl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-cluster/vzctl
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.23 2006/04/21 07:17:36 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.24 2006/04/24 14:53:35 phreak Exp $
+
+*vzctl-3.0.0.8 (24 Apr 2006)
+
+ 24 Apr 2006; Christian Heim <phreak@gentoo.org> +vzctl-3.0.0.8.ebuild:
+ Version bump, see http://openvz.org/news/updates/vzctl-3.0.0-8 for a
+ detailed ChangeLog
21 Apr 2006; Christian Heim <phreak@gentoo.org> vzctl-3.0.0.7.ebuild:
Ripping of the CONFIG_CHECK's and the VZKERNEL_HEADERS
diff --git a/sys-cluster/vzctl/files/digest-vzctl-3.0.0.8 b/sys-cluster/vzctl/files/digest-vzctl-3.0.0.8
new file mode 100644
index 000000000000..b4fab3f9f4bf
--- /dev/null
+++ b/sys-cluster/vzctl/files/digest-vzctl-3.0.0.8
@@ -0,0 +1,6 @@
+MD5 e8d42b9d85b3fc23c011e9439dffef85 vzctl-3.0.0-8.tar.bz2 115033
+RMD160 5bba4d678ea617f05220b4aca921ea62cd355e98 vzctl-3.0.0-8.tar.bz2 115033
+SHA256 7322bebc6f6b476cd2c8a1f9a3e601f9e723142ee317eb3304d40d0e068fc632 vzctl-3.0.0-8.tar.bz2 115033
+MD5 b2525320b5f1d4ee661ffa0795f785fa vzctl-3.0.0.8-patches-r0.tar.bz2 3816
+RMD160 33fa63aa9749beedf6bd7dfd03f11658edfa6266 vzctl-3.0.0.8-patches-r0.tar.bz2 3816
+SHA256 f1ac3df3a9f6f0f62ef97dd0b770cee800c37e3a267105c8fddc2f68dd05d535 vzctl-3.0.0.8-patches-r0.tar.bz2 3816
diff --git a/sys-cluster/vzctl/vzctl-3.0.0.8.ebuild b/sys-cluster/vzctl/vzctl-3.0.0.8.ebuild
new file mode 100644
index 000000000000..39f9729cbac6
--- /dev/null
+++ b/sys-cluster/vzctl/vzctl-3.0.0.8.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-3.0.0.8.ebuild,v 1.1 2006/04/24 14:53:35 phreak Exp $
+
+inherit eutils toolchain-funcs versionator flag-o-matic
+
+VVER="$(get_version_component_range 1-3 ${PV})"
+VREL="$(get_version_component_range 4 ${PV})"
+MY_PV="${VVER}-${VREL}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="OpenVZ VPS control utility"
+HOMEPAGE="http://openvz.org/"
+SRC_URI="http://download.openvz.org/utils/${PN}/${MY_PV}/src/${MY_P}.tar.bz2
+ http://dev.gentoo.org/~phreak/distfiles/${P}-patches-${PR}.tar.bz2
+ http://dev.gentoo.org/~hollow/distfiles/${P}-patches-${PR}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-admin/logrotate
+ app-shells/bash
+ sys-apps/sed
+ sys-apps/ed
+ sys-apps/grep
+ sys-apps/gawk
+ sys-apps/coreutils
+ net-firewall/iptables
+ app-arch/tar
+ sys-fs/vzquota
+ sys-process/procps
+ sys-apps/iproute2"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ filter-ldflags -Wl,--as-needed --as-needed
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${WORKDIR}"/patches/vzctl-3.0.0.2-gentoo_conf_d.patch
+ epatch "${WORKDIR}"/patches/vzctl-3.0.0.2-gentoo_etc_vz.patch
+
+ # fix hardcoded lib paths
+ use amd64 && epatch "${WORKDIR}"/patches/vzctl-3.0.0.2-amd64.patch
+}
+
+src_compile() {
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" VZCONFDIR=/etc/conf.d/ install || die "make install failed"
+
+ # sysconfig is vendor specific
+ rm -rf ${D}/etc/sysconfig
+
+ # Install gentoo specific init script
+ rm -f ${D}/etc/init.d/*
+ newinitd ${FILESDIR}/vz.initd vz
+
+ # Fix permissions on cron.d files
+ chmod 0644 ${D}/etc/cron.d/*
+}