summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2011-12-10 23:51:01 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2011-12-10 23:51:01 +0000
commit1bfffb2f3715ef8494bec4cc5f36d7ff9f7cfa43 (patch)
treec5b4ab3103a3422a013ab7d324019272617b66e6 /sys-cluster
parentUse autotools-utils.eclass in order to drop libtool archive(s). (diff)
downloadgentoo-2-1bfffb2f3715ef8494bec4cc5f36d7ff9f7cfa43.tar.gz
gentoo-2-1bfffb2f3715ef8494bec4cc5f36d7ff9f7cfa43.tar.bz2
gentoo-2-1bfffb2f3715ef8494bec4cc5f36d7ff9f7cfa43.zip
Bug #394257: Add patch needed for correct functioning on 3.x kernels where binding to AF_UNSPEC sockets fails.
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/keepalived/ChangeLog9
-rw-r--r--sys-cluster/keepalived/files/keepalived-1.2.2-bind-afunspec.patch13
-rw-r--r--sys-cluster/keepalived/keepalived-1.2.2-r2.ebuild55
3 files changed, 76 insertions, 1 deletions
diff --git a/sys-cluster/keepalived/ChangeLog b/sys-cluster/keepalived/ChangeLog
index 559dcb2f406d..d3d836a16ce8 100644
--- a/sys-cluster/keepalived/ChangeLog
+++ b/sys-cluster/keepalived/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-cluster/keepalived
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/keepalived/ChangeLog,v 1.82 2011/10/27 16:18:50 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/keepalived/ChangeLog,v 1.83 2011/12/10 23:51:00 robbat2 Exp $
+
+*keepalived-1.2.2-r2 (10 Dec 2011)
+
+ 10 Dec 2011; Robin H. Johnson <robbat2@gentoo.org>
+ +keepalived-1.2.2-r2.ebuild, +files/keepalived-1.2.2-bind-afunspec.patch:
+ Bug #394257: Add patch needed for correct functioning on 3.x kernels where
+ binding to AF_UNSPEC sockets fails.
27 Oct 2011; Jeroen Roovers <jer@gentoo.org> keepalived-1.2.2.ebuild,
keepalived-1.2.2-r1.ebuild:
diff --git a/sys-cluster/keepalived/files/keepalived-1.2.2-bind-afunspec.patch b/sys-cluster/keepalived/files/keepalived-1.2.2-bind-afunspec.patch
new file mode 100644
index 000000000000..1f365d26e517
--- /dev/null
+++ b/sys-cluster/keepalived/files/keepalived-1.2.2-bind-afunspec.patch
@@ -0,0 +1,13 @@
+diff --git a/keepalived/core/layer4.c b/keepalived/core/layer4.c
+index 5725500..5b33417 100644
+--- a/keepalived/core/layer4.c
++++ b/keepalived/core/layer4.c
+@@ -43,7 +43,7 @@ tcp_bind_connect(int fd, struct sockaddr_storage *addr, struct sockaddr_storage
+ fcntl(fd, F_SETFL, val | O_NONBLOCK);
+
+ /* Bind socket */
+- if (bind_addr) {
++ if (bind_addr && ((struct sockaddr *) bind_addr)->sa_family != AF_UNSPEC) {
+ addrlen = sizeof(*bind_addr);
+ if (bind(fd, (struct sockaddr *) bind_addr, addrlen) != 0)
+ return connect_error; \ No newline at end of file
diff --git a/sys-cluster/keepalived/keepalived-1.2.2-r2.ebuild b/sys-cluster/keepalived/keepalived-1.2.2-r2.ebuild
new file mode 100644
index 000000000000..51414c731c07
--- /dev/null
+++ b/sys-cluster/keepalived/keepalived-1.2.2-r2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/keepalived/keepalived-1.2.2-r2.ebuild,v 1.1 2011/12/10 23:51:01 robbat2 Exp $
+
+EAPI=4
+
+inherit autotools base
+
+DESCRIPTION="A strong & robust keepalive facility to the Linux Virtual Server project"
+HOMEPAGE="http://www.keepalived.org/"
+SRC_URI="http://www.keepalived.org/software/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="debug"
+
+RDEPEND="dev-libs/popt
+ sys-apps/iproute2
+ dev-libs/libnl:1.1
+ dev-libs/openssl"
+DEPEND="${RDEPEND}
+ >=sys-kernel/linux-headers-2.6.30"
+
+PATCHES=( "${FILESDIR}"/${PN}-1.1.20-do-not-need-kernel-sources.patch "${FILESDIR}"/${PN}-1.2.2-bind-afunspec.patch )
+
+DOCS=( README CONTRIBUTORS INSTALL VERSION ChangeLog AUTHOR TODO doc/keepalived.conf.SYNOPSIS )
+
+src_prepare() {
+ base_src_prepare
+ eautoreconf
+}
+
+src_configure() {
+ STRIP=/bin/true \
+ econf \
+ --enable-vrrp \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/init-keepalived keepalived
+
+ docinto genhash
+ dodoc genhash/README genhash/AUTHOR genhash/ChangeLog genhash/VERSION || die
+ # This was badly named by upstream, it's more HOWTO than anything else.
+ newdoc INSTALL INSTALL+HOWTO
+
+ # Security risk to bundle SSL certs
+ rm -f "${ED}"/etc/keepalived/samples/*.pem
+ # Clean up sysvinit files
+ rm -rf "${ED}"/etc/sysconfig "${ED}"/etc/rc.d/
+}