summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-04-10 16:53:03 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-04-10 16:53:03 +0000
commit24c6b5051ee8cb9b871879ac8b3bf973015d5b4d (patch)
tree3c61fee9f980cfe5d0126198b2293b7f7d7f61a0 /sys-cluster
parentPut an upper bound on the speech-dispatcher dependency, bug 465358. (diff)
downloadgentoo-2-24c6b5051ee8cb9b871879ac8b3bf973015d5b4d.tar.gz
gentoo-2-24c6b5051ee8cb9b871879ac8b3bf973015d5b4d.tar.bz2
gentoo-2-24c6b5051ee8cb9b871879ac8b3bf973015d5b4d.zip
updating sys-cluster/cinder to 2013.1 (grizzly)
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/cinder/ChangeLog7
-rw-r--r--sys-cluster/cinder/cinder-2013.1.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/sys-cluster/cinder/ChangeLog b/sys-cluster/cinder/ChangeLog
index 7596ef023142..ed855a196a3f 100644
--- a/sys-cluster/cinder/ChangeLog
+++ b/sys-cluster/cinder/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/cinder
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/cinder/ChangeLog,v 1.5 2013/02/20 06:15:40 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/cinder/ChangeLog,v 1.6 2013/04/10 16:53:03 prometheanfire Exp $
+
+*cinder-2013.1 (10 Apr 2013)
+
+ 10 Apr 2013; Matthew Thode <prometheanfire@gentoo.org> +cinder-2013.1.ebuild:
+ updating sys-cluster/cinder to 2013.1 (grizzly)
20 Feb 2013; Matthew Thode <prometheanfire@gentoo.org>
cinder-2012.2.3.ebuild:
diff --git a/sys-cluster/cinder/cinder-2013.1.ebuild b/sys-cluster/cinder/cinder-2013.1.ebuild
new file mode 100644
index 000000000000..f8145c1590aa
--- /dev/null
+++ b/sys-cluster/cinder/cinder-2013.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/cinder/cinder-2013.1.ebuild,v 1.1 2013/04/10 16:53:03 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Cinder is the OpenStack Block storage service. This is a spin out
+of nova-volumes."
+HOMEPAGE="https://launchpad.net/cinder"
+SRC_URI="http://launchpad.net/${PN}/grizzly/${PV}/+download/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+RDEPEND="=dev-python/amqplib-0.6.1
+ >=dev-python/anyjson-0.2.4[${PYTHON_USEDEP}]
+ >=dev-python/eventlet-0.9.17[${PYTHON_USEDEP}]
+ >=dev-python/kombu-1.0.4[${PYTHON_USEDEP}]
+ >=dev-python/lockfile-0.8
+ >=dev-python/lxml-2.3[${PYTHON_USEDEP}]
+ >=dev-python/routes-1.12.3[${PYTHON_USEDEP}]
+ =dev-python/webob-1.2.3
+ >=dev-python/greenlet-0.3.1[${PYTHON_USEDEP}]
+ >=dev-python/pastedeploy-1.5.0[${PYTHON_USEDEP}]
+ dev-python/paste[${PYTHON_USEDEP}]
+ >=dev-python/sqlalchemy-0.7.3
+ <=dev-python/sqlalchemy-0.7.9
+ >=dev-python/sqlalchemy-migrate-0.7.2
+ >=dev-python/stevedore-0.8
+ >=dev-python/suds-0.4
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ >=dev-python/Babel-0.9.6[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.4[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-git-0.4[${PYTHON_USEDEP}]
+ >=dev-python/python-glanceclient-0.5.0
+ <dev-python/python-glanceclient-2
+ >=dev-python/python-keystoneclient-0.2.0
+ dev-python/python-swiftclient[${PYTHON_USEDEP}]
+ >=dev-python/oslo-config-1.1.0[${PYTHON_USEDEP}]
+ virtual/python-argparse[${PYTHON_USEDEP}]"
+
+PATCHES=( )
+
+python_install() {
+ distutils-r1_python_install
+ keepdir /etc/cinder
+ keepdir /etc/cinder/rootwrap.d
+ insinto /etc/cinder
+
+ newins "${S}/etc/cinder/cinder.conf.sample" "cinder.conf"
+ newins "${S}/etc/cinder/api-paste.ini" "api-paste.ini"
+ newins "${S}/etc/cinder/logging_sample.conf" "logging_sample.conf"
+ newins "${S}/etc/cinder/policy.json" "policy.json"
+ newins "${S}/etc/cinder/rootwrap.conf" "rootwrap.conf"
+ insinto /etc/cinder/rootwrap.d
+ newins "${S}/etc/cinder/rootwrap.d/volume.filters" "volume.filters"
+}