summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-12-19 18:16:44 +0000
committerJustin Lecher <jlec@gentoo.org>2010-12-19 18:16:44 +0000
commit3eb75dac520a1d8fd71302db80ea0f0f46224482 (patch)
tree2cfaf2cb3cd37156da0e1531607e211306089ab1 /sys-cluster
parentFix for EPREFIX with whitespaces, thanks Arfrever for help (diff)
downloadgentoo-2-3eb75dac520a1d8fd71302db80ea0f0f46224482.tar.gz
gentoo-2-3eb75dac520a1d8fd71302db80ea0f0f46224482.tar.bz2
gentoo-2-3eb75dac520a1d8fd71302db80ea0f0f46224482.zip
Corrected fix for EPREFIX with whitespaces, thanks Arfrever for another help
(Portage version: 2.2.0_alpha6/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/openmpi/openmpi-1.4.1.ebuild23
-rw-r--r--sys-cluster/openmpi/openmpi-1.4.2.ebuild17
-rw-r--r--sys-cluster/openmpi/openmpi-1.4.3.ebuild15
3 files changed, 23 insertions, 32 deletions
diff --git a/sys-cluster/openmpi/openmpi-1.4.1.ebuild b/sys-cluster/openmpi/openmpi-1.4.1.ebuild
index c3186de2f7ef..d3d5daac48fe 100644
--- a/sys-cluster/openmpi/openmpi-1.4.1.ebuild
+++ b/sys-cluster/openmpi/openmpi-1.4.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.4.1.ebuild,v 1.12 2010/12/19 18:12:39 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.4.1.ebuild,v 1.13 2010/12/19 18:16:44 jlec Exp $
EAPI=2
inherit eutils multilib flag-o-matic toolchain-funcs
@@ -30,19 +30,19 @@ DEPEND="${RDEPEND}"
pkg_setup() {
if use mpi-threads; then
- ewarn
+ echo
ewarn "WARNING: use of MPI_THREAD_MULTIPLE is still disabled by"
ewarn "default and officially unsupported by upstream."
ewarn "You may stop now and set USE=-mpi-threads"
- ewarn
+ echo
epause 5
fi
- elog
+ echo
elog "OpenMPI has an overwhelming count of configuration options."
elog "Don't forget the EXTRA_ECONF environment variable can let you"
elog "specify configure options if you find them necessary."
- elog
+ echo
}
src_prepare() {
@@ -66,25 +66,22 @@ src_configure() {
--without-slurm)
if use mpi-threads; then
- myconf+=(${myconf}
- --enable-mpi-threads
+ myconf+=(--enable-mpi-threads
--enable-progress-threads)
fi
if use fortran; then
if [[ $(tc-getFC) =~ g77 ]]; then
- myconf="${myconf} --disable-mpi-f90"
+ myconf+=(--disable-mpi-f90)
elif [[ $(tc-getFC) =~ if ]]; then
# Enabled here as gfortran compile times are huge with this enabled.
- myconf+=(${myconf} --with-mpi-f90-size=medium)
+ myconf+=(--with-mpi-f90-size=medium)
fi
else
- myconf+=(${myconf}
- --disable-mpi-f90
- --disable-mpi-f77)
+ myconf+=(--disable-mpi-f90 --disable-mpi-f77)
fi
- ! use vt && myconf+=(${myconf} --enable-contrib-no-build=vt)
+ ! use vt && myconf+=(--enable-contrib-no-build=vt)
econf ${myconf} \
$(use_enable cxx mpi-cxx) \
diff --git a/sys-cluster/openmpi/openmpi-1.4.2.ebuild b/sys-cluster/openmpi/openmpi-1.4.2.ebuild
index 8919802f4f31..7e52950deb41 100644
--- a/sys-cluster/openmpi/openmpi-1.4.2.ebuild
+++ b/sys-cluster/openmpi/openmpi-1.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.4.2.ebuild,v 1.10 2010/12/19 18:12:39 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.4.2.ebuild,v 1.11 2010/12/19 18:16:44 jlec Exp $
EAPI=3
inherit eutils multilib flag-o-matic toolchain-funcs
@@ -55,32 +55,29 @@ src_prepare() {
src_configure() {
local myconf=(
- --sysconfdir=${EPREFIX}/etc/${PN}
+ --sysconfdir="${EPREFIX}/etc/${PN}"
--without-xgrid
--enable-pretty-print-stacktrace
--enable-orterun-prefix-by-default
--without-slurm)
if use mpi-threads; then
- myconf+=(${myconf}
- --enable-mpi-threads
+ myconf+=(--enable-mpi-threads
--enable-progress-threads)
fi
if use fortran; then
if [[ $(tc-getFC) =~ g77 ]]; then
- myconf+=(${myconf} --disable-mpi-f90)
+ myconf+=(--disable-mpi-f90)
elif [[ $(tc-getFC) =~ if ]]; then
# Enabled here as gfortran compile times are huge with this enabled.
- myconf+=(${myconf} --with-mpi-f90-size=medium)
+ myconf+=(--with-mpi-f90-size=medium)
fi
else
- myconf+=(${myconf}
- --disable-mpi-f90
- --disable-mpi-f77)
+ myconf+=(--disable-mpi-f90 --disable-mpi-f77)
fi
- ! use vt && myconf+=(${myconf} --enable-contrib-no-build=vt)
+ ! use vt && myconf+=(--enable-contrib-no-build=vt)
econf ${myconf} \
$(use_enable cxx mpi-cxx) \
diff --git a/sys-cluster/openmpi/openmpi-1.4.3.ebuild b/sys-cluster/openmpi/openmpi-1.4.3.ebuild
index 4c3b4177c385..0ec69778f222 100644
--- a/sys-cluster/openmpi/openmpi-1.4.3.ebuild
+++ b/sys-cluster/openmpi/openmpi-1.4.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.4.3.ebuild,v 1.5 2010/12/19 18:12:39 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.4.3.ebuild,v 1.6 2010/12/19 18:16:44 jlec Exp $
EAPI=3
inherit eutils multilib flag-o-matic toolchain-funcs
@@ -61,25 +61,22 @@ src_configure() {
--without-slurm)
if use mpi-threads; then
- myconf+=(${myconf}
- --enable-mpi-threads
+ myconf+=(--enable-mpi-threads
--enable-progress-threads)
fi
if use fortran; then
if [[ $(tc-getFC) =~ g77 ]]; then
- myconf+=(${myconf} --disable-mpi-f90)
+ myconf+=(--disable-mpi-f90)
elif [[ $(tc-getFC) =~ if ]]; then
# Enabled here as gfortran compile times are huge with this enabled.
- myconf+=(${myconf} --with-mpi-f90-size=medium)
+ myconf+=(--with-mpi-f90-size=medium)
fi
else
- myconf+=(${myconf}
- --disable-mpi-f90
- --disable-mpi-f77)
+ myconf+=(--disable-mpi-f90 --disable-mpi-f77)
fi
- ! use vt && myconf+=(${myconf} --enable-contrib-no-build=vt)
+ ! use vt && myconf+=(--enable-contrib-no-build=vt)
econf ${myconf} \
$(use_enable cxx mpi-cxx) \