summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2012-05-26 10:17:01 +0000
committerPeter Volkov <pva@gentoo.org>2012-05-26 10:17:01 +0000
commit7993b4e25169c028f99a4e669a65437a591b5f2c (patch)
treef8332a860f30286ad9d506c5106304b3317dced6 /sys-cluster
parentUse python-distutils-ng. Re-enable Python 3 support. (diff)
downloadgentoo-2-7993b4e25169c028f99a4e669a65437a591b5f2c.tar.gz
gentoo-2-7993b4e25169c028f99a4e669a65437a591b5f2c.tar.bz2
gentoo-2-7993b4e25169c028f99a4e669a65437a591b5f2c.zip
Version bump.
(Portage version: 2.1.10.54/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/vzctl/ChangeLog7
-rw-r--r--sys-cluster/vzctl/vzctl-3.1.ebuild63
2 files changed, 69 insertions, 1 deletions
diff --git a/sys-cluster/vzctl/ChangeLog b/sys-cluster/vzctl/ChangeLog
index 42cd0ac2a53a..da558cf87e35 100644
--- a/sys-cluster/vzctl/ChangeLog
+++ b/sys-cluster/vzctl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-cluster/vzctl
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.89 2012/03/31 05:09:25 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/ChangeLog,v 1.90 2012/05/26 10:17:01 pva Exp $
+
+*vzctl-3.1 (26 May 2012)
+
+ 26 May 2012; Peter Volkov <pva@gentoo.org> +vzctl-3.1.ebuild:
+ Version bump.
31 Mar 2012; Peter Volkov <pva@gentoo.org> -vzctl-3.0.28.3-r1.ebuild,
vzctl-3.0.30.2.ebuild, vzctl-9999.ebuild:
diff --git a/sys-cluster/vzctl/vzctl-3.1.ebuild b/sys-cluster/vzctl/vzctl-3.1.ebuild
new file mode 100644
index 000000000000..baefecafd892
--- /dev/null
+++ b/sys-cluster/vzctl/vzctl-3.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/vzctl/vzctl-3.1.ebuild,v 1.1 2012/05/26 10:17:01 pva Exp $
+
+EAPI="4"
+
+inherit bash-completion-r1 eutils
+
+DESCRIPTION="OpenVZ ConTainers control utility"
+HOMEPAGE="http://openvz.org/"
+SRC_URI="http://download.openvz.org/utils/${PN}/${PV}/src/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ net-firewall/iptables
+ sys-apps/ed
+ sys-apps/iproute2
+ sys-fs/vzquota
+ sys-cluster/ploop"
+
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ # Set default OSTEMPLATE on gentoo added
+ sed -e 's:=redhat-:=gentoo-:' -i etc/dists/default || die
+}
+
+src_configure() {
+ econf \
+ --localstatedir=/var \
+ --enable-udev \
+ --enable-bashcomp \
+ --enable-logrotate
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-gentoo
+
+ # install the bash-completion script into the right location
+ rm -rf "${ED}"/etc/bash_completion.d
+ newbashcomp etc/bash_completion.d/vzctl.sh ${PN}
+
+ # We need to keep some dirs
+ keepdir /vz/{dump,lock,root,private,template/cache}
+ keepdir /etc/vz/names /var/lib/vzctl/veip
+}
+
+pkg_postinst() {
+ ewarn "To avoid loosing network to CTs on iface down/up, please, add the"
+ ewarn "following code to /etc/conf.d/net:"
+ ewarn " postup() {"
+ ewarn " /usr/sbin/vzifup-post \${IFACE}"
+ ewarn " }"
+
+ ewarn "Starting with 3.0.25 there is new vzeventd service to reboot CTs."
+ ewarn "Please, drop /usr/share/vzctl/scripts/vpsnetclean and"
+ ewarn "/usr/share/vzctl/scripts/vpsreboot from crontab and use"
+ ewarn "/etc/init.d/vzeventd."
+}