summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2013-03-04 08:33:19 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2013-03-04 08:33:19 +0000
commit8bd5969c0928183e9d329dca3c1b181d32bbeca2 (patch)
treeaf80d4948573d40b2062c75b1faa841e0bd381c7 /sys-cluster
parentsci-biology/trf: What happens in /opt, stays in /opt (diff)
downloadgentoo-2-8bd5969c0928183e9d329dca3c1b181d32bbeca2.tar.gz
gentoo-2-8bd5969c0928183e9d329dca3c1b181d32bbeca2.tar.bz2
gentoo-2-8bd5969c0928183e9d329dca3c1b181d32bbeca2.zip
Remove old; bump to use autotools-utils and use sub-slot dependency on boost.
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 1CD13C8AD4301342)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/gearmand/ChangeLog11
-rw-r--r--sys-cluster/gearmand/files/gearmand-0.33+gcc-4.7.patch12
-rw-r--r--sys-cluster/gearmand/gearmand-0.33.ebuild90
-rw-r--r--sys-cluster/gearmand/gearmand-0.34-r1.ebuild (renamed from sys-cluster/gearmand/gearmand-0.34.ebuild)48
4 files changed, 30 insertions, 131 deletions
diff --git a/sys-cluster/gearmand/ChangeLog b/sys-cluster/gearmand/ChangeLog
index 92ed7b25262e..9a4174c3c378 100644
--- a/sys-cluster/gearmand/ChangeLog
+++ b/sys-cluster/gearmand/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-cluster/gearmand
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/gearmand/ChangeLog,v 1.19 2012/11/22 04:19:21 flameeyes Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/gearmand/ChangeLog,v 1.20 2013/03/04 08:33:18 flameeyes Exp $
+
+*gearmand-0.34-r1 (04 Mar 2013)
+
+ 04 Mar 2013; Diego E. Pettenò <flameeyes@gentoo.org> +gearmand-0.34-r1.ebuild,
+ -files/gearmand-0.33+gcc-4.7.patch, -gearmand-0.33.ebuild,
+ -gearmand-0.34.ebuild:
+ Remove old; bump to use autotools-utils and use sub-slot dependency on boost.
22 Nov 2012; Diego E. Pettenò <flameeyes@gentoo.org> gearmand-0.34.ebuild:
Depend on a multithread-safe version of boost if available.
diff --git a/sys-cluster/gearmand/files/gearmand-0.33+gcc-4.7.patch b/sys-cluster/gearmand/files/gearmand-0.33+gcc-4.7.patch
deleted file mode 100644
index 459952313d99..000000000000
--- a/sys-cluster/gearmand/files/gearmand-0.33+gcc-4.7.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Index: gearmand-0.33/util/logfile.cc
-===================================================================
---- gearmand-0.33.orig/util/logfile.cc
-+++ gearmand-0.33/util/logfile.cc
-@@ -49,6 +49,7 @@
- #include <sstream>
- #include <sys/stat.h>
- #include <sys/types.h>
-+#include <unistd.h>
-
- namespace datadifferential {
- namespace util {
diff --git a/sys-cluster/gearmand/gearmand-0.33.ebuild b/sys-cluster/gearmand/gearmand-0.33.ebuild
deleted file mode 100644
index eea8af24dd60..000000000000
--- a/sys-cluster/gearmand/gearmand-0.33.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/gearmand/gearmand-0.33.ebuild,v 1.2 2012/06/21 14:43:30 flameeyes Exp $
-
-EAPI=4
-
-inherit flag-o-matic libtool
-
-DESCRIPTION="Generic framework to farm out work to other machines"
-HOMEPAGE="http://www.gearman.org/"
-SRC_URI="http://launchpad.net/gearmand/trunk/${PV}/+download/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug tcmalloc +memcache drizzle sqlite tokyocabinet postgres"
-
-RDEPEND="dev-libs/libevent
- || ( >=sys-apps/util-linux-2.16 <sys-libs/e2fsprogs-libs-1.41.8 )
- tcmalloc? ( dev-util/google-perftools )
- memcache? ( >=dev-libs/libmemcached-0.47 )
- drizzle? ( dev-db/drizzle )
- sqlite? ( dev-db/sqlite:3 )
- tokyocabinet? ( dev-db/tokyocabinet )
- postgres? ( >=dev-db/postgresql-base-9.0 )"
-DEPEND="${RDEPEND}"
-
-pkg_setup() {
- enewuser gearmand -1 -1 /dev/null nogroup
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}+gcc-4.7.patch
- elibtoolize
-}
-
-src_configure() {
- # Don't ever use --enable-assert since configure.ac is broken, and
- # only does --disable-assert correctly.
- if use debug; then
- # Since --with-debug would turn off optimisations as well as
- # enabling debug, we just enable debug through the
- # preprocessor then.
- append-flags -DDEBUG
- else
- myconf="${myconf} --disable-assert"
- fi
-
- econf \
- --disable-static \
- --disable-dependency-tracking \
- --disable-mtmalloc \
- $(use_enable tcmalloc) \
- $(use_enable memcache libmemcached) \
- $(use_enable drizzle libdrizzle) \
- $(use_enable sqlite libsqlite3) \
- $(use_enable tokyocabinet libtokyocabinet) \
- $(use_enable postgres libpq)
-}
-
-src_test() {
- # Since libtool is stupid and doesn't discard /usr/lib64 from the
- # load path, we'd end up testing against the installed copy of
- # gearmand (bad).
- #
- # We thus cheat and "fix" the scripts by hand.
- sed -i -e '/LD_LIBRARY_PATH=/s|/usr/lib64:||' "${S}"/tests/*_test \
- || die "test fixing failed"
-
- emake check
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- dodoc README AUTHORS ChangeLog
-
- newinitd "${FILESDIR}"/gearmand.init.d.2 gearmand
- newconfd "${FILESDIR}"/gearmand.conf.d gearmand
-
- find "${D}" -name '*.la' -delete || die
-}
-
-pkg_postinst() {
- elog ""
- elog "Unless you set the PERSISTENT_TABLE option in"
- elog "/etc/conf.d/gearmand, Gearmand will use table 'queue'."
- elog "If such table doesn't exist, Gearmand will create it for you"
- elog ""
-}
diff --git a/sys-cluster/gearmand/gearmand-0.34.ebuild b/sys-cluster/gearmand/gearmand-0.34-r1.ebuild
index babf6b2115b9..563f0e929b27 100644
--- a/sys-cluster/gearmand/gearmand-0.34.ebuild
+++ b/sys-cluster/gearmand/gearmand-0.34-r1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/gearmand/gearmand-0.34.ebuild,v 1.3 2012/11/22 04:19:21 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/gearmand/gearmand-0.34-r1.ebuild,v 1.1 2013/03/04 08:33:18 flameeyes Exp $
-EAPI=4
+EAPI=5
-inherit flag-o-matic libtool
+inherit flag-o-matic libtool autotools-utils
DESCRIPTION="Generic framework to farm out work to other machines"
HOMEPAGE="http://www.gearman.org/"
@@ -16,7 +16,7 @@ KEYWORDS="~amd64 ~x86"
IUSE="debug tcmalloc +memcache drizzle sqlite tokyocabinet postgres"
RDEPEND="dev-libs/libevent
- >=dev-libs/boost-1.39[threads(+)]
+ >=dev-libs/boost-1.39:=[threads(+)]
|| ( >=sys-apps/util-linux-2.16 <sys-libs/e2fsprogs-libs-1.41.8 )
tcmalloc? ( dev-util/google-perftools )
memcache? ( >=dev-libs/libmemcached-0.47 )
@@ -31,32 +31,28 @@ pkg_setup() {
enewuser gearmand -1 -1 /dev/null nogroup
}
-src_prepare() {
- elibtoolize
-}
-
src_configure() {
+ local myeconfargs=(
+ $(use_enable drizzle libdrizzle)
+ $(use_enable memcache libmemcached)
+ $(use_enable postgres libpq)
+ $(use_enable tcmalloc)
+ $(use_enable tokyocabinet libtokyocabinet)
+ $(use_with sqlite sqlite3)
+ --disable-mtmalloc
+ --disable-static
+ )
+
# Don't ever use --enable-assert since configure.ac is broken, and
# only does --disable-assert correctly.
- if use debug; then
+ if use debug; then
# Since --with-debug would turn off optimisations as well as
# enabling debug, we just enable debug through the
# preprocessor then.
append-cppflags -DDEBUG
- else
- myconf="${myconf} --disable-assert"
fi
- econf \
- --disable-static \
- --disable-dependency-tracking \
- --disable-mtmalloc \
- $(use_enable tcmalloc) \
- $(use_enable memcache libmemcached) \
- $(use_enable drizzle libdrizzle) \
- $(use_with sqlite sqlite3) \
- $(use_enable tokyocabinet libtokyocabinet) \
- $(use_enable postgres libpq)
+ autotools-utils_src_configure
}
src_test() {
@@ -65,21 +61,19 @@ src_test() {
# gearmand (bad).
#
# We thus cheat and "fix" the scripts by hand.
- sed -i -e '/LD_LIBRARY_PATH=/s|/usr/lib64:||' "${S}"/tests/*_test \
+ sed -i -e '/LD_LIBRARY_PATH=/s|/usr/lib64:||' "${BUILD_DIR}"/tests/*_test \
|| die "test fixing failed"
- emake check
+ autotools-utils_src_test
}
DOCS=( README AUTHORS ChangeLog )
src_install() {
- default
+ autotools-utils_src_install
newinitd "${FILESDIR}"/gearmand.init.d.2 gearmand
newconfd "${FILESDIR}"/gearmand.conf.d gearmand
-
- find "${D}" -name '*.la' -delete || die
}
pkg_postinst() {