summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2014-04-01 03:46:51 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2014-04-01 03:46:51 +0000
commitd6bfa447a86c007392e24c3efb399cee3fb63370 (patch)
tree66be1337ec493ad2ef82fb864ea5c73dd9376b39 /sys-cluster
parentStable for amd64, wrt bug #506404 (diff)
downloadgentoo-2-d6bfa447a86c007392e24c3efb399cee3fb63370.tar.gz
gentoo-2-d6bfa447a86c007392e24c3efb399cee3fb63370.tar.bz2
gentoo-2-d6bfa447a86c007392e24c3efb399cee3fb63370.zip
update to nova and deps 2013.2.9999
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/nova/ChangeLog6
-rw-r--r--sys-cluster/nova/files/nova.initd20
-rw-r--r--sys-cluster/nova/metadata.xml1
-rw-r--r--sys-cluster/nova/nova-2013.2.9999.ebuild40
4 files changed, 39 insertions, 28 deletions
diff --git a/sys-cluster/nova/ChangeLog b/sys-cluster/nova/ChangeLog
index cd3c58a5ee28..27d67ad0634d 100644
--- a/sys-cluster/nova/ChangeLog
+++ b/sys-cluster/nova/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-cluster/nova
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/ChangeLog,v 1.55 2014/03/30 05:42:20 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/ChangeLog,v 1.56 2014/04/01 03:46:51 prometheanfire Exp $
+
+ 01 Apr 2014; Matthew Thode <prometheanfire@gentoo.org> +files/nova.initd,
+ metadata.xml, nova-2013.2.9999.ebuild:
+ update to nova and deps 2013.2.9999
30 Mar 2014; Matthew Thode <prometheanfire@gentoo.org> metadata.xml,
nova-2013.2.9999.ebuild:
diff --git a/sys-cluster/nova/files/nova.initd b/sys-cluster/nova/files/nova.initd
new file mode 100644
index 000000000000..e1f44f8913aa
--- /dev/null
+++ b/sys-cluster/nova/files/nova.initd
@@ -0,0 +1,20 @@
+#!/sbin/runscript
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+description="Starts ${SVCNAME} service for OpenStack"
+
+command=/usr/bin/${SVCNAME}
+command_background=yes
+pidfile=/var/run/nova/${SVCNAME}.pid
+required_files=/etc/nova/nova.conf
+start_stop_daemon_args="--quiet --user ${NOVA_USER:-nova}"
+
+depend() {
+ need net
+ need rabbitmq
+}
+
+start_pre() {
+ checkpath --directory --owner ${NOVA_USER:-nova}:${NOVA_GROUP:-nova} --mode 0664 ${NOVA_RUN:-/var/run/nova}
+}
diff --git a/sys-cluster/nova/metadata.xml b/sys-cluster/nova/metadata.xml
index b30cc7aab287..e0397817f1d3 100644
--- a/sys-cluster/nova/metadata.xml
+++ b/sys-cluster/nova/metadata.xml
@@ -19,7 +19,6 @@
<flag name="kvm">qemu-kvm hypervisor support</flag>
<flag name="network">Installs the initscripts for the nova network service</flag>
<flag name="novncproxy">Installs the initscripts for the nova novncproxy service</flag>
- <flag name="rabbit">Installs the rabbitmq server as the amqp server for nova</flag>
<flag name="scheduler">Installs the initscripts for the nova scheduler service</flag>
<flag name="spicehtml5proxy">Installs the initscripts for the nova spicehtml5proxy service</flag>
<flag name="xen">xen hypervisor support</flag>
diff --git a/sys-cluster/nova/nova-2013.2.9999.ebuild b/sys-cluster/nova/nova-2013.2.9999.ebuild
index 4d59b574f8f7..5326994f18e9 100644
--- a/sys-cluster/nova/nova-2013.2.9999.ebuild
+++ b/sys-cluster/nova/nova-2013.2.9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/nova-2013.2.9999.ebuild,v 1.11 2014/03/30 05:42:20 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/nova/nova-2013.2.9999.ebuild,v 1.12 2014/04/01 03:46:51 prometheanfire Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -15,9 +15,9 @@ EGIT_BRANCH="stable/havana"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS=""
-IUSE="+api +cert +compute +conductor +consoleauth ipv6 +kvm +network +novncproxy +rabbit +scheduler +spicehtml5proxy +xvpvncproxy sqlite mysql postgres xen"
+IUSE="+compute +kvm +network +novncproxy sqlite mysql postgres xen"
REQUIRED_USE="|| ( mysql postgres sqlite )
- || ( kvm xen )"
+ compute? ( || ( kvm xen ) )"
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
>=dev-python/pbr-0.5.21[${PYTHON_USEDEP}]
@@ -65,10 +65,9 @@ RDEPEND="sqlite? ( >=dev-python/sqlalchemy-0.7.8[sqlite,${PYTHON_USEDEP}]
novncproxy? ( www-apps/novnc )
sys-apps/iproute2
net-misc/openvswitch
+ net-misc/rabbitmq-server
sys-fs/sysfsutils
sys-fs/multipath-tools
- ipv6? ( net-misc/radvd )
- rabbit? ( net-misc/rabbitmq-server )
kvm? ( app-emulation/qemu )
xen? ( app-emulation/xen
app-emulation/xen-tools )"
@@ -83,47 +82,36 @@ pkg_setup() {
python_install() {
distutils-r1_python_install
- newconfd "${FILESDIR}/nova-confd" "nova"
- newinitd "${FILESDIR}/nova-initd" "nova"
- use api && dosym /etc/init.d/nova /etc/init.d/nova-api
- use cert && dosym /etc/init.d/nova /etc/init.d/nova-cert
- use compute && dosym /etc/init.d/nova /etc/init.d/nova-compute
- use conductor && dosym /etc/init.d/nova /etc/init.d/nova-conductor
- use consoleauth && dosym /etc/init.d/nova /etc/init.d/nova-consoleauth
- use network && dosym /etc/init.d/nova /etc/init.d/nova-network
- use novncproxy &&dosym /etc/init.d/nova /etc/init.d/nova-novncproxy
- use scheduler && dosym /etc/init.d/nova /etc/init.d/nova-scheduler
- use spicehtml5proxy && dosym /etc/init.d/nova /etc/init.d/nova-spicehtml5proxy
- use xvpvncproxy && dosym /etc/init.d/nova /etc/init.d/nova-xvpncproxy
- diropts -m 0750
- dodir /var/run/nova /var/log/nova /var/lock/nova
- fowners nova:nova /var/log/nova /var/lock/nova /var/run/nova
+ for svc in api cert compute conductor consoleauth network scheduler spicehtml5proxy xvpvncproxy; do
+ newinitd "${FILESDIR}/nova.initd" "nova-${svc}"
+ done
+ use compute && newinitd "${FILESDIR}/nova.initd" "nova-compute"
+ use novncproxy && newinitd "${FILESDIR}/nova.initd" "nova-novncproxy"
- diropts -m 0755
- dodir /var/lib/nova/instances
- fowners nova:nova /var/lib/nova/instances
+ diropts -m 0750 -o nova -g nova
+ dodir /var/log/nova /var/lib/nova/instances
- keepdir /etc/nova
insinto /etc/nova
+ insopts -m 0640 -o nova -g nova
newins "etc/nova/nova.conf.sample" "nova.conf"
doins "etc/nova/api-paste.ini"
doins "etc/nova/logging_sample.conf"
doins "etc/nova/policy.json"
doins "etc/nova/rootwrap.conf"
+ #rootwrap filters
insinto /etc/nova/rootwrap.d
doins "etc/nova/rootwrap.d/api-metadata.filters"
doins "etc/nova/rootwrap.d/compute.filters"
doins "etc/nova/rootwrap.d/network.filters"
-
#copy migration conf file (not coppied on install via setup.py script)
insinto /usr/$(get_libdir)/python2.7/site-packages/nova/db/sqlalchemy/migrate_repo/
doins "nova/db/sqlalchemy/migrate_repo/migrate.cfg"
-
#copy the CA cert dir (not coppied on install via setup.py script)
cp -R "${S}/nova/CA" "${D}/usr/$(get_libdir)/python2.7/site-packages/nova/" || die "isntalling CA files failed"
#add sudoers definitions for user nova
insinto /etc/sudoers.d/
+ insopts -m 0600 -o root -g root
doins "${FILESDIR}/nova-sudoers"
}