summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@gentoo.org>2008-09-12 14:34:02 +0000
committerJustin Bronder <jsbronder@gentoo.org>2008-09-12 14:34:02 +0000
commitee632037458847d7bb0b10dad1dc02cfb7cfd208 (patch)
treee4ed1d8f7df01bfae102e3b6b8a7025c3bdb7329 /sys-cluster
parentVersion bump. (diff)
downloadgentoo-2-ee632037458847d7bb0b10dad1dc02cfb7cfd208.tar.gz
gentoo-2-ee632037458847d7bb0b10dad1dc02cfb7cfd208.tar.bz2
gentoo-2-ee632037458847d7bb0b10dad1dc02cfb7cfd208.zip
Clean up the misleading usage of USE=threads by separating the safe and experimental portions. See #237435. Thanks to kyron (Eric Thibodeau) for the report and patch.
(Portage version: 2.1.4.4)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/openmpi/ChangeLog10
-rw-r--r--sys-cluster/openmpi/metadata.xml1
-rw-r--r--sys-cluster/openmpi/openmpi-1.2.7-r1.ebuild108
3 files changed, 118 insertions, 1 deletions
diff --git a/sys-cluster/openmpi/ChangeLog b/sys-cluster/openmpi/ChangeLog
index 44d5331e4fa6..ec304252fde6 100644
--- a/sys-cluster/openmpi/ChangeLog
+++ b/sys-cluster/openmpi/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-cluster/openmpi
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/ChangeLog,v 1.32 2008/07/28 20:46:59 pchrist Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/ChangeLog,v 1.33 2008/09/12 14:34:02 jsbronder Exp $
+
+*openmpi-1.2.7-r1 (12 Sep 2008)
+
+ 12 Sep 2008; Justin Bronder <jsbronder@gentoo.org> metadata.xml,
+ +openmpi-1.2.7-r1.ebuild:
+ Clean up the misleading usage of USE=threads by separating the safe and
+ experimental portions. See #237435. Thanks to kyron (Eric Thibodeau) for the
+ report and patch.
28 Jul 2008; Panagiotis Christopoulos <pchrist@gentoo.org> metadata.xml:
Update metadata.xml to include USE flag descriptions. Entries taken from
diff --git a/sys-cluster/openmpi/metadata.xml b/sys-cluster/openmpi/metadata.xml
index c082e92a5a4a..0e87e388c80a 100644
--- a/sys-cluster/openmpi/metadata.xml
+++ b/sys-cluster/openmpi/metadata.xml
@@ -12,5 +12,6 @@
<flag name='romio'>Build the ROMIO MPI-IO component</flag>
<flag name='smp'>Enable smp locks in atomic ops. Recommended for
SMP/multi-threaded environments.</flag>
+ <flag name='mpi-threads'>Enable MPI_THREAD_MULTIPLE</flag>
</use>
</pkgmetadata>
diff --git a/sys-cluster/openmpi/openmpi-1.2.7-r1.ebuild b/sys-cluster/openmpi/openmpi-1.2.7-r1.ebuild
new file mode 100644
index 000000000000..27c31558dc47
--- /dev/null
+++ b/sys-cluster/openmpi/openmpi-1.2.7-r1.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/openmpi/openmpi-1.2.7-r1.ebuild,v 1.1 2008/09/12 14:34:02 jsbronder Exp $
+
+inherit eutils multilib flag-o-matic toolchain-funcs fortran
+
+MY_P=${P/-mpi}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="A high-performance message passing library (MPI)"
+HOMEPAGE="http://www.open-mpi.org"
+SRC_URI="http://www.open-mpi.org/software/ompi/v1.2/downloads/${MY_P}.tar.bz2"
+LICENSE="BSD"
+SLOT="0"
+RESTRICT="mpi-threads? ( test )"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="fortran heterogeneous ipv6 mpi-threads nocxx pbs romio threads"
+RDEPEND="pbs? ( sys-cluster/torque )
+ !sys-cluster/mpich
+ !sys-cluster/lam-mpi
+ !sys-cluster/mpich2"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ if use mpi-threads; then
+ ewarn
+ ewarn "WARNING: use of MPI_THREAD_MULTIPLE is still disabled by"
+ ewarn "default and officially unsupported by upstream."
+ ewarn "You may stop now and set USE=-mpi-threads"
+ ewarn
+ epause 5
+ fi
+
+ elog
+ elog "OpenMPI has an overwhelming count of configuration options."
+ elog "Don't forget the EXTRA_ECONF environment variable can let you"
+ elog "specify configure options if you find them necessary."
+ elog
+
+ if use fortran; then
+ FORTRAN="g77 gfortran ifc"
+ fortran_pkg_setup
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Necessary for scalibility, see
+ # http://www.open-mpi.org/community/lists/users/2008/09/6514.php
+ if use threads; then
+ echo 'oob_tcp_listen_mode = listen_thread' \
+ >> opal/etc/openmpi-mca-params.conf
+ fi
+}
+
+src_compile() {
+ local myconf="
+ --sysconfdir=/etc/${PN}
+ --without-xgrid
+ --enable-pretty-print-stacktrace
+ --enable-orterun-prefix-by-default
+ --without-slurm"
+
+ if use mpi-threads; then
+ myconf="${myconf}
+ --enable-mpi-threads
+ --with-progress-threads"
+ fi
+
+ if use fortran; then
+ if [[ "${FORTRANC}" = "g77" ]]; then
+ myconf="${myconf} --disable-mpi-f90"
+ elif [[ "${FORTRANC}" = "gfortran" ]]; then
+ # Because that's just a pain in the butt.
+ myconf="${myconf} --with-wrapper-fflags=-I/usr/include"
+ elif [[ "${FORTRANC}" = if* ]]; then
+ # Enabled here as gfortran compile times are huge with this enabled.
+ myconf="${myconf} --with-mpi-f90-size=medium"
+ fi
+ else
+ myconf="${myconf}
+ --disable-mpi-f90
+ --disable-mpi-f77"
+ fi
+
+ econf ${myconf} \
+ $(use_enable !nocxx mpi-cxx) \
+ $(use_enable romio io-romio) \
+ $(use_enable heterogeneous) \
+ $(use_with pbs tm) \
+ $(use_enable ipv6) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc README AUTHORS NEWS VERSION
+}
+
+src_test() {
+ # Doesn't work with the default src_test as the dry run (-n) fails.
+ cd "${S}"
+ emake -j1 check || die "emake check failed"
+}