summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Gardner <je_fro@gentoo.org>2009-11-27 07:08:50 +0000
committerJeffrey Gardner <je_fro@gentoo.org>2009-11-27 07:08:50 +0000
commitf145574a9a31b3d02a974674427bf5f2ab136e76 (patch)
tree93771852b1a3025757a21918877bc4f62787dc5b /sys-cluster
parentVersion bump. (diff)
downloadgentoo-2-f145574a9a31b3d02a974674427bf5f2ab136e76.tar.gz
gentoo-2-f145574a9a31b3d02a974674427bf5f2ab136e76.tar.bz2
gentoo-2-f145574a9a31b3d02a974674427bf5f2ab136e76.zip
Cleanup and fix charm-6.1.2-r2-charmc-gentoo.patch
(Portage version: 2.1.7.7/cvs/Linux x86_64)
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/charm/ChangeLog6
-rw-r--r--sys-cluster/charm/charm-6.1.2-r1.ebuild131
-rw-r--r--sys-cluster/charm/charm-6.1.2.ebuild131
-rw-r--r--sys-cluster/charm/files/charm-6.1.2-charmc-gentoo.patch25
4 files changed, 12 insertions, 281 deletions
diff --git a/sys-cluster/charm/ChangeLog b/sys-cluster/charm/ChangeLog
index 4c6d91bb58fe..c3533b872a9f 100644
--- a/sys-cluster/charm/ChangeLog
+++ b/sys-cluster/charm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-cluster/charm
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/charm/ChangeLog,v 1.24 2009/11/27 05:26:01 je_fro Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-cluster/charm/ChangeLog,v 1.25 2009/11/27 07:08:50 je_fro Exp $
+
+ 27 Nov 2009; Jeff Gardner <je_fro@gentoo.org> -charm-6.1.2.ebuild,
+ -charm-6.1.2-r1.ebuild, files/charm-6.1.2-charmc-gentoo.patch:
+ Cleanup and fix charm-6.1.2-charmc-gentoo.patch
*charm-6.1.2-r2 (27 Nov 2009)
diff --git a/sys-cluster/charm/charm-6.1.2-r1.ebuild b/sys-cluster/charm/charm-6.1.2-r1.ebuild
deleted file mode 100644
index bfa3bfd2a44f..000000000000
--- a/sys-cluster/charm/charm-6.1.2-r1.ebuild
+++ /dev/null
@@ -1,131 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/charm/charm-6.1.2-r1.ebuild,v 1.2 2009/08/31 08:53:37 loki_val Exp $
-
-inherit eutils toolchain-funcs flag-o-matic multilib
-
-DESCRIPTION="Charm++ is a message-passing parallel language and runtime system."
-LICENSE="charm"
-HOMEPAGE="http://charm.cs.uiuc.edu/"
-SRC_URI="http://charm.cs.uiuc.edu/distrib/${P}_src.tar.gz"
-S="${WORKDIR}/${P}"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="cmkopt tcp smp doc"
-
-DEPEND="doc? ( virtual/poppler-utils
- dev-tex/latex2html
- virtual/tex-base
- )"
-
-RDEPEND="${DEPEND}"
-
-case ${ARCH} in
-
- x86)
- CHARM_ARCH="net-linux" ;;
-
- amd64)
- CHARM_ARCH="net-linux-amd64" ;;
-esac
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/${P}-charmrun.patch"
-
- # TCP instead of default UDP for socket comunication
- # protocol
- if use tcp; then
- CHARM_OPTS="${CHARM_OPTS} tcp"
- fi
-
- # enable direct SMP support using shared memory
-# if use smp && [ "${ARCH}" != "amd64" ]; then
- if use smp; then
- CHARM_OPTS="${CHARM_OPTS} smp"
- fi
-
- # CMK optimization
- if use cmkopt; then
- append-flags -DCMK_OPTIMIZE=1
- fi
-
- echo "charm opts: ${CHARM_OPTS}"
-}
-
-src_compile() {
- # build charmm++ first
- cd "${S}"
- ./build charm++ ${CHARM_ARCH} ${CHARM_OPTS} ${CFLAGS} || \
- die "Failed to build charm++"
-
- # make pdf/html docs
- if use doc; then
- cd "${S}"/doc
- make doc || die "failed to create pdf/html docs"
- fi
-}
-
-src_install() {
- # make charmc play well with gentoo before
- # we move it into /usr/bin
- epatch "${FILESDIR}/${P}-charmc-gentoo.patch"
-
- sed -e "s|gentoo-include|${P}|" \
- -e "s|gentoo-libdir|$(get_libdir)|g" \
- -e "s|VERSION|${P}/VERSION|" \
- -i ./src/scripts/charmc || die "failed patching charmc script"
-
- # install binaries
- cd "${S}"/bin
- dobin ./charmd ./charmd_faceless ./charmr* ./charmc ./charmxi \
- ./conv-cpm ./dep.pl || die "Failed to install binaries"
-
- # install headers
- cd "${S}"/include
- insinto /usr/include/${P}
- doins * || die "failed to install header files"
-
- # install static libs
- cd "${S}"/lib
- dolib.a * || die "failed to install static libs"
-
- # install shared libs
- cd "${S}"/lib_so
- dolib.so * || die "failed to install shared libs"
-
- # basic docs
- cd "${S}"
- dodoc CHANGES README || die "Failed to install docs"
-
- # install examples
- find examples/ -name 'Makefile' | xargs sed \
- -r "s:(../)+bin/charmc:/usr/bin/charmc:" -i || \
- die "Failed to fix examples"
- find examples/ -name 'Makefile' | xargs sed \
- -r "s:./charmrun:./charmrun ++local:" -i || \
- die "Failed to fix examples"
- insinto /usr/share/doc/${PF}/examples
- doins -r examples/charm++/*
-
- # pdf/html docs
- if use doc; then
- cd "${S}"/doc
- # install pdfs
- insinto /usr/share/doc/${PF}/pdf
- doins doc/pdf/* || die "failed to install pdf docs"
- # install html
- docinto html
- dohtml -r doc/html/* || die "failed to install html docs"
- fi
-}
-
-pkg_postinst() {
- echo
- einfo "Please test your charm installation by copying the"
- einfo "content of /usr/share/doc/${PF}/examples to a"
- einfo "temporary location and run 'make test'."
- echo
-}
diff --git a/sys-cluster/charm/charm-6.1.2.ebuild b/sys-cluster/charm/charm-6.1.2.ebuild
deleted file mode 100644
index 3b2a4463ff0d..000000000000
--- a/sys-cluster/charm/charm-6.1.2.ebuild
+++ /dev/null
@@ -1,131 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-cluster/charm/charm-6.1.2.ebuild,v 1.6 2009/08/31 08:53:37 loki_val Exp $
-
-inherit eutils toolchain-funcs flag-o-matic multilib
-
-DESCRIPTION="Charm++ is a message-passing parallel language and runtime system."
-LICENSE="charm"
-HOMEPAGE="http://charm.cs.uiuc.edu/"
-SRC_URI="http://charm.cs.uiuc.edu/distrib/${P}_src.tar.gz"
-S="${WORKDIR}/${P}"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="cmkopt tcp smp doc"
-
-DEPEND="doc? ( virtual/poppler-utils
- dev-tex/latex2html
- virtual/tex-base
- )"
-
-RDEPEND="${DEPEND}"
-
-case ${ARCH} in
-
- x86)
- CHARM_ARCH="net-linux" ;;
-
- amd64)
- CHARM_ARCH="net-linux-amd64" ;;
-esac
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}/${P}-charmrun.patch"
-
- # TCP instead of default UDP for socket comunication
- # protocol
- if use tcp; then
- CHARM_OPTS="${CHARM_OPTS} tcp"
- fi
-
- # enable direct SMP support using shared memory
-# if use smp && [ "${ARCH}" != "amd64" ]; then
- if use smp; then
- CHARM_OPTS="${CHARM_OPTS} smp"
- fi
-
- # CMK optimization
- if use cmkopt; then
- append-flags -DCMK_OPTIMIZE=1
- fi
-
- echo "charm opts: ${CHARM_OPTS}"
-}
-
-src_compile() {
- # build charmm++ first
- cd "${S}"
- ./build charm++ ${CHARM_ARCH} ${CHARM_OPTS} ${CFLAGS} || \
- die "Failed to build charm++"
-
- # make pdf/html docs
- if use doc; then
- cd "${S}"/doc
- make doc || die "failed to create pdf/html docs"
- fi
-}
-
-src_install() {
- # make charmc play well with gentoo before
- # we move it into /usr/bin
- epatch "${FILESDIR}/${P}-charmc-gentoo.patch"
-
- sed -e "s|gentoo-include|${P}|" \
- -e "s|gentoo-libdir|$(get_libdir)|g" \
- -e "s|VERSION|${P}/VERSION|" \
- -i ./src/scripts/charmc || die "failed patching charmc script"
-
- # install binaries
- cd "${S}"/bin
- dobin ./charmd ./charmd_faceless ./charmr* ./charmc ./charmxi \
- ./conv-cpm ./dep.pl || die "Failed to install binaries"
-
- # install headers
- cd "${S}"/include
- insinto /usr/include/${P}
- doins * || die "failed to install header files"
-
- # install static libs
- cd "${S}"/lib
- dolib.a * || die "failed to install static libs"
-
- # install shared libs
- cd "${S}"/lib_so
- dolib.so * || die "failed to install shared libs"
-
- # basic docs
- cd "${S}"
- dodoc CHANGES README || die "Failed to install docs"
-
- # install examples
- find examples/ -name 'Makefile' | xargs sed \
- -r "s:(../)+bin/charmc:/usr/bin/charmc:" -i || \
- die "Failed to fix examples"
- find examples/ -name 'Makefile' | xargs sed \
- -r "s:./charmrun:./charmrun ++local:" -i || \
- die "Failed to fix examples"
- insinto /usr/share/doc/${PF}/examples
- doins -r examples/charm++/*
-
- # pdf/html docs
- if use doc; then
- cd "${S}"/doc
- # install pdfs
- insinto /usr/share/doc/${PF}/pdf
- doins doc/pdf/* || die "failed to install pdf docs"
- # install html
- docinto html
- dohtml -r doc/html/* || die "failed to install html docs"
- fi
-}
-
-pkg_postinst() {
- echo
- einfo "Please test your charm installation by copying the"
- einfo "content of /usr/share/doc/${PF}/examples to a"
- einfo "temporary location and run 'make test'."
- echo
-}
diff --git a/sys-cluster/charm/files/charm-6.1.2-charmc-gentoo.patch b/sys-cluster/charm/files/charm-6.1.2-charmc-gentoo.patch
index 02cad1354f04..89cec4bf7aa0 100644
--- a/sys-cluster/charm/files/charm-6.1.2-charmc-gentoo.patch
+++ b/sys-cluster/charm/files/charm-6.1.2-charmc-gentoo.patch
@@ -1,26 +1,15 @@
---- src/scripts/charmc.old 2009-05-31 23:09:12.285687725 -0500
-+++ src/scripts/charmc 2009-05-31 23:08:49.782155308 -0500
-@@ -335,19 +335,9 @@
- PROG_EXT=".exe"
+--- src/scripts/charmc.old 2009-11-27 00:57:14.260614376 -0600
++++ src/scripts/charmc 2009-11-27 00:59:14.128805834 -0600
+@@ -343,9 +343,9 @@
+ PROG_EXT=".exe"
fi
--CHARMLIB="$CHARMBIN/../lib"
--CHARMINC="$CHARMBIN/../include"
--CHARMLIBSO=
--if test -d "$CHARMBIN/../lib_so"
--then
-- CHARMLIBSO=`cd $CHARMBIN/../lib_so 2>/dev/null && pwd`
-- #getting absolute path is harder than thought because of symbolic links and ..
-- #ksh needs cd -P to resolve werid symbolic links, however -P is not portable
-- #csh is ok too if it exists
-- test -z "$CHARMLIBSO" && CHARMLIBSO=`cd -P $CHARMBIN/../lib_so 2>/dev/null && pwd`
-- test -z "$CHARMLIBSO" && CHARMLIBSO=`csh -c "cd $CHARMBIN/../lib_so >& /dev/null && pwd"`
-- test -z "$CHARMLIBSO" && echo "$CHARMBIN/../lib_so: not found" && exit 1
--fi
+-CHARMLIB="/usr/lib64"
+-CHARMINC="/usr/include/charm-6.1.2"
+-CHARMLIBSO="/usr/lib64"
+CHARMLIB="/usr/gentoo-libdir"
+CHARMINC="/usr/include/gentoo-include"
+CHARMLIBSO="/usr/gentoo-libdir"
##############################################################################
#
-