summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-04-10 08:05:14 +0000
committerMike Frysinger <vapier@gentoo.org>2008-04-10 08:05:14 +0000
commit90f618324f5d614913d1683e5186061dbf879462 (patch)
tree6e1dad8120841bf3b5147dc931cf54fb67b42ce4 /sys-devel/autoconf-wrapper
parentRevbump to make sure ~arch users get fixes, partly suggested by mraudsepp. (diff)
downloadgentoo-2-90f618324f5d614913d1683e5186061dbf879462.tar.gz
gentoo-2-90f618324f5d614913d1683e5186061dbf879462.tar.bz2
gentoo-2-90f618324f5d614913d1683e5186061dbf879462.zip
old
Diffstat (limited to 'sys-devel/autoconf-wrapper')
-rw-r--r--sys-devel/autoconf-wrapper/autoconf-wrapper-3.2-r2.ebuild28
-rw-r--r--sys-devel/autoconf-wrapper/autoconf-wrapper-3.2.ebuild28
-rwxr-xr-xsys-devel/autoconf-wrapper/files/ac-wrapper-3.2.sh119
3 files changed, 0 insertions, 175 deletions
diff --git a/sys-devel/autoconf-wrapper/autoconf-wrapper-3.2-r2.ebuild b/sys-devel/autoconf-wrapper/autoconf-wrapper-3.2-r2.ebuild
deleted file mode 100644
index f2afb6c6876e..000000000000
--- a/sys-devel/autoconf-wrapper/autoconf-wrapper-3.2-r2.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf-wrapper/autoconf-wrapper-3.2-r2.ebuild,v 1.11 2006/12/29 22:10:55 vapier Exp $
-
-inherit multilib
-
-DESCRIPTION="wrapper for autoconf to manage multiple autoconf versions"
-HOMEPAGE="http://www.gentoo.org/"
-SRC_URI=""
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE=""
-
-S=${WORKDIR}
-
-src_install() {
- exeinto /usr/$(get_libdir)/misc
- newexe "${FILESDIR}"/ac-wrapper-${PV}.sh ac-wrapper.sh || die
- dosed '/^binary_new=/s:2.59:2.60:' /usr/$(get_libdir)/misc/ac-wrapper.sh
-
- dodir /usr/bin
- local x=
- for x in auto{conf,header,m4te,reconf,scan,update} ifnames ; do
- dosym ../$(get_libdir)/misc/ac-wrapper.sh /usr/bin/${x} || die
- done
-}
diff --git a/sys-devel/autoconf-wrapper/autoconf-wrapper-3.2.ebuild b/sys-devel/autoconf-wrapper/autoconf-wrapper-3.2.ebuild
deleted file mode 100644
index 2c88ab46a7e3..000000000000
--- a/sys-devel/autoconf-wrapper/autoconf-wrapper-3.2.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf-wrapper/autoconf-wrapper-3.2.ebuild,v 1.12 2006/11/03 18:39:27 grobian Exp $
-
-DESCRIPTION="wrapper for autoconf to manage multiple autoconf versions"
-HOMEPAGE="http://www.gentoo.org/"
-SRC_URI=""
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE=""
-
-RDEPEND=">=sys-devel/autoconf-2.59-r6
- ~sys-devel/autoconf-2.13"
-
-S=${WORKDIR}
-
-src_install() {
- exeinto /usr/lib/misc
- newexe ${FILESDIR}/ac-wrapper-${PV}.sh ac-wrapper.sh || die
-
- dodir /usr/bin
- local x=
- for x in auto{conf,header,m4te,reconf,scan,update} ifnames ; do
- dosym ../lib/misc/ac-wrapper.sh /usr/bin/${x} || die
- done
-}
diff --git a/sys-devel/autoconf-wrapper/files/ac-wrapper-3.2.sh b/sys-devel/autoconf-wrapper/files/ac-wrapper-3.2.sh
deleted file mode 100755
index 9701f84bd3ab..000000000000
--- a/sys-devel/autoconf-wrapper/files/ac-wrapper-3.2.sh
+++ /dev/null
@@ -1,119 +0,0 @@
-#!/bin/bash
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf-wrapper/files/ac-wrapper-3.2.sh,v 1.1 2005/09/09 23:15:25 azarah Exp $
-
-# Based on the ac-wrapper.pl script provided by MandrakeSoft
-# Rewritten in bash by Gregorio Guidi
-#
-# Executes the correct autoconf version.
-#
-# - defaults to latest version (2.5x)
-# - runs autoconf 2.13 only if:
-# - envvar WANT_AUTOCONF is set to `2.1'
-# -or-
-# - `ac{local,include}.m4' or `configure.{in,ac}' have AC_PREREQ(2.1) (not higher)
-# -or-
-# - `configure' is already present and was generated by autoconf 2.13
-
-if [[ ${0##*/} == "ac-wrapper.sh" ]] ; then
- echo "Don't call this script directly" >&2
- exit 1
-fi
-
-if [[ ${WANT_AUTOCONF} == "2.1" && ${0##*/} == "autom4te" ]] ; then
- echo "ac-wrapper: Autoconf 2.13 doesn't contain autom4te." >&2
- echo " Either unset WANT_AUTOCONF or don't execute anything" >&2
- echo " that would use autom4te." >&2
- exit 1
-fi
-
-binary_new="${0}-2.59"
-binary_old="${0}-2.13"
-binary=${binary_new}
-
-acprereq_version() {
- gawk \
- '($0 !~ /^[[:space:]]*(#|dnl)/) {
- if (match($0, "AC_PREREQ\\(\\[?([0-9]\\.[0-9])", res))
- VERSIONS[COUNT++] = res[1]
- }
-
- END {
- asort(VERSIONS)
- print VERSIONS[COUNT]
- }' "$@"
-}
-
-generated_version() {
- gawk \
- '{
- if (match($0,
- "^# Generated (by (GNU )?Autoconf|automatically using autoconf version) ([0-9].[0-9])",
- res)) {
- print res[3]
- exit
- }
- }' "$@"
-}
-
-#
-# autodetect routine
-#
-if [[ ${WANT_AUTOCONF} != "2.5" ]] ; then
- if [[ ${WANT_AUTOCONF} == "2.1" ]] ; then
- if [[ ! -f "configure.ac" ]] ; then
- binary=${binary_old}
- else
- echo "ac-wrapper: Since configure.ac is present, aclocal always use" >&2
- echo " autoconf 2.59, which conflicts with your choice and" >&2
- echo " causes error. You have two options:" >&2
- echo " 1. Try execute command again after removing configure.ac" >&2
- echo " 2. Don't set WANT_AUTOCONF" >&2
- exit 1
- fi
- else
- # Automake-1.7 and better requie autoconf-2.5x
- case "${WANT_AUTOMAKE}" in
- 1.[7-9]) ;;
- *)
- acfiles=$(ls ac{local,include}.m4 configure.{in,ac} 2>/dev/null)
- [[ -n ${acfiles} ]] && confversion=$(acprereq_version ${acfiles})
-
- [[ -z ${confversion} && -r "configure" ]] && \
- confversion=$(generated_version configure)
-
- if [[ ${confversion} == "2.1" && ! -f "configure.ac" ]] ; then
- binary="${binary_old}"
- fi
- esac
- fi
-fi
-
-if [[ -n ${WANT_ACWRAPPER_DEBUG} ]] ; then
- if [[ -n ${WANT_AUTOCONF} ]] ; then
- echo "ac-wrapper: DEBUG: WANT_AUTOCONF is set to ${WANT_AUTOCONF}" >&2
- fi
- echo "ac-wrapper: DEBUG: will execute <${binary}>" >&2
-fi
-
-#
-# for further consistency
-#
-if [[ ${binary} == "${binary_new}" ]] ; then
- export WANT_AUTOCONF="2.5"
-elif [[ ${binary} == "${binary_old}" ]] ; then
- export WANT_AUTOCONF="2.1"
-fi
-
-if [[ ! -x ${binary} ]] ; then
- # this shouldn't happen
- echo "ac-wrapper: ${binary} is missing or not executable." >&2
- echo " Please try emerging the correct version of autoconf." >&2
- exit 1
-fi
-
-exec "${binary}" "$@"
-
-echo "ac-wrapper: was unable to exec ${binary} !?" >&2
-exit 1