summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-04-25 03:57:16 +0000
committerMike Frysinger <vapier@gentoo.org>2012-04-25 03:57:16 +0000
commita5316a0fd82b7a7f4bf0ff3830d78ff656c7bbb3 (patch)
tree851243fc474bd722ee2ec72f5008ffee9185e804 /sys-devel/autoconf
parentVersion bump. Tentative fix for random failure which might be due to python-3... (diff)
downloadgentoo-2-a5316a0fd82b7a7f4bf0ff3830d78ff656c7bbb3.tar.gz
gentoo-2-a5316a0fd82b7a7f4bf0ff3830d78ff656c7bbb3.tar.bz2
gentoo-2-a5316a0fd82b7a7f4bf0ff3830d78ff656c7bbb3.zip
Version bump.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/autoconf')
-rw-r--r--sys-devel/autoconf/ChangeLog10
-rw-r--r--sys-devel/autoconf/autoconf-2.69.ebuild53
-rw-r--r--sys-devel/autoconf/autoconf-9999.ebuild12
3 files changed, 67 insertions, 8 deletions
diff --git a/sys-devel/autoconf/ChangeLog b/sys-devel/autoconf/ChangeLog
index fce343fe8718..49c5c5eb767d 100644
--- a/sys-devel/autoconf/ChangeLog
+++ b/sys-devel/autoconf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/autoconf
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/ChangeLog,v 1.166 2011/09/21 08:36:01 mgorny Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/ChangeLog,v 1.167 2012/04/25 03:57:16 vapier Exp $
+
+*autoconf-2.69 (25 Apr 2012)
+
+ 25 Apr 2012; Mike Frysinger <vapier@gentoo.org> +autoconf-2.69.ebuild,
+ autoconf-9999.ebuild:
+ Version bump.
21 Sep 2011; Michał Górny <mgorny@gentoo.org> autoconf-9999.ebuild:
Migrate to git-2.
diff --git a/sys-devel/autoconf/autoconf-2.69.ebuild b/sys-devel/autoconf/autoconf-2.69.ebuild
new file mode 100644
index 000000000000..7555c0416509
--- /dev/null
+++ b/sys-devel/autoconf/autoconf-2.69.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.69.ebuild,v 1.1 2012/04/25 03:57:16 vapier Exp $
+
+EAPI="3"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://git.savannah.gnu.org/${PN}.git
+ http://git.savannah.gnu.org/r/${PN}.git"
+
+ inherit git-2
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ SRC_URI="mirror://gnu/${PN}/${P}.tar.xz
+ ftp://alpha.gnu.org/pub/gnu/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+fi
+
+DESCRIPTION="Used to create autoconfiguration files"
+HOMEPAGE="http://www.gnu.org/software/autoconf/autoconf.html"
+
+LICENSE="GPL-3"
+SLOT="2.5"
+IUSE="emacs"
+
+DEPEND=">=sys-apps/texinfo-4.3
+ >=sys-devel/m4-1.4.6
+ >=dev-lang/perl-5.6"
+RDEPEND="${DEPEND}
+ >=sys-devel/autoconf-wrapper-10"
+PDEPEND="emacs? ( app-emacs/autoconf-mode )"
+
+src_prepare() {
+ if [[ ${PV} == "9999" ]] ; then
+ autoreconf -f -i || die
+ fi
+}
+
+src_configure() {
+ # Disable Emacs in the build system since it is in a separate package.
+ export EMACS=no
+ econf --program-suffix="-${PV}" || die
+ # econf updates config.{sub,guess} which forces the manpages
+ # to be regenerated which we dont want to do #146621
+ touch man/*.1
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS BUGS NEWS README TODO THANKS \
+ ChangeLog ChangeLog.0 ChangeLog.1 ChangeLog.2
+}
diff --git a/sys-devel/autoconf/autoconf-9999.ebuild b/sys-devel/autoconf/autoconf-9999.ebuild
index eb8c5125e6f0..2471b7be65c3 100644
--- a/sys-devel/autoconf/autoconf-9999.ebuild
+++ b/sys-devel/autoconf/autoconf-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-9999.ebuild,v 1.4 2011/09/21 08:36:01 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-9999.ebuild,v 1.5 2012/04/25 03:57:16 vapier Exp $
-EAPI="2"
+EAPI="3"
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://git.savannah.gnu.org/${PN}.git
@@ -12,8 +12,8 @@ if [[ ${PV} == "9999" ]] ; then
SRC_URI=""
#KEYWORDS=""
else
- SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2
- ftp://alpha.gnu.org/pub/gnu/${PN}/${P}.tar.bz2"
+ SRC_URI="mirror://gnu/${PN}/${P}.tar.xz
+ ftp://alpha.gnu.org/pub/gnu/${PN}/${P}.tar.xz"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
fi
@@ -26,7 +26,7 @@ IUSE="emacs"
DEPEND=">=sys-apps/texinfo-4.3
>=sys-devel/m4-1.4.6
- dev-lang/perl"
+ >=dev-lang/perl-5.6"
RDEPEND="${DEPEND}
>=sys-devel/autoconf-wrapper-10"
PDEPEND="emacs? ( app-emacs/autoconf-mode )"