summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-16 02:30:56 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-16 02:30:56 +0000
commitd1ffd1b9e16e8398b6d7712219c43a71649daa63 (patch)
tree78a6283ab73d2046765dc615f64b749dd337f3ad /sys-devel/binutils-config
parentSupport $(get_libdir) for funky arches (diff)
downloadgentoo-2-d1ffd1b9e16e8398b6d7712219c43a71649daa63.tar.gz
gentoo-2-d1ffd1b9e16e8398b6d7712219c43a71649daa63.tar.bz2
gentoo-2-d1ffd1b9e16e8398b6d7712219c43a71649daa63.zip
Support $(get_libdir) for funky arches.
Diffstat (limited to 'sys-devel/binutils-config')
-rw-r--r--sys-devel/binutils-config/ChangeLog8
-rw-r--r--sys-devel/binutils-config/binutils-config-1.3.ebuild19
-rwxr-xr-xsys-devel/binutils-config/files/binutils-config-1.3267
-rw-r--r--sys-devel/binutils-config/files/digest-binutils-config-1.30
4 files changed, 293 insertions, 1 deletions
diff --git a/sys-devel/binutils-config/ChangeLog b/sys-devel/binutils-config/ChangeLog
index 03b4928d28d4..219c28d9cd9f 100644
--- a/sys-devel/binutils-config/ChangeLog
+++ b/sys-devel/binutils-config/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/binutils-config
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-config/ChangeLog,v 1.3 2004/12/15 17:00:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-config/ChangeLog,v 1.4 2004/12/16 02:30:56 vapier Exp $
+
+*binutils-config-1.3 (15 Dec 2004)
+
+ 15 Dec 2004; Mike Frysinger <vapier@gentoo.org>
+ +files/binutils-config-1.3, +binutils-config-1.3.ebuild:
+ Support $(get_libdir) for funky arches.
*binutils-config-1.2 (15 Dec 2004)
diff --git a/sys-devel/binutils-config/binutils-config-1.3.ebuild b/sys-devel/binutils-config/binutils-config-1.3.ebuild
new file mode 100644
index 000000000000..75844dac6d5b
--- /dev/null
+++ b/sys-devel/binutils-config/binutils-config-1.3.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-config/binutils-config-1.3.ebuild,v 1.1 2004/12/16 02:30:56 vapier Exp $
+
+DESCRIPTION="Utility to change the binutils version being used"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+DEPEND="app-shells/bash"
+
+src_install() {
+ newbin ${FILESDIR}/${PN}-${PV} ${PN} || die
+ dosed "s:PORTAGE-VERSION:${PV}:" /usr/bin/${PN}
+}
diff --git a/sys-devel/binutils-config/files/binutils-config-1.3 b/sys-devel/binutils-config/files/binutils-config-1.3
new file mode 100755
index 000000000000..51281e5fb00c
--- /dev/null
+++ b/sys-devel/binutils-config/files/binutils-config-1.3
@@ -0,0 +1,267 @@
+#!/bin/bash
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils-config/files/binutils-config-1.3,v 1.1 2004/12/16 02:30:56 vapier Exp $
+
+# Format of /etc/env.d/binutils/:
+# config-TARGET: CURRENT=version for TARGET
+# TARGET-VER: has a TARGET and VER variable
+
+trap ":" INT QUIT TSTP
+
+source /etc/init.d/functions.sh || {
+ echo "$0: Could not source /etc/init.d/functions.sh!"
+ exit 1
+}
+umask 022
+
+usage() {
+cat << "USAGE_END"
+Usage: binutils-config [options] [binutils profile]
+Change the current binutils profile, or give info about profiles.
+
+Options:
+ -c, --get-current-profile Print current profile
+ -l, --list-profiles Print a list of available profiles
+ -u, --uninstall Remove all signs of specified target
+
+Profile names are of the form: <CHOST>-<binutils version>
+For example: x86_64-pc-linux-gnu-2.15.92.0.2
+USAGE_END
+}
+
+[[ $# -lt 1 ]] && usage && exit 1
+
+switch_profile() {
+ unset TARGET VER LIBPATH
+ source "${ENV_D}/${PROFILE}"
+ if [[ -z ${TARGET} ]] ; then
+ eerror "${PROFILE} is invalid (no \$TARGET defined) :("
+ return 1
+ fi
+ if [[ -z ${VER} ]] ; then
+ eerror "${PROFILE} is invalid (no \$VER defined) :("
+ return 1
+ fi
+
+ ebegin "Switching to ${PROFILE}"
+
+ #
+ # Generate binary symlinks
+ #
+ BINPATH="/usr/${TARGET}/binutils-bin/${VER}"
+ cd "${ROOT}/${BINPATH}" || exit 1
+ mkdir -p "${ROOT}"/usr/${TARGET}/bin
+ for x in * ; do
+ ln -sf "${BINPATH}/${x}" "${ROOT}"/usr/${TARGET}/bin/${x}
+ ln -sf ../${TARGET}/bin/${x} "${ROOT}"/usr/bin/${TARGET}-${x}
+ if [[ ${TARGET} == ${HOST} ]] ; then
+ ln -sf ${TARGET}-${x} "${ROOT}"/usr/bin/${x}
+ fi
+ done
+
+ #
+ # Generate library / ldscripts symlinks
+ #
+ LIBPATH="${LIBPATH:-/usr/lib/binutils/${TARGET}/${VER}}"
+ cd "${ROOT}/${LIBPATH}" || exit 1
+ mkdir -p "${ROOT}"/usr/${TARGET}/lib
+ if [[ -d ${ROOT}/usr/${TARGET}/lib/ldscripts ]] ; then
+ # When upgrading, we need to clean up ldscripts
+ rm -r "${ROOT}"/usr/${TARGET}/lib/ldscripts
+ else
+ rm -f "${ROOT}"/usr/${TARGET}/lib/ldscripts
+ fi
+ ln -sf "${LIBPATH}/ldscripts" "${ROOT}"/usr/${TARGET}/lib/ldscripts
+ if [[ ${TARGET} = ${HOST} ]] ; then
+ dstlib="${ROOT}"/usr/${HOST}/lib
+ else
+ dstlib="${ROOT}"/usr/${HOST}/${TARGET}/lib
+ fi
+ mkdir -p "${dstlib}"
+ for x in lib* ; do
+ ln -sf "${LIBPATH}/${x}" "${dstlib}/${x}"
+ done
+
+ #
+ # Generate include symlinks
+ #
+ INCPATH="${LIBPATH}/include"
+ cd "${ROOT}/${INCPATH}" || exit 1
+ if [[ ${TARGET} = ${HOST} ]] ; then
+ dstinc="${ROOT}"/usr/include
+ else
+ dstinc="${ROOT}"/usr/${TARGET}/include
+ fi
+ mkdir -p "${dstinc}"
+ for x in * ; do
+ ln -sf "${INCPATH}/${x}" "${dstinc}/${x}"
+ done
+
+ eend 0
+
+ echo "CURRENT=${VER}" > "${ENV_D}/config-${TARGET}"
+
+ return 0
+}
+
+uninstall_target() {
+ if [[ ${TARGET} = ${HOST} ]] ; then
+ eerror "$0: Refusing to uninstall native binutils"
+ exit 1
+ fi
+
+ shopt -s nullglob
+ PROFILE=""
+
+ for PROFILE in "${ENV_D}"/${TARGET}-* ; do
+ ewarn "Removing all signs of ${PROFILE##*/}"
+ rm -f "${ENV_D}"/${PROFILE}
+ done
+ if [[ -z ${PROFILE} ]] ; then
+ eerror "$0: No profiles exist for '${TARGET}'"
+ exit 1
+ fi
+
+ rm -f "${ENV_D}"/config-${TARGET}
+
+ for x in addr2line ar as c++filt ld nm objcopy \
+ objdump ranlib readelf size strings strip ; do
+ rm -f "${ROOT}"/usr/bin/${TARGET}-${x}
+ rm -f "${ROOT}"/usr/${TARGET}/bin/${x}
+ done
+ for x in ansidecl.h bfd.h bfdlink.h dis-asm.h symcat.h ; do
+ rm -f "${ROOT}"/usr/${TARGET}/include/${x}
+ done
+ rm -f "${ROOT}"/usr/${TARGET}/lib/ldscripts
+}
+
+get_current_profile() {
+ if [[ ! -f ${ENV_D}/config-${PROFILE} ]] ; then
+ eerror "$0: No binutils profile is active!"
+ return 1
+ fi
+
+ source "${ENV_D}/config-${PROFILE}"
+
+ if [[ -z ${CURRENT} ]] ; then
+ eerror "$0: No binutils profile is active!"
+ return 1
+ fi
+
+ echo "${PROFILE}-${CURRENT}"
+
+ return 0
+}
+
+list_profiles() {
+ local i=1
+
+ if [[ ${ROOT} != / ]] ; then
+ echo "Using binutils-config info in ${ROOT}"
+ fi
+ target=
+ for x in "${ENV_D}"/* ; do
+ if [[ -f ${x} ]] && [[ ${x/\/config-} = ${x} ]] ; then
+ source "${x}"
+ if [[ ${target} != ${TARGET} ]] ; then
+ [[ -n ${target} ]] && echo
+ target="${TARGET}"
+ fi
+
+ x="${x##*/}"
+ if [[ -e ${ENV_D}/config-${TARGET} ]] ; then
+ source "${ENV_D}/config-${TARGET}"
+ [ "${VER}" == "${CURRENT}" ] && x="${x} *"
+ fi
+ echo " [${i}] ${x}"
+ i=$((i + 1))
+ fi
+ done
+}
+
+[[ -z ${ROOT} ]] && ROOT="/"
+ENV_D="${ROOT}etc/env.d/binutils"
+
+NEED_ACTION="yes"
+DOIT="switch_profile"
+PROFILE=""
+
+while [[ $# -gt 0 ]] ; do
+ x=$1
+ shift
+ case "${x}" in
+ -c|--get-current-profile)
+ if [[ ${NEED_ACTION} = "yes" ]] ; then
+ NEED_ACTION="no"
+ DOIT="get_current_profile"
+ fi
+ ;;
+ -l|--list-profiles)
+ if [[ ${NEED_ACTION} = "yes" ]] ; then
+ NEED_ACTION="no"
+ DOIT="list_profiles"
+ fi
+ ;;
+ -u|--uninstall)
+ if [[ ${NEED_ACTION} = "yes" ]] ; then
+ NEED_ACTION="no"
+ DOIT="uninstall_target"
+ TARGET="$1"
+ shift
+ fi
+ ;;
+ -h|--help)
+ usage
+ exit 0
+ ;;
+ -v|--version)
+ echo "binutils-config-1.0"
+ exit 0
+ ;;
+ -*)
+ eerror "$0: Invalid switch! Run $0 without parameters for help."
+ exit 1
+ ;;
+ *)
+ if [[ -n ${PROFILE} ]] ; then
+ eerror "$0: Too many arguments! Run $0 without parameters for help."
+ exit 1
+ fi
+
+ if [[ -z $(echo ${x} | tr -d '[:digit:]') ]] ; then
+ # User gave us a # representing the profile
+ i=1
+ for y in "${ENV_D}"/* ; do
+ [[ ${y/config-} != ${y} ]] && continue
+
+ if [[ -f ${y} ]] && [[ ${x} -eq ${i} ]] ; then
+ PROFILE="${y##*/}"
+ break
+ fi
+ i=$((i + 1))
+ done
+ else
+ # User gave us a full HOST-ver
+ x="${x##*/}"
+ if [[ ! -f ${ENV_D}/${x} ]] && [[ ! -f ${ENV_D}/config-${x} ]] ; then
+ eerror "$0: Could not locate '$x' in '${ENV_D}/'!"
+ exit 1
+ fi
+ PROFILE="${x}"
+ fi
+ ;;
+ esac
+done
+
+if [[ ${DOIT} != "list_profiles" ]] ; then
+ if [[ -z ${CHOST} ]] ; then
+ HOST="$(portageq envvar CHOST)"
+ else
+ HOST="${CHOST}"
+ fi
+fi
+[ -z "${PROFILE}" ] && PROFILE="${HOST}"
+eval ${DOIT}
+
+# vim:ts=4
diff --git a/sys-devel/binutils-config/files/digest-binutils-config-1.3 b/sys-devel/binutils-config/files/digest-binutils-config-1.3
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/sys-devel/binutils-config/files/digest-binutils-config-1.3