summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-06-09 02:10:54 +0000
committerAchim Gottinger <achim@gentoo.org>2001-06-09 02:10:54 +0000
commit3b85f6dfe5c5a53951d993f35d74fe88597ee623 (patch)
treeb0ddc2a1d67e12d8db8eeca758d016248d77d1a8 /sys-devel/binutils
parentSome cleanup (diff)
downloadgentoo-2-3b85f6dfe5c5a53951d993f35d74fe88597ee623.tar.gz
gentoo-2-3b85f6dfe5c5a53951d993f35d74fe88597ee623.tar.bz2
gentoo-2-3b85f6dfe5c5a53951d993f35d74fe88597ee623.zip
*** empty log message ***
Diffstat (limited to 'sys-devel/binutils')
-rw-r--r--sys-devel/binutils/binutils-2.10.0.26.ebuild64
-rw-r--r--sys-devel/binutils/binutils-2.10.91.0.2-r1.ebuild64
-rw-r--r--sys-devel/binutils/files/digest-binutils-2.10.0.261
-rw-r--r--sys-devel/binutils/files/digest-binutils-2.10.91.0.2-r11
4 files changed, 0 insertions, 130 deletions
diff --git a/sys-devel/binutils/binutils-2.10.0.26.ebuild b/sys-devel/binutils/binutils-2.10.0.26.ebuild
deleted file mode 100644
index 6aab41fa67f4..000000000000
--- a/sys-devel/binutils/binutils-2.10.0.26.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.10.0.26.ebuild,v 1.1 2000/09/28 01:57:28 achim Exp $
-
-A=${P}.tar.gz
-S=${WORKDIR}/${P}
-DESCRIPTION="Tools necessary to build programs"
-SRC_URI="ftp://ftp.varesearch.com/pub/support/hjl/binutils/${A}"
-
-src_compile() {
- try ./configure --prefix=/usr --host=${CHOST}
- try make
-}
-
-src_install() {
- #I'm sure this can be simplified with a "try make PREFIX=${D}/usr install"
- #one of these days...
- into /usr
- doman binutils/*.1 gas/doc/as.1 gprof/gprof.1
- insinto /usr/lib
- doins bfd/libbfd.la bfd/libbfd.a opcodes/libopcodes.a opcodes/libopcodes.la libiberty/libiberty.a
- insinto /usr/include
- doins bfd/bfd.h include/ansidecl.h include/bfdlink.h
- cp binutils/nm-new binutils/nm
- cp binutils/strip-new binutils/strip
- cp gas/as-new gas/as
- cp gas/gasp-new gas/gasp
- cp ld/ld-new ld/ld
- cd binutils
- dobin addr2line ar cxxfilt nm objcopy objdump ranlib readelf size strings strip
- cd ..
- dobin ld/ld gprof/gprof gas/as gas/gasp
- dodir /usr/${CHOST}/bin
- for i in nm strip ar ranlib as ld
- do
- dosym /usr/bin/${i} /usr/${CHOST}/bin/${i}
- done
- insinto /usr/${CHOST}/lib/ldscripts
- doins ld/ldscripts/*
- dodoc COPYING* README* ChangeLog* mpw-README
- docinto bfd
- dodoc bfd/ChangeLog* bfd/COPYING bfd/README bfd/PORTING bfd/TODO
- docinto binutils
- dodoc binutils/MAINTAINERS binutils/NEWS binutils/README
- docinto gas
- dodoc gas/ChangeLog* gas/CONTRIBUTORS gas/COPYING gas/MAINTAINERS gas/NEWS gas/README*
- docinto gprof
- dodoc gprof/ChangeLog* gprof/MAINTAINERS gprof/NOTES gprof/TEST gprof/TODO
- docinto include
- dodoc include/ChangeLog* include/COPYING include/MAINTAINERS
- docinto intl
- dodoc intl/ChangeLog
- docinto ld
- dodoc ld/ChangeLog* ld/MAINTAINERS ld/README ld/NEWS ld/TODO
- docinto libiberty
- dodoc libiberty/ChangeLog* libiberty/COPYING.LIB libiberty/README
- docinto opcodes
- dodoc opcodes/ChangeLog* opcodes/MAINTAINERS
-
-}
-
-
-
diff --git a/sys-devel/binutils/binutils-2.10.91.0.2-r1.ebuild b/sys-devel/binutils/binutils-2.10.91.0.2-r1.ebuild
deleted file mode 100644
index f4c6fd6cafbb..000000000000
--- a/sys-devel/binutils/binutils-2.10.91.0.2-r1.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.10.91.0.2-r1.ebuild,v 1.4 2001/05/01 10:13:38 achim Exp $
-
-A=${P}.tar.gz
-S=${WORKDIR}/${P}
-DESCRIPTION="Tools necessary to build programs"
-SRC_URI="http://ftp.valinux.com/pub/support/hjl/binutils/${A}"
-
-if [ -z "`use build`" ] ; then
- DEPEND="nls? ( sys-devel/gettext )"
-fi
-
-src_compile() {
-
- local myconf
- if [ "`use nls`" ]
- then
- if [ "`use build`" ] ; then
- myconf="--with-included-gettext"
- fi
- else
- myconf="--disable-nls"
- fi
- try ./configure --prefix=/usr --mandir=/usr/share/man --host=${CHOST} ${myconf}
- if [ "`use static`" ]
- then
- try make -e LDFLAGS=-all-static ${MAKEOPTS}
- else
- try make ${MAKEOPTS}
- fi
-}
-
-src_install() {
-
- try make prefix=${D}/usr mandir=${D}/usr/share/man install
-
- if [ -z "`use build`" ]
- then
- dodoc COPYING* README
- docinto bfd
- dodoc bfd/ChangeLog* bfd/COPYING bfd/README bfd/PORTING bfd/TODO
- docinto binutils
- dodoc binutils/ChangeLog binutils/NEWS binutils/README
- docinto gas
- dodoc gas/ChangeLog* gas/CONTRIBUTORS gas/COPYING \
- gas/NEWS gas/README*
- docinto gprof
- dodoc gprof/ChangeLog* gprof/NOTES gprof/TEST gprof/TODO
- docinto ld
- dodoc ld/ChangeLog* ld/README ld/NEWS ld/TODO
- docinto libiberty
- dodoc libiberty/ChangeLog* libiberty/COPYING.LIB libiberty/README
- docinto opcodes
- dodoc opcodes/ChangeLog*
- else
- rm -rf ${D}/usr/share/man
- fi
-
-}
-
-
-
diff --git a/sys-devel/binutils/files/digest-binutils-2.10.0.26 b/sys-devel/binutils/files/digest-binutils-2.10.0.26
deleted file mode 100644
index d951d3ed4959..000000000000
--- a/sys-devel/binutils/files/digest-binutils-2.10.0.26
+++ /dev/null
@@ -1 +0,0 @@
-MD5 85662fb0b136f3b0fccd211fdde259a9 binutils-2.10.0.26.tar.gz
diff --git a/sys-devel/binutils/files/digest-binutils-2.10.91.0.2-r1 b/sys-devel/binutils/files/digest-binutils-2.10.91.0.2-r1
deleted file mode 100644
index f21977d64c6e..000000000000
--- a/sys-devel/binutils/files/digest-binutils-2.10.91.0.2-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 76a67983e1ce656681925cb2c7b2ba45 binutils-2.10.91.0.2.tar.gz