summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-03-29 04:58:51 +0000
committerMike Frysinger <vapier@gentoo.org>2010-03-29 04:58:51 +0000
commit08a9eab129c1e0d013ff0d6a7335f92eb745e8ee (patch)
tree60e3c159c8ec7f18db8b3287e57c2cdbccf558ca /sys-devel/bison
parentfix header (diff)
downloadgentoo-2-08a9eab129c1e0d013ff0d6a7335f92eb745e8ee.tar.gz
gentoo-2-08a9eab129c1e0d013ff0d6a7335f92eb745e8ee.tar.bz2
gentoo-2-08a9eab129c1e0d013ff0d6a7335f92eb745e8ee.zip
Version bump #311727 by Lars Wendler.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/bison')
-rw-r--r--sys-devel/bison/ChangeLog7
-rw-r--r--sys-devel/bison/bison-2.4.2.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/sys-devel/bison/ChangeLog b/sys-devel/bison/ChangeLog
index 9f535202174f..d150c3eff805 100644
--- a/sys-devel/bison/ChangeLog
+++ b/sys-devel/bison/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/bison
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.78 2010/01/24 21:24:57 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.79 2010/03/29 04:58:51 vapier Exp $
+
+*bison-2.4.2 (29 Mar 2010)
+
+ 29 Mar 2010; Mike Frysinger <vapier@gentoo.org> +bison-2.4.2.ebuild:
+ Version bump #311727 by Lars Wendler.
24 Jan 2010; Jonathan Callen <abcd@gentoo.org> bison-2.4.1.ebuild:
Remove old, unused build-dep on flex; cleanup (no patches => no need to
diff --git a/sys-devel/bison/bison-2.4.2.ebuild b/sys-devel/bison/bison-2.4.2.ebuild
new file mode 100644
index 000000000000..0de2f479cd0d
--- /dev/null
+++ b/sys-devel/bison/bison-2.4.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-2.4.2.ebuild,v 1.1 2010/03/29 04:58:51 vapier Exp $
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="A yacc-compatible parser generator"
+HOMEPAGE="http://www.gnu.org/software/bison/bison.html"
+SRC_URI="mirror://gnu/bison/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="nls static"
+
+DEPEND="nls? ( sys-devel/gettext )"
+RDEPEND="sys-devel/m4"
+
+src_compile() {
+ use static && append-ldflags -static
+ econf $(use_enable nls)
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ # This one is installed by dev-util/yacc
+ mv "${D}"/usr/bin/yacc{,.bison} || die
+ mv "${D}"/usr/share/man/man1/yacc{,.bison}.1 || die
+
+ # We do not need this.
+ rm -r "${D}"/usr/lib* || die
+
+ dodoc AUTHORS NEWS ChangeLog README OChangeLog THANKS TODO
+}
+
+pkg_postinst() {
+ if [[ ! -e ${ROOT}/usr/bin/yacc ]] ; then
+ ln -s yacc.bison "${ROOT}"/usr/bin/yacc
+ fi
+}