summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-10-26 03:57:45 +0000
committerMike Frysinger <vapier@gentoo.org>2006-10-26 03:57:45 +0000
commit792effceeaeeb016e8b67a315dfad84745240508 (patch)
tree8cd8ef8b372f925b0c747f4e1a263d6f067e84d3 /sys-devel/bison
parentstable x86 (diff)
downloadgentoo-2-792effceeaeeb016e8b67a315dfad84745240508.tar.gz
gentoo-2-792effceeaeeb016e8b67a315dfad84745240508.tar.bz2
gentoo-2-792effceeaeeb016e8b67a315dfad84745240508.zip
Version bump #152812 by Bernd Buschinski.
(Portage version: 2.1.2_pre3-r7)
Diffstat (limited to 'sys-devel/bison')
-rw-r--r--sys-devel/bison/ChangeLog7
-rw-r--r--sys-devel/bison/bison-2.3.ebuild42
-rw-r--r--sys-devel/bison/files/digest-bison-2.33
3 files changed, 51 insertions, 1 deletions
diff --git a/sys-devel/bison/ChangeLog b/sys-devel/bison/ChangeLog
index 2a431a350e5e..54711d25d457 100644
--- a/sys-devel/bison/ChangeLog
+++ b/sys-devel/bison/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/bison
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.61 2006/10/17 12:49:00 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.62 2006/10/26 03:57:45 vapier Exp $
+
+*bison-2.3 (26 Oct 2006)
+
+ 26 Oct 2006; Mike Frysinger <vapier@gentoo.org> +bison-2.3.ebuild:
+ Version bump #152812 by Bernd Buschinski.
17 Oct 2006; Roy Marples <uberlord@gentoo.org> bison-2.2.ebuild:
Added ~sparc-fbsd keyword.
diff --git a/sys-devel/bison/bison-2.3.ebuild b/sys-devel/bison/bison-2.3.ebuild
new file mode 100644
index 000000000000..158f38cc85eb
--- /dev/null
+++ b/sys-devel/bison/bison-2.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-2.3.ebuild,v 1.1 2006/10/26 03:57:45 vapier Exp $
+
+inherit toolchain-funcs flag-o-matic
+
+DESCRIPTION="A yacc-compatible parser generator"
+HOMEPAGE="http://www.gnu.org/software/bison/bison.html"
+SRC_URI="mirror://gnu/bison/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="nls static"
+
+DEPEND="nls? ( sys-devel/gettext )"
+
+RDEPEND="sys-devel/m4"
+
+src_compile() {
+ use static && append-ldflags -static
+ econf $(use_enable nls) || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ # This one is installed by dev-util/yacc
+ mv "${D}"/usr/bin/yacc{,.bison} || die
+
+ # We do not need this.
+ rm -r "${D}"/usr/lib
+
+ dodoc AUTHORS NEWS ChangeLog README REFERENCES OChangeLog doc/FAQ
+}
+
+pkg_postinst() {
+ if [[ ! -e ${ROOT}/usr/bin/yacc ]] ; then
+ ln -s yacc.bison "${ROOT}"/usr/bin/yacc
+ fi
+}
diff --git a/sys-devel/bison/files/digest-bison-2.3 b/sys-devel/bison/files/digest-bison-2.3
new file mode 100644
index 000000000000..d638f6d22e19
--- /dev/null
+++ b/sys-devel/bison/files/digest-bison-2.3
@@ -0,0 +1,3 @@
+MD5 c18640c6ec31a169d351e3117ecce3ec bison-2.3.tar.bz2 1080319
+RMD160 c6a116d6b763fad3f4df6e303943e09ed080cb26 bison-2.3.tar.bz2 1080319
+SHA256 b10d7e9e354be72aee4e4911cf19dd27b5c527d4e7200857365b5fcdeea0dffb bison-2.3.tar.bz2 1080319