summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-05-16 19:37:21 +0000
committerMike Frysinger <vapier@gentoo.org>2011-05-16 19:37:21 +0000
commit7a416726ea0045c1b99e0a969be9471c1a022f18 (patch)
treef99f6ada579a90ad60a1b98dec396837b9939bbf /sys-devel/bison
parentNo JIT compiler support. (diff)
downloadgentoo-2-7a416726ea0045c1b99e0a969be9471c1a022f18.tar.gz
gentoo-2-7a416726ea0045c1b99e0a969be9471c1a022f18.tar.bz2
gentoo-2-7a416726ea0045c1b99e0a969be9471c1a022f18.zip
Version bump #367459 by taaroa.
(Portage version: 2.2.0_alpha32/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/bison')
-rw-r--r--sys-devel/bison/ChangeLog7
-rw-r--r--sys-devel/bison/bison-2.5.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/sys-devel/bison/ChangeLog b/sys-devel/bison/ChangeLog
index 0aaddd810f1e..9e8332187395 100644
--- a/sys-devel/bison/ChangeLog
+++ b/sys-devel/bison/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/bison
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.97 2011/02/06 11:31:15 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/ChangeLog,v 1.98 2011/05/16 19:37:21 vapier Exp $
+
+*bison-2.5 (16 May 2011)
+
+ 16 May 2011; Mike Frysinger <vapier@gentoo.org> +bison-2.5.ebuild:
+ Version bump #367459 by taaroa.
06 Feb 2011; Mart Raudsepp <leio@gentoo.org> bison-1.875d.ebuild,
bison-2.3.ebuild:
diff --git a/sys-devel/bison/bison-2.5.ebuild b/sys-devel/bison/bison-2.5.ebuild
new file mode 100644
index 000000000000..a727c8709c67
--- /dev/null
+++ b/sys-devel/bison/bison-2.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-2.5.ebuild,v 1.1 2011/05/16 19:37:21 vapier Exp $
+
+EAPI="2"
+
+inherit eutils
+
+DESCRIPTION="A yacc-compatible parser generator"
+HOMEPAGE="http://www.gnu.org/software/bison/bison.html"
+SRC_URI="mirror://gnu/bison/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+IUSE="nls static"
+
+DEPEND="nls? ( sys-devel/gettext )"
+RDEPEND="sys-devel/m4"
+
+src_configure() {
+ use static && append-ldflags -static
+ econf $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ # This one is installed by dev-util/yacc
+ mv "${D}"/usr/bin/yacc{,.bison} || die
+ mv "${D}"/usr/share/man/man1/yacc{,.bison}.1 || die
+
+ # We do not need this.
+ rm -r "${D}"/usr/lib* || die
+
+ dodoc AUTHORS NEWS ChangeLog README OChangeLog THANKS TODO
+}
+
+pkg_postinst() {
+ if [[ ! -e ${ROOT}/usr/bin/yacc ]] ; then
+ ln -s yacc.bison "${ROOT}"/usr/bin/yacc
+ fi
+}