summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-04-24 12:12:06 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-04-24 12:12:06 +0000
commitc19ca0fd5ed297af1c30e5dcfcdc1d5ecef5365b (patch)
tree929cf2bea9d21c951076a9f2652ddfd5ed180c75 /sys-devel/bmake/bmake-20120325.ebuild
parentRemoving vulnerable non-stable ebuilds from tree. (diff)
downloadgentoo-2-c19ca0fd5ed297af1c30e5dcfcdc1d5ecef5365b.tar.gz
gentoo-2-c19ca0fd5ed297af1c30e5dcfcdc1d5ecef5365b.tar.bz2
gentoo-2-c19ca0fd5ed297af1c30e5dcfcdc1d5ecef5365b.zip
version bump
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/bmake/bmake-20120325.ebuild')
-rw-r--r--sys-devel/bmake/bmake-20120325.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/sys-devel/bmake/bmake-20120325.ebuild b/sys-devel/bmake/bmake-20120325.ebuild
new file mode 100644
index 000000000000..32612b3326a3
--- /dev/null
+++ b/sys-devel/bmake/bmake-20120325.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bmake/bmake-20120325.ebuild,v 1.1 2012/04/24 12:12:06 aballier Exp $
+
+EAPI=3
+
+inherit eutils
+
+MK_VER=20120315
+DESCRIPTION="NetBSD's portable make"
+HOMEPAGE="http://www.crufty.net/help/sjg/bmake.html"
+SRC_URI="http://void.crufty.net/ftp/pub/sjg/${P}.tar.gz
+ http://void.crufty.net/ftp/pub/sjg/mk-${MK_VER}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${PN}"
+
+src_configure() {
+ econf \
+ --with-mksrc=../mk \
+ --with-default-sys-path=/usr/share/mk/${PN} \
+ --with-machine_arch=${ARCH}
+}
+
+src_compile() {
+ sh make-bootstrap.sh || die "bootstrap failed"
+}
+
+src_test() {
+ cd unit-tests
+ LC_ALL=C env -u A ${S}/bmake -r -m . > test.out 2>&1 \
+ || die "tests compilation failed"
+ sed -i \
+ -e "s:${S}/::g" \
+ -e "s:bmake:make:g" \
+ -e "s:unit-tests/::g" \
+ test.out || die "Fixing values failed"
+ diff -u test.exp test.out
+ [[ $(diff -u test.exp test.out |wc -l) -gt 0 ]] && die "tests differ"
+}
+
+src_install() {
+ dobin ${PN} || die
+ newman ${PN}.cat1 ${PN}.1 || die
+ FORCE_BSD_MK=1 SYS_MK_DIR=. \
+ sh ../mk/install-mk -v -m 644 "${D}"/usr/share/mk/${PN} \
+ || die "failed to install mk files"
+}