summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2011-06-14 08:31:35 +0000
committerNaohiro Aota <naota@gentoo.org>2011-06-14 08:31:35 +0000
commitfe7aa080f6c92384ac2b955b4feb17023cbfadd2 (patch)
tree3e63abb390126b7da0a39010568b71dc67aa7bc6 /sys-devel/bmake
parentImprove patch to avoid warnings and build failures with USE=nis; thanks to Ju... (diff)
downloadgentoo-2-fe7aa080f6c92384ac2b955b4feb17023cbfadd2.tar.gz
gentoo-2-fe7aa080f6c92384ac2b955b4feb17023cbfadd2.tar.bz2
gentoo-2-fe7aa080f6c92384ac2b955b4feb17023cbfadd2.zip
Version bump. fix bug #327399
(Portage version: 2.2.0_alpha40/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/bmake')
-rw-r--r--sys-devel/bmake/ChangeLog9
-rw-r--r--sys-devel/bmake/bmake-20110606.ebuild55
2 files changed, 62 insertions, 2 deletions
diff --git a/sys-devel/bmake/ChangeLog b/sys-devel/bmake/ChangeLog
index 6109cd910ef7..363768957138 100644
--- a/sys-devel/bmake/ChangeLog
+++ b/sys-devel/bmake/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/bmake
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bmake/ChangeLog,v 1.7 2009/08/10 09:19:13 aballier Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bmake/ChangeLog,v 1.8 2011/06/14 08:31:35 naota Exp $
+
+*bmake-20110606 (14 Jun 2011)
+
+ 14 Jun 2011; Naohiro Aota <naota@gentoo.org> +bmake-20110606.ebuild:
+ Version bump. fix bug #327399
10 Aug 2009; Alexis Ballier <aballier@gentoo.org> -bmake-20080515.ebuild:
remove old
diff --git a/sys-devel/bmake/bmake-20110606.ebuild b/sys-devel/bmake/bmake-20110606.ebuild
new file mode 100644
index 000000000000..c34954575c9a
--- /dev/null
+++ b/sys-devel/bmake/bmake-20110606.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bmake/bmake-20110606.ebuild,v 1.1 2011/06/14 08:31:35 naota Exp $
+
+EAPI=3
+
+inherit eutils
+
+MK_VER=20110606
+DESCRIPTION="NetBSD's portable make"
+HOMEPAGE="http://www.crufty.net/help/sjg/bmake.html"
+SRC_URI="http://void.crufty.net/ftp/pub/sjg/${P}.tar.gz
+ http://void.crufty.net/ftp/pub/sjg/mk-${MK_VER}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${PN}"
+
+src_configure() {
+ econf \
+ --with-mksrc=../mk \
+ --with-default-sys-path=/usr/share/mk/${PN} \
+ --with-machine_arch=${ARCH}
+}
+
+src_compile() {
+ sh make-bootstrap.sh || die "bootstrap failed"
+}
+
+src_test() {
+ cd unit-tests
+ LC_ALL=C env -u A ${S}/bmake -r -m . > test.out 2>&1 \
+ || die "tests compilation failed"
+ sed -i \
+ -e "s:${S}/::g" \
+ -e "s:bmake:make:g" \
+ -e "s:unit-tests/::g" \
+ test.out || die "Fixing values failed"
+ diff -u test.exp test.out
+ [[ $(diff -u test.exp test.out |wc -l) -gt 0 ]] && die "tests differ"
+}
+
+src_install() {
+ dobin ${PN} || die
+ newman ${PN}.cat1 ${PN}.1 || die
+ FORCE_BSD_MK=1 SYS_MK_DIR=. \
+ sh ../mk/install-mk -v -m 644 "${D}"/usr/share/mk/${PN} \
+ || die "failed to install mk files"
+}