summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-09-17 07:04:53 +0000
committerMike Frysinger <vapier@gentoo.org>2006-09-17 07:04:53 +0000
commit0d34e86099f9acf4acad1a78c6945c0ce6a61ffe (patch)
tree7316668dcac55cb98137336e6b60ce33d8a395ae /sys-devel/crossdev
parentStable on ppc64; bug #147882 (diff)
downloadgentoo-2-0d34e86099f9acf4acad1a78c6945c0ce6a61ffe.tar.gz
gentoo-2-0d34e86099f9acf4acad1a78c6945c0ce6a61ffe.tar.bz2
gentoo-2-0d34e86099f9acf4acad1a78c6945c0ce6a61ffe.zip
Add support for mingw compilers #129598.
(Portage version: 2.1.1)
Diffstat (limited to 'sys-devel/crossdev')
-rw-r--r--sys-devel/crossdev/ChangeLog8
-rw-r--r--sys-devel/crossdev/crossdev-0.9.17.ebuild20
-rwxr-xr-xsys-devel/crossdev/files/crossdev8
-rw-r--r--sys-devel/crossdev/files/digest-crossdev-0.9.171
4 files changed, 35 insertions, 2 deletions
diff --git a/sys-devel/crossdev/ChangeLog b/sys-devel/crossdev/ChangeLog
index d9c1bf5c54f3..30497bcf2cc4 100644
--- a/sys-devel/crossdev/ChangeLog
+++ b/sys-devel/crossdev/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/crossdev
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.39 2006/09/07 17:03:22 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/ChangeLog,v 1.40 2006/09/17 07:04:53 vapier Exp $
+
+*crossdev-0.9.17 (17 Sep 2006)
+
+ 17 Sep 2006; Mike Frysinger <vapier@gentoo.org> files/crossdev,
+ -crossdev-0.9.16-r2.ebuild, +crossdev-0.9.17.ebuild:
+ Add support for mingw compilers #129598.
*crossdev-0.9.16-r2 (07 Sep 2006)
diff --git a/sys-devel/crossdev/crossdev-0.9.17.ebuild b/sys-devel/crossdev/crossdev-0.9.17.ebuild
new file mode 100644
index 000000000000..a40f01b41706
--- /dev/null
+++ b/sys-devel/crossdev/crossdev-0.9.17.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/crossdev-0.9.17.ebuild,v 1.1 2006/09/17 07:04:53 vapier Exp $
+
+DESCRIPTION="Gentoo Cross-toolchain generator"
+HOMEPAGE="http://www.gentoo.org/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=sys-apps/portage-2.1
+ app-shells/bash"
+
+src_install() {
+ dosbin "${FILESDIR}"/crossdev || die
+ dosed "s:GENTOO_PV:${PV}:" /usr/sbin/crossdev
+}
diff --git a/sys-devel/crossdev/files/crossdev b/sys-devel/crossdev/files/crossdev
index b18a2e2895a5..f6be3ad42f42 100755
--- a/sys-devel/crossdev/files/crossdev
+++ b/sys-devel/crossdev/files/crossdev
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/files/crossdev,v 1.73 2006/09/07 17:03:22 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/files/crossdev,v 1.74 2006/09/17 07:04:53 vapier Exp $
cd /
@@ -117,6 +117,12 @@ parse_target() {
TARCH=${HARCH};
LPKG="uclibc";;
+ mingw*)
+ TARCH=${HARCH}; CPOST="";
+ WITH_DEF_HEADERS="yes";
+ KCAT="dev-util"; KPKG="w32api";
+ LCAT="dev-util"; LPKG="mingw-runtime";;
+
msp430)
TARCH=${HARCH}; CPOST="";
STAGE=${STAGE_BINUTILS};;
diff --git a/sys-devel/crossdev/files/digest-crossdev-0.9.17 b/sys-devel/crossdev/files/digest-crossdev-0.9.17
new file mode 100644
index 000000000000..8b137891791f
--- /dev/null
+++ b/sys-devel/crossdev/files/digest-crossdev-0.9.17
@@ -0,0 +1 @@
+