summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-03-08 23:39:39 +0000
committerMike Frysinger <vapier@gentoo.org>2005-03-08 23:39:39 +0000
commit15eb73d84d7d123519b3953008d2f3ea496ffeb9 (patch)
treeb9685bb55360e192536fc04b7bbef06d43d3e704 /sys-devel/crossdev
parentAdded a mask for >=splashutils-1.1 (diff)
downloadgentoo-2-15eb73d84d7d123519b3953008d2f3ea496ffeb9.tar.gz
gentoo-2-15eb73d84d7d123519b3953008d2f3ea496ffeb9.tar.bz2
gentoo-2-15eb73d84d7d123519b3953008d2f3ea496ffeb9.zip
add --version and `emerge info`
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-devel/crossdev')
-rw-r--r--sys-devel/crossdev/crossdev-0.9-r3.ebuild3
-rwxr-xr-xsys-devel/crossdev/files/crossdev6
2 files changed, 7 insertions, 2 deletions
diff --git a/sys-devel/crossdev/crossdev-0.9-r3.ebuild b/sys-devel/crossdev/crossdev-0.9-r3.ebuild
index c37c0b82c5ee..c0f8c4416ca4 100644
--- a/sys-devel/crossdev/crossdev-0.9-r3.ebuild
+++ b/sys-devel/crossdev/crossdev-0.9-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/crossdev-0.9-r3.ebuild,v 1.1 2005/03/04 18:59:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/crossdev-0.9-r3.ebuild,v 1.2 2005/03/08 23:39:39 vapier Exp $
DESCRIPTION="Gentoo Cross-toolchain generator"
HOMEPAGE="http://www.gentoo.org/"
@@ -17,4 +17,5 @@ RDEPEND="sys-apps/portage
src_install() {
dobin "${FILESDIR}"/crossdev || die
+ dosed ":GENTOO_PV:${PV}:" /usr/bin/crossdev
}
diff --git a/sys-devel/crossdev/files/crossdev b/sys-devel/crossdev/files/crossdev
index fc9873d20491..100f45a9c5dc 100755
--- a/sys-devel/crossdev/files/crossdev
+++ b/sys-devel/crossdev/files/crossdev
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/files/crossdev,v 1.5 2005/03/04 18:59:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/crossdev/files/crossdev,v 1.6 2005/03/08 23:39:39 vapier Exp $
source /sbin/functions.sh || exit 1
die() {
@@ -25,6 +25,8 @@ ${GOOD}Options${NORMAL}:
${GOOD}--l, --libc${NORMAL} ver Specify version of libc to use
${GOOD}-a, -b, -p, -v${NORMAL} Options to pass to emerge (see emerge(1))
+ ${GOOD}-V, --version${NORMAL} Show crossdev version
+
${GOOD}-s1, --stage1${NORMAL} Build a C compiler (no libc/C++)
${GOOD}-s2, --stage2${NORMAL} Build a C compiler & libc (no C++)
${GOOD}-s3, --stage3${NORMAL} Build a C/C++ compiler & libc [default]
@@ -104,6 +106,7 @@ LVER="[latest]"
while [[ $# -gt 0 ]] ; do
case $1 in
+ -V|--version) echo "crossdev-GENTOO_PV"; exit 0;;
-t|--target) shift; parse_target $1;;
--b|--binutils) shift; BVER=-$1;;
--g|--gcc) shift; GVER=-$1;;
@@ -156,6 +159,7 @@ einfo "PKGDIR: ${PKGDIR}"
hr
) >& ${PORT_LOGDIR}/cross-${CTARGET}-info.log
cat ${PORT_LOGDIR}/cross-${CTARGET}-info.log
+emerge info >> ${PORT_LOGDIR}/cross-${CTARGET}-info.log
#################
mkdir -p /etc/portage