summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2014-09-09 09:27:46 +0000
committerAnthony G. Basile <blueness@gentoo.org>2014-09-09 09:27:46 +0000
commit952887fb50ac8aed5ab15be8e4671ca6deb57176 (patch)
treefe32cea36d2c522b6b0c4d9da238b17c9e6dae5e /sys-devel/ct-ng
parentMarked ~hppa (bug #522284). (diff)
downloadgentoo-2-952887fb50ac8aed5ab15be8e4671ca6deb57176.tar.gz
gentoo-2-952887fb50ac8aed5ab15be8e4671ca6deb57176.tar.bz2
gentoo-2-952887fb50ac8aed5ab15be8e4671ca6deb57176.zip
Version bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'sys-devel/ct-ng')
-rw-r--r--sys-devel/ct-ng/ChangeLog7
-rw-r--r--sys-devel/ct-ng/ct-ng-1.20.0.ebuild40
2 files changed, 46 insertions, 1 deletions
diff --git a/sys-devel/ct-ng/ChangeLog b/sys-devel/ct-ng/ChangeLog
index c11bc41680f7..9e5145f08d12 100644
--- a/sys-devel/ct-ng/ChangeLog
+++ b/sys-devel/ct-ng/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/ct-ng
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/ct-ng/ChangeLog,v 1.48 2014/08/28 16:47:50 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/ct-ng/ChangeLog,v 1.49 2014/09/09 09:27:46 blueness Exp $
+
+*ct-ng-1.20.0 (09 Sep 2014)
+
+ 09 Sep 2014; Anthony G. Basile <blueness@gentoo.org> +ct-ng-1.20.0.ebuild:
+ Version bump
28 Aug 2014; Michał Górny <mgorny@gentoo.org> ct-ng-1.19.0.ebuild:
Remove unused USE=bash-completion. Install the completion file using the
diff --git a/sys-devel/ct-ng/ct-ng-1.20.0.ebuild b/sys-devel/ct-ng/ct-ng-1.20.0.ebuild
new file mode 100644
index 000000000000..5c18b0a9fb5c
--- /dev/null
+++ b/sys-devel/ct-ng/ct-ng-1.20.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/ct-ng/ct-ng-1.20.0.ebuild,v 1.1 2014/09/09 09:27:46 blueness Exp $
+
+EAPI="5"
+
+inherit autotools bash-completion-r1 eutils
+
+DESCRIPTION="crosstool-ng is a tool to build cross-compiling toolchains"
+HOMEPAGE="http://crosstool-ng.org"
+MY_P=${P/ct/crosstool}
+S=${WORKDIR}/${MY_P}
+SRC_URI="http://ymorin.is-a-geek.org/download/crosstool-ng/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="net-misc/curl
+ dev-util/gperf
+ dev-vcs/cvs
+ dev-vcs/subversion"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-kconfig-respect-flags.patch
+
+ #Upstream provides ${S}/bootstrap which runs autoconf -Wall --force
+ #We'll use eautoconf to be portage friendly
+ eautoconf -Wall --force
+}
+
+src_install() {
+ emake DESTDIR="${D%/}" install
+ newbashcomp ${PN}.comp ${PN}
+ dodoc README TODO
+ use doc && mv "${D}"/usr/share/doc/crosstool-ng/"${PN}.${PVR}"/* \
+ "${D}"/usr/share/doc/"${PF}"
+ rm -rf "${D}"/usr/share/doc/crosstool-ng
+}