summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLisa M. Seelye <lisa@gentoo.org>2003-12-25 04:37:09 +0000
committerLisa M. Seelye <lisa@gentoo.org>2003-12-25 04:37:09 +0000
commit10712195f90b5fe726ba8e830ae6a851d850d402 (patch)
tree29910e591357714feffc725e1384c4a1aa68a2d5 /sys-devel/distcc
parentVersion bump, which includes IPv6 support (shoulda been in last one, but oh w... (diff)
downloadgentoo-2-10712195f90b5fe726ba8e830ae6a851d850d402.tar.gz
gentoo-2-10712195f90b5fe726ba8e830ae6a851d850d402.tar.bz2
gentoo-2-10712195f90b5fe726ba8e830ae6a851d850d402.zip
Version bump, which includes IPv6 support (shoulda been in last one, but oh well), and a setuid patch that was posted to the distcc ml by Wayne Davison <wayned@samba.org> (this patch fixes the order in which setuid happens during daemon startup)
Diffstat (limited to 'sys-devel/distcc')
-rw-r--r--sys-devel/distcc/ChangeLog11
-rw-r--r--sys-devel/distcc/Manifest4
-rw-r--r--sys-devel/distcc/distcc-2.12.ebuild143
-rw-r--r--sys-devel/distcc/files/digest-distcc-2.121
-rw-r--r--sys-devel/distcc/files/setuid-2.12-order-fix.gzbin0 -> 405 bytes
5 files changed, 156 insertions, 3 deletions
diff --git a/sys-devel/distcc/ChangeLog b/sys-devel/distcc/ChangeLog
index 298152279814..0368245131d1 100644
--- a/sys-devel/distcc/ChangeLog
+++ b/sys-devel/distcc/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for sys-devel/distcc
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/ChangeLog,v 1.86 2003/12/11 15:51:51 pyrania Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/ChangeLog,v 1.87 2003/12/25 04:37:00 lisa Exp $
+
+*distcc-2.12 (24 Dec 2003)
+
+ 24 Dec 2003; Lisa Seelye <lisa@gentoo.org> distcc-2.12.ebuild,
+ files/setuid-2.12-order-fix.gz:
+ Version bump, which includes IPv6 support (shoulda been in last one, but oh
+ well), and a setuid patch that was posted to the distcc ml by Wayne Davison
+ <wayned@samba.org> (this patch fixes the order in which setuid happens in
+ the daemon startup)
11 Dec 2003; Markus Nigbur <pyrania@gentoo.org> files/2.11.1p/distcc-config:
Fixed distcc-config. See bug #27432 for details.
diff --git a/sys-devel/distcc/Manifest b/sys-devel/distcc/Manifest
index 875051757be5..95cf9fce5acb 100644
--- a/sys-devel/distcc/Manifest
+++ b/sys-devel/distcc/Manifest
@@ -2,11 +2,11 @@ MD5 ba434fcebbfbd2db6cdbd7527edd2080 distcc-2.11.2.ebuild 4052
MD5 16bbbf9b6b111668ff00046829e6b917 distcc-2.11.2-r1.ebuild 4051
MD5 50800c649c3587e5f0dfef810410abb6 distcc-2.8-r2.ebuild 3365
MD5 70619e7eb5fa4fd0aa4f3588579cd50d metadata.xml 443
-MD5 66a09224011772f756cfee0a3777f5f5 ChangeLog 15362
+MD5 650133eb96d46226369dd4c127bb71c1 ChangeLog 15741
MD5 6d0efb7bb3a7e30546d91844510da07d distcc-2.5-r1.ebuild 3215
MD5 730d7f375b2a94bce7d91191789c4dc5 distcc-2.9.ebuild 3455
MD5 a1b583a4f17172ee9b85bfaecb7dee21 distcc-2.11.1.ebuild 3927
-MD5 6915c8371968e19378cc611d323fc577 distcc-2.12.ebuild 4201
+MD5 b42d1ceddfceb681c333b29d97dfc335 distcc-2.12.ebuild 4333
MD5 c09d755beeab4ae675a8352f4ee04c63 files/digest-distcc-2.11.2-r1 66
MD5 86e7b8c5c35c5e34e2adfe2c55369f7a files/digest-distcc-2.11.1 66
MD5 56fd1ac60c1b8402e1632da62f32a890 files/digest-distcc-2.8-r2 63
diff --git a/sys-devel/distcc/distcc-2.12.ebuild b/sys-devel/distcc/distcc-2.12.ebuild
new file mode 100644
index 000000000000..be96a50e773a
--- /dev/null
+++ b/sys-devel/distcc/distcc-2.12.ebuild
@@ -0,0 +1,143 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/distcc-2.12.ebuild,v 1.1 2003/12/25 04:37:00 lisa Exp $
+
+inherit eutils gcc flag-o-matic
+[ `gcc-major-version` -eq 2 ] && filter-flags -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
+
+PATCHLEVEL="2.11.1p"
+
+HOMEPAGE="http://distcc.samba.org/"
+SRC_URI="http://distcc.samba.org/ftp/distcc/distcc-${PV}.tar.bz2"
+DESCRIPTION="a program to distribute compilation of C code across several machines on a network"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~arm"
+
+
+IUSE="gnome gtk selinux ipv6"
+
+
+DEPEND=">=sys-apps/portage-2.0.49-r6
+ >=sys-devel/gcc-config-1.3.1
+ sys-apps/shadow"
+
+RDEPEND="gnome? ( >=x11-libs/gtk+-2.0.0
+ >=gnome-base/libgnome-2.0.0
+ >=gnome-base/libgnomeui-2.0.0.0
+ >=gnome-base/libglade-2.0.0
+ x11-libs/pango
+ )
+ gtk? (
+ >=x11-libs/gtk+-2.0.0
+ x11-libs/pango
+ )
+ selinux? ( sec-policy/selinux-distcc )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/src
+ epatch ${FILESDIR}/setuid-2.12-order-fix.gz
+}
+
+
+src_compile() {
+ local myconf="--with-included-popt "
+ #Here we use the built in parse-options package. saves a dependancy
+
+ #not taking any chances here, guessing which takes precedence in the
+ #configure script, so we'll just make the distinction here:
+ #gnome takes precedence over gtk if both are specified (gnome pulls
+ #in gtk anyways...)
+ use gtk && ! use gnome && myconf="${myconf} --with-gtk"
+ use gtk && use gnome && myconf="${myconf} --with-gnome"
+
+ if use ipv6; then
+ ewarn "To use IPV6 you must have IPV6 compiled into your kernel"
+ ewarn "either via a module or compiled code"
+ myconf=" ${myconf} --enable-rfc2553 "
+ sleep 2s
+ fi
+
+ econf ${myconf} || die "econf ${myconf} failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D%/}" install
+
+ insinto /usr/share/doc/${PN}
+ doins "${S}/survey.txt"
+
+ exeinto /usr/bin
+ doexe "${FILESDIR}/${PATCHLEVEL}/distcc-config"
+
+ insinto /etc/conf.d
+ newins "${FILESDIR}/${PATCHLEVEL}/conf" distccd
+
+ exeinto /etc/init.d
+ newexe "${FILESDIR}/${PATCHLEVEL}/init" distccd
+
+ # create and keep the symlink dir
+ dodir /usr/lib/distcc/bin
+ keepdir /usr/lib/distcc/bin
+
+ # create the distccd pid directory
+ dodir /var/run/distccd
+ keepdir /var/run/distccd
+}
+
+pkg_preinst() {
+ # non-/ installs don't require us to do anything here
+ [ "${ROOT}" != "/" ] && return 0
+
+ # stop daemon since script is being updated
+ [ -n "$(pidof distccd)" -a -x /etc/init.d/distccd ] && \
+ /etc/init.d/distccd stop
+
+ # moved user creation and permissions to distcc-config script
+ # because of ROOT install requirements
+}
+
+pkg_postinst() {
+ # handle DISTCC_HOSTS upgrade better
+ local ENVFILE
+ ENVFILE="${ROOT}etc/env.d/02distcc"
+ [ ! -f "${ENVFILE}" ] && \
+ ENVFILE="${ROOT}etc/env.d/04distcc"
+ if [ -f "${ENVFILE}" ]
+ then
+ # save hosts to new file
+ ROOT="${ROOT}"
+ HOSTS=$(egrep '^DISTCC_HOSTS' "${ENVFILE}" | sed 's,[^=]*=,,')
+ [ ${HOSTS} ] && ${ROOT}usr/bin/distcc-config --set-hosts ${HOSTS}
+ # now remove from the file
+ grep -v 'DISTCC_HOSTS' "${ENVFILE}" > "${ENVFILE}.new"
+ mv "${ENVFILE}.new" "${ENVFILE}"
+ fi
+
+ if [ "${ROOT}" = "/" ]; then
+ einfo "Installing links to native compilers..."
+ /usr/bin/distcc-config --install
+ else
+ # distcc-config can *almost* handle ROOT installs itself
+ # but for now, but user must finsh things off
+ ewarn "*** Installation is not complete ***"
+ ewarn "You must run the following as root:"
+ ewarn " /usr/bin/distcc-config --install"
+ ewarn "after booting or chrooting into ${ROOT}"
+ fi
+ einfo "Tips on using distcc with Gentoo can be found at"
+ einfo "http://www.gentoo.org/doc/en/distcc.xml"
+ ewarn "As of distcc-2.11, the only thing you have to do to configure distcc"
+ ewarn "is to set your hosts (see the Guide, above) and to add distcc to"
+ ewarn "the FEATURES line in /etc/make.conf"
+ ewarn "This version is using a new distcc-config. If you encounter problems with it"
+ ewarn "Please report errors to bug 27432 on the bugs.gentoo.org site"
+ echo ""
+ einfo "To use the distccmon programs with Gentoo you should use this command:"
+ einfo " DISTCC_DIR=/var/tmp/portage/.distcc distccmon-text N"
+ use gnome || use gtk && einfo "Or: DISTCC_DIR=/var/tmp/portage/.distcc distccmon-gnome"
+ sleep 10
+}
diff --git a/sys-devel/distcc/files/digest-distcc-2.12 b/sys-devel/distcc/files/digest-distcc-2.12
new file mode 100644
index 000000000000..6d38656e45fe
--- /dev/null
+++ b/sys-devel/distcc/files/digest-distcc-2.12
@@ -0,0 +1 @@
+MD5 f258778811c8610453471ea89faeaac6 distcc-2.12.tar.bz2 323723
diff --git a/sys-devel/distcc/files/setuid-2.12-order-fix.gz b/sys-devel/distcc/files/setuid-2.12-order-fix.gz
new file mode 100644
index 000000000000..93578a57c07c
--- /dev/null
+++ b/sys-devel/distcc/files/setuid-2.12-order-fix.gz
Binary files differ