summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-11-21 01:12:11 +0000
committerMike Frysinger <vapier@gentoo.org>2005-11-21 01:12:11 +0000
commit6229669e07d0c09e49e231dc17c953d0519acda1 (patch)
tree27d062c876c377394fe472843de2fb1991cfe399 /sys-devel/gcc
parent+sys-devel/gcc:mudflap (diff)
downloadgentoo-2-6229669e07d0c09e49e231dc17c953d0519acda1.tar.gz
gentoo-2-6229669e07d0c09e49e231dc17c953d0519acda1.tar.bz2
gentoo-2-6229669e07d0c09e49e231dc17c953d0519acda1.zip
tighten up depends on glibc when dealing with cross-compilers
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'sys-devel/gcc')
-rw-r--r--sys-devel/gcc/gcc-4.0.1.ebuild15
-rw-r--r--sys-devel/gcc/gcc-4.0.2-r1.ebuild10
-rw-r--r--sys-devel/gcc/gcc-4.1.0_beta20051112.ebuild15
3 files changed, 15 insertions, 25 deletions
diff --git a/sys-devel/gcc/gcc-4.0.1.ebuild b/sys-devel/gcc/gcc-4.0.1.ebuild
index 9704e2737e84..aa1671be652d 100644
--- a/sys-devel/gcc/gcc-4.0.1.ebuild
+++ b/sys-devel/gcc/gcc-4.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.0.1.ebuild,v 1.9 2005/11/13 22:03:06 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.0.1.ebuild,v 1.10 2005/11/21 01:12:11 vapier Exp $
PATCH_VER="1.0"
PATCH_GCC_VER="4.0.1"
@@ -25,11 +25,9 @@ HOMEPAGE="http://www.gnu.org/software/gcc/gcc.html"
LICENSE="GPL-2 LGPL-2.1"
KEYWORDS="-*"
-RDEPEND="virtual/libc
+RDEPEND="!sys-devel/hardened-gcc
|| ( app-admin/eselect-compiler >=sys-devel/gcc-config-1.3.10 )
>=sys-libs/zlib-1.1.4
- !sys-devel/hardened-gcc
- elibc_glibc? ( >=sys-libs/glibc-2.3.6 )
amd64? ( multilib? ( >=app-emulation/emul-linux-x86-glibc-1.1 ) )
fortran? (
dev-libs/gmp
@@ -43,16 +41,13 @@ RDEPEND="virtual/libc
>=sys-libs/ncurses-5.2-r2
nls? ( sys-devel/gettext )
)"
-
-
-if [[ ${CATEGORY/cross-} != ${CATEGORY} ]]; then
- RDEPEND="${RDEPEND} ${CATEGORY}/binutils"
+if [[ ${CATEGORY} != cross-* ]] ; then
+ RDEPEND="${RDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.3.6 )"
fi
-
DEPEND="${RDEPEND}
>=sys-apps/texinfo-4.2-r4
>=sys-devel/bison-1.875
- >=sys-devel/binutils-2.15.97"
+ >=${CATEGORY}/binutils-2.16.1"
PDEPEND="|| ( app-admin/eselect-compiler sys-devel/gcc-config )
x86? ( !nocxx? ( !elibc_uclibc? ( !build? ( || ( sys-libs/libstdc++-v3 =sys-devel/gcc-3.3* ) ) ) ) )"
diff --git a/sys-devel/gcc/gcc-4.0.2-r1.ebuild b/sys-devel/gcc/gcc-4.0.2-r1.ebuild
index 2e9936a1436d..801ac8c21220 100644
--- a/sys-devel/gcc/gcc-4.0.2-r1.ebuild
+++ b/sys-devel/gcc/gcc-4.0.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.0.2-r1.ebuild,v 1.10 2005/11/13 22:03:06 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.0.2-r1.ebuild,v 1.11 2005/11/21 01:12:11 vapier Exp $
PATCH_VER="1.2"
PATCH_GCC_VER="4.0.2"
@@ -29,11 +29,9 @@ HOMEPAGE="http://www.gnu.org/software/gcc/gcc.html"
LICENSE="GPL-2 LGPL-2.1"
KEYWORDS="-*"
-RDEPEND="virtual/libc
+RDEPEND="!sys-devel/hardened-gcc
|| ( app-admin/eselect-compiler >=sys-devel/gcc-config-1.3.10 )
>=sys-libs/zlib-1.1.4
- !sys-devel/hardened-gcc
- elibc_glibc? ( >=sys-libs/glibc-2.3.6 )
amd64? ( multilib? ( >=app-emulation/emul-linux-x86-glibc-1.1 ) )
fortran? (
dev-libs/gmp
@@ -47,7 +45,9 @@ RDEPEND="virtual/libc
>=sys-libs/ncurses-5.2-r2
nls? ( sys-devel/gettext )
)"
-
+if [[ ${CATEGORY} != cross-* ]] ; then
+ RDEPEND="${RDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.3.6 )"
+fi
DEPEND="${RDEPEND}
>=sys-apps/texinfo-4.2-r4
>=sys-devel/bison-1.875
diff --git a/sys-devel/gcc/gcc-4.1.0_beta20051112.ebuild b/sys-devel/gcc/gcc-4.1.0_beta20051112.ebuild
index 394c436b20df..4258b3ccb6f6 100644
--- a/sys-devel/gcc/gcc-4.1.0_beta20051112.ebuild
+++ b/sys-devel/gcc/gcc-4.1.0_beta20051112.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.1.0_beta20051112.ebuild,v 1.2 2005/11/13 22:03:06 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.1.0_beta20051112.ebuild,v 1.3 2005/11/21 01:12:11 vapier Exp $
ETYPE="gcc-compiler"
@@ -12,11 +12,9 @@ HOMEPAGE="http://www.gnu.org/software/gcc/gcc.html"
LICENSE="GPL-2 LGPL-2.1"
KEYWORDS="-*"
-RDEPEND="virtual/libc
+RDEPEND="!sys-devel/hardened-gcc
|| ( app-admin/eselect-compiler >=sys-devel/gcc-config-1.3.10 )
>=sys-libs/zlib-1.1.4
- !sys-devel/hardened-gcc
- elibc_glibc? ( >=sys-libs/glibc-2.3.6 )
amd64? ( multilib? ( >=app-emulation/emul-linux-x86-glibc-1.1 ) )
fortran? (
dev-libs/gmp
@@ -30,16 +28,13 @@ RDEPEND="virtual/libc
>=sys-libs/ncurses-5.2-r2
nls? ( sys-devel/gettext )
)"
-
-
-if [[ ${CATEGORY/cross-} != ${CATEGORY} ]]; then
- RDEPEND="${RDEPEND} ${CATEGORY}/binutils"
+if [[ ${CATEGORY} != cross-* ]] ; then
+ RDEPEND="${RDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.3.6 )"
fi
-
DEPEND="${RDEPEND}
>=sys-apps/texinfo-4.2-r4
>=sys-devel/bison-1.875
- >=sys-devel/binutils-2.15.97"
+ >=${CATEGORY}/binutils-2.16.1"
PDEPEND="|| ( app-admin/eselect-compiler sys-devel/gcc-config )
x86? ( !nocxx? ( !elibc_uclibc? ( !build? ( || ( sys-libs/libstdc++-v3 =sys-devel/gcc-3.3* ) ) ) ) )"