summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-09-25 13:28:17 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-09-25 13:28:17 +0000
commit995f0010e6223714c78ccaf62932d3e52d644054 (patch)
tree977600b15ac15107f8019df0ed73e91746d9075e /sys-devel/icecream
parentUpdate ebuild to pass under both -java and +java cases. (diff)
downloadgentoo-2-995f0010e6223714c78ccaf62932d3e52d644054.tar.gz
gentoo-2-995f0010e6223714c78ccaf62932d3e52d644054.tar.bz2
gentoo-2-995f0010e6223714c78ccaf62932d3e52d644054.zip
Bump to latest. Fixes gcc-4.6 issues.
(Portage version: 2.2.0_alpha59/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/icecream')
-rw-r--r--sys-devel/icecream/ChangeLog9
-rw-r--r--sys-devel/icecream/icecream-0.9.7.ebuild85
2 files changed, 92 insertions, 2 deletions
diff --git a/sys-devel/icecream/ChangeLog b/sys-devel/icecream/ChangeLog
index 19aadb9c6196..b417a7082585 100644
--- a/sys-devel/icecream/ChangeLog
+++ b/sys-devel/icecream/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/icecream
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/icecream/ChangeLog,v 1.39 2010/09/18 10:24:22 scarabeus Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/icecream/ChangeLog,v 1.40 2011/09/25 13:28:17 scarabeus Exp $
+
+*icecream-0.9.7 (25 Sep 2011)
+
+ 25 Sep 2011; Tomáš Chvátal <scarabeus@gentoo.org> +icecream-0.9.7.ebuild:
+ Bump to latest. Fixes gcc-4.6 issues.
*icecream-0.9.6-r1 (18 Sep 2010)
diff --git a/sys-devel/icecream/icecream-0.9.7.ebuild b/sys-devel/icecream/icecream-0.9.7.ebuild
new file mode 100644
index 000000000000..f7d49a0ea09f
--- /dev/null
+++ b/sys-devel/icecream/icecream-0.9.7.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/icecream/icecream-0.9.7.ebuild,v 1.1 2011/09/25 13:28:17 scarabeus Exp $
+
+EAPI=4
+
+inherit base autotools
+
+MY_P="icecc-${PV}"
+
+DESCRIPTION="icecc is a program for distributed compiling of C(++) code across several machines; based on distcc"
+HOMEPAGE="http://en.opensuse.org/Icecream"
+SRC_URI="ftp://ftp.suse.com/pub/projects/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}/0.9.6-symlinks.patch"
+ "${FILESDIR}/0.9.6-crosscompile.patch"
+ "${FILESDIR}/${PN}-conf.d-verbosity.patch"
+ "${FILESDIR}/${PN}-gentoo-multilib.patch"
+)
+
+pkg_setup() {
+ enewgroup icecream
+ enewuser icecream -1 -1 /var/cache/icecream icecream
+}
+
+src_prepare() {
+ base_src_prepare
+
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ dosbin "${FILESDIR}"/icecream-config
+ dosbin "${FILESDIR}"/icecream-create-env
+
+ newconfd suse/sysconfig.icecream icecream
+ doinitd "${FILESDIR}"/icecream
+
+ diropts -m0755
+ keepdir /usr/lib/icecc/bin
+}
+
+pkg_postinst() {
+ ebegin "Scanning for compiler front-ends..."
+ /usr/sbin/icecream-config --install-links
+ /usr/sbin/icecream-config --install-links "${CHOST}"
+ eend ${?}
+
+ elog
+ elog "If you have compiled binutils/gcc/glibc with processor-specific flags"
+ elog "(as normal using Gentoo), there is a greater chance that your compiler"
+ elog "won't work on other machines. The best would be to build gcc, glibc and"
+ elog "binutils without those flags and then copy the needed files into your"
+ elog "tarball for distribution to other machines. This tarball can be created"
+ elog "by running /usr/bin/icecc --build-native, and used by setting"
+ elog "ICECC_VERSION in /etc/conf.d/icecream"
+ elog ' ICECC_VERSION=<filename_of_archive_containing_your_environment>'
+ elog
+ elog "To use icecream with portage add the following line to /etc/make.conf"
+ elog ' PREROOTPATH=/usr/lib/icecc/bin'
+ elog
+ elog "To use icecream with normal make use (e.g. in /etc/profile)"
+ elog ' PATH=/usr/lib/icecc/bin:$PATH'
+ elog
+ elog "N.B. To use icecream with ccache, the ccache PATH should come first:"
+ elog ' PATH=/usr/lib/ccache/bin:/usr/lib/icecc/bin:$PATH'
+ elog
+ elog "Don't forget to open the following ports in your firewall(s):"
+ elog " TCP/10245 on the daemon computers (required)"
+ elog " TCP/8765 for the the scheduler computer (required)"
+ elog " TCP/8766 for the telnet interface to the scheduler (optional)"
+ elog " UDP/8765 for broadcast to find the scheduler (optional)"
+ elog
+ elog "Further usage instructions: ${HOMEPAGE}"
+}