summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2008-10-26 18:54:43 +0000
committerJoshua Kinard <kumba@gentoo.org>2008-10-26 18:54:43 +0000
commit53a1381d0a6f2b8a8132bbe13c55b1bc2d6feeb3 (patch)
tree698939461067b25a90bf3470f4cf847d0c676166 /sys-devel/kgcc64
parentamd64/x86 stable, bug #244252 (diff)
downloadgentoo-2-53a1381d0a6f2b8a8132bbe13c55b1bc2d6feeb3.tar.gz
gentoo-2-53a1381d0a6f2b8a8132bbe13c55b1bc2d6feeb3.tar.bz2
gentoo-2-53a1381d0a6f2b8a8132bbe13c55b1bc2d6feeb3.zip
Add ebuild for kgcc64-4.3.2 cross-compiler.
(Portage version: 2.2_rc12/cvs/Linux 2.6.27-mipsgit-20081010 mips64)
Diffstat (limited to 'sys-devel/kgcc64')
-rw-r--r--sys-devel/kgcc64/ChangeLog7
-rw-r--r--sys-devel/kgcc64/kgcc64-4.3.2.ebuild45
2 files changed, 51 insertions, 1 deletions
diff --git a/sys-devel/kgcc64/ChangeLog b/sys-devel/kgcc64/ChangeLog
index ec8b3ae63308..402fc32171ea 100644
--- a/sys-devel/kgcc64/ChangeLog
+++ b/sys-devel/kgcc64/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/kgcc64
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/ChangeLog,v 1.20 2008/08/04 04:48:56 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/ChangeLog,v 1.21 2008/10/26 18:54:43 kumba Exp $
+
+*kgcc64-4.3.2 (26 Oct 2008)
+
+ 26 Oct 2008; Joshua Kinard <kumba@gentoo.org> +kgcc64-4.3.2.ebuild:
+ Add ebuild for kgcc64-4.3.2 cross-compiler.
04 Aug 2008; Mark Loeser <halcy0n@gentoo.org> Manifest:
Manifest out of date due to changes to toolchain eclass for gcj fixes
diff --git a/sys-devel/kgcc64/kgcc64-4.3.2.ebuild b/sys-devel/kgcc64/kgcc64-4.3.2.ebuild
new file mode 100644
index 000000000000..c07018628d03
--- /dev/null
+++ b/sys-devel/kgcc64/kgcc64-4.3.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/kgcc64/kgcc64-4.3.2.ebuild,v 1.1 2008/10/26 18:54:43 kumba Exp $
+
+case ${CHOST} in
+ hppa*) CTARGET=hppa64-${CHOST#*-};;
+ mips*) CTARGET=${CHOST/mips/mips64};;
+ powerpc*) CTARGET=${CHOST/powerpc/powerpc64};;
+ s390*) CTARGET=${CHOST/s390/s390x};;
+ sparc*) CTARGET=${CHOST/sparc/sparc64};;
+ i?86*) CTARGET=x86_64-${CHOST#*-};;
+esac
+export CTARGET
+TOOLCHAIN_ALLOWED_LANGS="c"
+GCC_TARGET_NO_MULTILIB=true
+
+PATCH_VER="1.1"
+ETYPE="gcc-compiler"
+GCC_FILESDIR=${FILESDIR/${PN}/gcc}
+
+inherit toolchain eutils
+
+DESCRIPTION="64bit kernel compiler"
+
+KEYWORDS="" #228115
+
+# unlike every other target, hppa has not unified the 32/64 bit
+# ports in binutils yet
+DEPEND="hppa? ( sys-devel/binutils-hppa64 )
+ !sys-devel/gcc-hppa64
+ !sys-devel/gcc-mips64
+ !sys-devel/gcc-powerpc64
+ !sys-devel/gcc-sparc64"
+
+pkg_postinst() {
+ cd "${ROOT}"/usr/bin
+ local x
+ for x in gcc cpp ; do
+ cat <<-EOF >${CTARGET%%-*}-linux-${x}
+ #!/bin/sh
+ exec ${CTARGET}-${x} "\$@"
+ EOF
+ chmod a+rx ${CTARGET%%-*}-linux-${x}
+ done
+}