summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2005-08-14 15:45:53 +0000
committerMichael Cummings <mcummings@gentoo.org>2005-08-14 15:45:53 +0000
commit5221c8c6b40bc9af4e1aa2dd7fb75fc909108411 (patch)
tree4259457fddfb6e84b2c5877669224267a0f52d2a /sys-devel/libperl
parenttrailing space, manifest rebuild (diff)
downloadgentoo-2-5221c8c6b40bc9af4e1aa2dd7fb75fc909108411.tar.gz
gentoo-2-5221c8c6b40bc9af4e1aa2dd7fb75fc909108411.tar.bz2
gentoo-2-5221c8c6b40bc9af4e1aa2dd7fb75fc909108411.zip
The rest of the patch for bug 58931
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'sys-devel/libperl')
-rw-r--r--sys-devel/libperl/ChangeLog5
-rw-r--r--sys-devel/libperl/libperl-5.8.7.ebuild10
2 files changed, 9 insertions, 6 deletions
diff --git a/sys-devel/libperl/ChangeLog b/sys-devel/libperl/ChangeLog
index 271a6e562098..a9e3924b6318 100644
--- a/sys-devel/libperl/ChangeLog
+++ b/sys-devel/libperl/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-devel/libperl
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/ChangeLog,v 1.78 2005/08/14 15:37:34 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/ChangeLog,v 1.79 2005/08/14 15:42:37 mcummings Exp $
+
+ 14 Aug 2005; Michael Cummings <mcummings@gentoo.org> libperl-5.8.7.ebuild:
+ The rest of the patch for bug 58931
14 Aug 2005; Michael Cummings <mcummings@gentoo.org> libperl-5.8.7.ebuild:
Bug #58931, more userland darwin
diff --git a/sys-devel/libperl/libperl-5.8.7.ebuild b/sys-devel/libperl/libperl-5.8.7.ebuild
index 65ac65763093..9eb1d01a394a 100644
--- a/sys-devel/libperl/libperl-5.8.7.ebuild
+++ b/sys-devel/libperl/libperl-5.8.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.7.ebuild,v 1.9 2005/08/14 15:38:08 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.7.ebuild,v 1.10 2005/08/14 15:42:37 mcummings Exp $
# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
#
@@ -332,12 +332,12 @@ pkg_postinst() {
# Next bit is to try and setup the /usr/lib/libperl.so symlink
# properly ...
- local libnumber="`ls -1 ${ROOT}usr/$(get_libdir)/libperl$(get_libname).?.* | grep -v '\.old' | wc -l`"
+ local libnumber="`ls -1 ${ROOT}usr/$(get_libdir)/libperl$(get_libname ?.*) | grep -v '\.old' | wc -l`"
if [ "${libnumber}" -eq 1 ]
then
# Only this version of libperl is installed, so just link libperl.so
# to the *soname* version of it ...
- ln -snf libperl$(get_libname).${PERLSLOT} ${ROOT}usr/$(get_libdir)/libperl$(get_libname)
+ ln -snf libperl$(get_libname ${PERLSLOT}) ${ROOT}usr/$(get_libdir)/libperl$(get_libname)
else
if [ -x "${ROOT}/usr/bin/perl" ]
then
@@ -348,13 +348,13 @@ pkg_postinst() {
cd ${ROOT}usr/$(get_libdir)
# Link libperl.so to the *soname* versioned lib ...
- ln -snf `echo libperl$(get_libname).?.${perlversion} | cut -d. -f1,2,3` libperl$(get_libname)
+ ln -snf `echo libperl$(get_libname ?.${perlversion}) | cut -d. -f1,2,3` libperl$(get_libname)
else
local x latest
# Nope, we are not so lucky ... try to figure out what version
# is the latest, and keep fingers crossed ...
- for x in `ls -1 ${ROOT}usr/$(get_libdir)/libperl$(get_libname).?.*`
+ for x in `ls -1 ${ROOT}usr/$(get_libdir)/libperl$(get_libname ?.*)`
do
latest="${x}"
done